最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信股票公式:统一MACD指标

通达信股票公式:统一MACD指标

来源:网络 点击: 时间:2019-02-21

  通达信股票公式有哪些?通达信股票公式是什么?下面股票知识网为您介绍:通达信股票公式。

SH:=12;LO:=26;M:=9;
DA:=IF(DATE<1070531,1,0);
DJ:=MINUTE-REF(MINUTE,1);
SJ1:=HHV(HOUR-REF(HOUR,1),5);
SJ2:=LLV(HOUR-REF(HOUR,1),5);
KJ:=IF(DJ=5 OR DJ=-55 OR DJ=-25 OR DJ=35,5,
IF(DJ=-15 OR DJ=-45 OR DJ=15 OR DJ=45,15,
IF(LLV(DJ,80)=0 AND SJ1=0,240,
IF((DJ=0 OR DJ=-30 OR DJ=30) AND SJ1<3 AND SJ2<=0,30,
IF(LLV(DJ,3)=1 OR HHV(DJ,3)=1,1,60)))));
DIF:(EMA(CLOSE,SH)-EMA(CLOSE,LO))/EMA(CLOSE,LO)*1000,COLORGREEN;
DEA:EMA(DIF,M);
MACD:(DIF-DEA)*2,COLORSTICK;
JB:=(LO-SH)*KJ/(14*240);
BD:=(MACD-LLV(REF(MACD,1),2))/ABS(REF(DIF,1))/2;
该期增减:IF(BD>10,10,IF(BD<-10,-10,BD)),LINETHICK0;
L1:IF(DA=1 AND DIF>0,PLOYLINE(DIF>0,DIF),DRAWNULL),COLORWHITE;
L2:IF(DA=1 AND DIF>10*JB,PLOYLINE(DIF>10*JB,DIF),DRAWNULL),COLORRED;
L3:IF(DA=1 AND DIF>50*JB,PLOYLINE(DIF>50*JB,DIF),DRAWNULL),COLORMAGENTA;
MD:=MAX(MAX(DIF,DEA),MACD);
MX:=MIN(MIN(DIF,DEA),MACD);
MDC:=HHV(MD,50);
MXC:=LLV(MX,50);
DX:=MDC-MXC;
YS:=IF(DIF>50*JB,'强得发紫',
IF(DIF>10*JB AND DIF<50*JB,'多头区',
IF(DIF>0 AND DIF<10*JB,'多头观望',
IF(DIF<0,'空头区',DRAWNULL))));
DRAWTEXT(DA=1 AND CURRBARSCOUNT=1 AND DIF>50*JB,MXC+0.6*DX,YS),COLORMAGENTA;
DRAWTEXT(DA=1 AND CURRBARSCOUNT=1 AND DIF>10*JB AND DIF<50*JB,MXC+0.6*DX,YS),COLORRED;
DRAWTEXT(DA=1 AND CURRBARSCOUNT=1 AND DIF>0 AND DIF<10*JB,MXC+0.6*DX,YS),COLORWHITE;
DRAWTEXT(DA=1 AND CURRBARSCOUNT=1 AND DIF<0,MXC+0.6*DX,YS),COLORGREEN;
DRAWTEXT(DA=1 AND DIF>0 AND DIF>DEA AND CURRBARSCOUNT=1,MXC+0.5*DX,'上升通道持续(参数③周期)');
DRAWTEXT(DA=1 AND DIF>0 AND DIF DRAWTEXT(DA=1 AND DIF<0 AND DIF>DEA AND CURRBARSCOUNT=1,MXC+0.5*DX,'下降通道趋缓(参数③周期)');
DRAWTEXT(CURRBARSCOUNT=1,MXC+0.8*DX,'MACD庞辉V2.0大众版请阅用法注释'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,MXC+0.4*DX,'SHOP34328852.TAOBAO.COM'),COLORMAGENTA;
{DRAWTEXT(CURRBARSCOUNT=1 AND MACD>=LLV(REF(MACD,1),2),MXC+0.6*DX,
' 增强'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1 AND MACD ' 减弱'),COLORGREEN;};

更多通达信股票公式知识请关注股票知识网

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top