最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 今日通达信股票公式:六脉神剑源码图

今日通达信股票公式:六脉神剑源码图

来源:网络 点击: 时间:2019-05-25

www.igojr.com带来今日通达信股票公式:六脉神剑源码图。

  六脉神剑源码图

  {N1=1;N2=5;N3=9;N4=13;N5=21;N6=34}

  DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);

  DEA:=EMA(DIFF,N2);

  DRAWICON(DIFF》DEA,1,1);

  DRAWICON(DIFF《DEA,1,2);

  {DRAWTEXT(ISLASTBAR=1,1,‘.MACD’),COLORFFFFFF;}

  A1:=DIFF》DEA;

  RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;

  K:=SMA(RSV1,N1,1);

  D:=SMA(K,N1,1);

  DRAWICON(K》D,1.1,1);

  DRAWICON(K《D,1.1,2);

  {DRAWTEXT(ISLASTBAR=1,1.1,‘.KDJ’),COLORFFFFFF;}

  A2:=K》D;

  LC:=REF(CLOSE,1);

  RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;

  RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;

  DRAWICON(RSI1》RSI2,1.2,1);

  DRAWICON(RSI1《RSI2,1.2,2);

  {DRAWTEXT(ISLASTBAR=1,1.2,‘.RSI’),COLORFFFFFF;}

  A3:=RSI1》RSI2;

  RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;

  LWR1:=SMA(RSV,N1,1);

  LWR2:=SMA(LWR1,N1,1);

  DRAWICON(LWR1》LWR2,1.3,1);

  DRAWICON(LWR1《LWR2,1.3,2);

  {DRAWTEXT(ISLASTBAR=1,1.3,‘.LW&R’),COLORFFFFFF;}

  A4:=LWR1》LWR2;

  BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;

  DRAWICON(CLOSE》BBI,1.4,1);

  DRAWICON(CLOSE《BBI,1.4,2);

  {DRAWTEXT(ISLASTBAR=1,1.4,‘.BBI’),COLORFFFFFF;}

  A5:=CLOSE》BBI;

  MTM:=CLOSE-REF(CLOSE,1);

  MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);

  MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);

  DRAWICON(MMS》MMM,1.5,1);

  DRAWICON(MMS《MMM,1.5,2);

  {DRAWTEXT(ISLASTBAR=1,1.5,‘.ZLMM’),COLORFFFFFF;}

  A6:=MMS》MMM;

  BIAS:=(C-MA(C,N2))/MA(C,N2);

  DIF:=(BIAS-REF(BIAS,16));

  DBCD:=SMA(DIF,76,1);

  MM:=MA(DBCD,5);

  DRAWICON(DBCD》MM ,1.6,1);

  DRAWICON(DBCD《MM,1.6,2);

  {DRAWTEXT(ISLASTBAR=1,1.6,‘.DBCD’),COLORFFFFFF;}

  A7:=DBCD》MM;

  持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0,COLORRED;

  支撑:=LLV(持股,3),LINETHICK0,COLOR00FFFF;

  下跌:=MA(持股,12),COLOR6B8E23,LINETHICK0;

  转向:=CROSS(持股,下跌){ AND 下跌《30};

  MA1:=MA(持股,5);

  向下:=CROSS(MA1,持股) AND MA1》80;

  DRAWICON(持股》下跌 ,1.7,1);

  DRAWICON(持股《下跌,1.7,2);

  {DRAWTEXT(ISLASTBAR=1,1.7,‘.CGZ’),COLORFFFFFF;}

  A8:=持股》下跌;

  MT:=C-REF(C,1);

  ZLGJ:=100*EMA(EMA(MT,N3),N3)/EMA(EMA(ABS(MT),N3),N3);

  MAZL:=MA(ZLGJ,5);

  DRAWICON(ZLGJ》MAZL,1.8,1);

  DRAWICON(ZLGJ《MAZL,1.8,2);

  A9:=ZLGJ》MAZL;

  {DRAWTEXT(ISLASTBAR=1,1.8,‘.ZLGJ’),COLORFFFFFF;}

  PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);

  JJ:=REF(EMA(PJJ,3),1);

  QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

  XVL:=IF(CLOSE》OPEN,QJJ*(HIGH-LOW),IF(CLOSE《OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE》OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE《OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));

  HSL:=(XVL/20)/1.15;

  攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));

  GJJ:=EMA(攻击流量,8);

  LLJX:=EMA(攻击流量,3);

  资金流量:=LLJX,LINETHICK0,COLOR0000FF;

  DRAWICON(资金流量》0,1.95,1);

  DRAWICON(资金流量《0,1.95,2);

  A10:=资金流量》0;

  {DRAWTEXT(ISLASTBAR=1,1.89,‘.ZJL’),COLORFFFFFF;}

  指导线:=(A1+A2+A3+A4+A5+A6+A7+A8+A9+A10),LINETHICK0,COLORFFFF00;

  操作:IF(指导线 》6 ,1.1,1),LINETHICK3,COLORYELLOW;

  更多通达信股票公式,请关注www.igojr.com。

?



标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top