最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 今日通达信股票指标公式:通达信RSI+MACD指标公式

今日通达信股票指标公式:通达信RSI+MACD指标公式

来源:网络 点击: 时间:2019-03-23

今日通达信股票指标公式:通达信RSI+MACD指标公式 www.igojr.com小编为您提供

?

?

?LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;

RSIE:=EMA(RSI,3);

DIFF : EMA(RSIE,12) - EMA(RSIE,26);

BBDIFF:=DIFF-REF(DIFF,1);

DEA ?: EMA(DIFF,9);

DRAWBAND(DIFF,RGB(255,105,180),DEA,RGB(34,139,34));

BBDEA:=DEA-REF(DEA,1);

MACD : 2*(DIFF-DEA), COLORSTICK;

STICKLINE(MACD0,0,MACD,2,0),COLORFFFF00;

STICKLINE(MACD

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0),COLOR0099FF;

STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,2,0),COLORRED;

0,COLORFF8855,LINETHICK2;

IF(DIFF>DEA,DIFF,DRAWNULL),COLORRED,LINETHICK2;

IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA;

DRAWICON(CROSS(DIFF,DEA),DEA,1);

DRAWICON(CROSS(DEA,DIFF),DEA,2);

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,0,-1.5,2,0),COLORFFFF00;

DRAWTEXT(低位金叉,-1.5, '低位金叉'),COLORFFFF00;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,-1,5,0),COLORFF00FF;

DRAWICON(二次金叉,DEA*1.2,11) ;

DRAWTEXT(二次金叉,-1, '二次金叉'),COLORFF00FF;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,1.5,3,0),COLOR00FF00;

DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;

DRAWTEXT(底背离,2, '底背离'),COLOR00FF00;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);

STICKLINE(顶背离,0,2,3,0),COLORFF8855;

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFF8855,LINETHICK2;

DRAWTEXT(顶背离,2, '顶背离'),COLORFF8855;

?

更多通达信股票指标公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top