最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 今日通达信股票指标公式:通达信牛熊三宝主图公式源码

今日通达信股票指标公式:通达信牛熊三宝主图公式源码

来源:网络 点击: 时间:2019-02-27

今日通达信股票指标公式:通达信牛熊三宝主图公式源码 www.igojr.com小编为您提供

?

P:=30;N:=8;
线A1:=(MA(CLOSE,5)+MA(CLOSE,10)+MA(CLOSE,25))/3;
线A2:=(MA(CLOSE,5)+MA(CLOSE,10)+MA(CLOSE,20)+MA(CLOSE,30)+MA(CLOSE,60)+MA(CLOSE,120))/6;
线A3:=(MA(CLOSE,20)+MA(CLOSE,60)+MA(CLOSE,120))/3;
线A4:=(MA(CLOSE,13)+MA(CLOSE,34)+MA(CLOSE,55))/3;
?STICKLINE(线A1>线A4,线A1,线A4,0.1,1),COLORFF0080;
?STICKLINE(线A1<线A4,线A1,线A4,0.1,1),COLOR00FF00;
?STICKLINE(C>O OR (C=O AND C>REF(C,1)),H,L,0.1,0),COLORRED;
?STICKLINE(C>O OR (C=O AND C>REF(C,1)),O,C,4,1),COLORRED;
?STICKLINE(C ?STICKLINE(C ?DRAWICON(CROSS(线A1,线A4),线A1,1);
线:IF(线A1<线A3,线A1,线A3),COLOR00FF00;
?IF(线A1<线A3,线A3,线A1),COLORRED;
?HV1:=REF(H,P)=HHV(H,2*P+1);
?HV2:=FILTER(HV1,P);
?HV3:=BACKSET(HV2,P+1);
?HV4:=FILTER(HV3,P);
?R11:=BACKSET(ISLASTBAR,BARSLAST(HV4)+1);
?S11:=R11>REF(R11,1);
?BOH:DRAWLINE(HV4,H,S11,H,1),COLORBLUE;
?AA2:=REF(L,P)=LLV(L,2*P+1);
?BB2:=FILTER(AA2,P);
?CC2:=BACKSET(BB2,P+1);
?DD2:=FILTER(CC2,P);
?T11:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
?U11:=T11>REF(T11,1);
?BOL:DRAWLINE(DD2,L,U11,L,1),COLOR00FFFF;

BOV:=L<=BOL AND C>BOL;
?M:=INTPART(3*N/5);
?AAA:=REF(H,M)=HHV(H,2*M+1);
?QYY:=BACKSET(AAA,M+1);
?CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);
?DDDD:=BARSLAST(CCC),NODRAW;
?GDTSS:=IF(CCC,CURRBARSCOUNT,0);
?DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);
?GDCS11:=CONST(DINGBUTSS);
?DINGBUTS11:=REF(DINGBUTSS,DDDD+1);
?GDCS22:=CONST(DINGBUTS11);
?AA11:=REF(L,M)=LLV(L,2*M+1);
?QY11:=BACKSET(AA11,M+1);
?CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);
?DD11:=BARSLAST(CC11);
?DDTSS:=IF(CC11,CURRBARSCOUNT,0);
?DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);
?DDCS11:=CONST(DDTS11);
?DDTS22:=REF(DDTS11,DD11+1);
?DDCS22:=CONST(DDTS22);
线1:DRAWLINE(CURRBARSCOUNT=GDCS22,H,CURRBARSCOUNT=GDCS11,H,1),COLORFFAA99,LINETHICK1;
线2:DRAWLINE(CURRBARSCOUNT=DDCS22,L,CURRBARSCOUNT=DDCS11,L,1) COLOR9966FF,LINETHICK1;
卖出:H>=线1 AND REF(H<线1,1),COLOR00FFFF,NODRAW;
?STICKLINE(卖出,O,C,3,0),COLOR00FFFF;

?

?

更多通达信股票指标公式相关资讯请关注www.igojr.com


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top