最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 有什么股票选股公式?通达信KDJ+MACD+RSI背离主图指标公式

有什么股票选股公式?通达信KDJ+MACD+RSI背离主图指标公式

来源:网络 点击: 时间:2019-02-23

有什么股票选股公式通达信KDJ+MACD+RSI背离主图指标公式 ?www.igojr.com小编为您提供

?

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1) A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)DIFF AND CROSS(DEA,DIFF);
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
MACD底背:=IF(B1>0,-0.1,0),COLORRED,POINTDOT;
KDJ底背:=IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;
RSI底背:=IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;
MACD顶背:=IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;
KDJ顶背:=IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;
RSI顶背:=IF(D3>0,0.1,0),COLORWHITE,POINTDOT;
DRAWTEXT(FILTER(B1>0,5),L-0.38,'MACD底背'),COLORGREEN;
DRAWTEXT(FILTER(B2>0,5),L-0.39,'KDJ底背'),COLORYELLOW;
DRAWTEXT(FILTER(B3>0,5),L,'RSI底背'),COLORCYAN;
DRAWTEXT(FILTER(D1>0,5),L+0.08,'MACD顶背'),COLORWHITE;
DRAWTEXT(FILTER(D2>0,5),L+0.32,'KDJ顶背'),COLORWHITE;
DRAWTEXT(FILTER(D3>0,5),L+0.1,'RSI顶背'),COLORMAGENTA;
DRAWBAND(MA(CLOSE,3),RGB(200,50,160),MA(CLOSE,5),RGB(0,120,0));

?

?

更多最新股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top