最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 有什么股票选股公式?通达信背离CCI副图指标公式

有什么股票选股公式?通达信背离CCI副图指标公式

来源:网络 点击: 时间:2019-03-29

有什么股票选股公式通达信背离CCI副图指标公式 www.igojr.com小编为您提供

?

?

STICKLINE(C>0,-100,100,28,0)COLOR000840;
STICKLINE(C>0,200,200,28,-1)COLOR000080;
STICKLINE(C>0,100,100,28,-1)COLOR000080;
STICKLINE(C>0,-2.5,2.5,28,0)COLOR000080;
STICKLINE(C>0,-100,-100,28,-1)COLOR000080;
STICKLINE(C>0,-200,-200,28,-1)COLOR000080;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),STICK;{CCI柱线}
趋势线:EXPMA(CCI,4.5),COLORFF8000,NODRAW;{CCI的5天EMA}
DRAWBAND(CCI,RGB(128,0,0),趋势线,RGB(0,128,0));
STICKLINE(CCI>=0,0,CCI,0,-1),COLORLIRED;{红柱}
STICKLINE(CCI<0,0,CCI,0,-1),COLORLIBLUE;{绿柱}
CCI值:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORYELLOW,LINETHICK1;{CCI线}
DRAWTEXT(ISLASTBAR,CCI值,' ←CCI'),COLORYELLOW;
N:=5;
CCI底背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),1))+1)>C AND
REF(CCI,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),1))+1) FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),COLORWHITE,NODRAW;{WWW.STOVIEW.COM}
DRAWLINE(FILTER(BACKSET(REF(CCI,N)=LLV(CCI,2*N+1),N+1),N) AND CCI=LLV(CCI,N+1),CCI,FILTER(CCI底背>0,5),CCI,0),
COLORWHITE,DOTLINE;
DRAWTEXT(CCI底背,CCI,'底背'),COLORWHITE;
CCI顶背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),1))+1) REF(CCI,BARSLAST(REF(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),1))+1)>CCI AND
FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(CCI,N)=HHV(CCI,2*N+1),N+1),N) AND CCI=HHV(CCI,N+1),CCI,FILTER(CCI顶背>0,5),CCI,0),
COLORGREEN,DOTLINE;
DRAWTEXT(CCI顶背,CCI,'顶背'),COLORGREEN;
趋势线底背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),1))+1)>C AND
REF(趋势线,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),1))+1)<趋势线 AND
FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),COLORWHITE,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(趋势线,N)=LLV(趋势线,2*N+1),N+1),N) AND 趋势线=LLV(趋势线,N+1),趋势线,FILTER(趋势线底背>0,5),趋势线,0),
COLORWHITE,DOTLINE;
DRAWTEXT(趋势线底背,趋势线,'趋势底背'),COLORFF80FF;
趋势线顶背:=REF(C,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),1))+1) REF(趋势线,BARSLAST(REF(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),1))+1)>趋势线 AND
FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),COLORGREEN,NODRAW;
DRAWLINE(FILTER(BACKSET(REF(趋势线,N)=HHV(趋势线,2*N+1),N+1),N) AND 趋势线=HHV(趋势线,N+1),趋势线,FILTER(趋势线顶背>0,5),趋势线,0),
COLORGREEN,DOTLINE;
DRAWTEXT(趋势线顶背,趋势线,'趋势顶背'),COLORFF8000;
{面积背离}
JC:= 0-CCI;
绿柱面积:=IF(CCI<0,SUM(CCI,BARSLAST(JC<0)),0);
红柱面积:=IF(CCI>0,SUM(CCI,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (CCI<0,BARSLAST(CROSS(CCI,0)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积) RS1:= CCI<0 AND REF(CCI,1)<0 AND C<前次最低价
AND ABS(绿柱面积) 底背驰:= IF (CROSS(CCI,0),REF(Y1,1),0);
DRAWTEXT(底背驰,LLV(CCI,5),'←面积底背'),COLORLIRED;
X2:=IF (CCI>0,BARSLAST(CROSS(0,CCI)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);
RS2:= CCI>0 AND REF(CCI,1)>0 AND C>前次最高价 AND ABS(红柱面积) 顶背驰:= IF (CROSS(0,CCI),REF(Y2,1),0);
DRAWTEXT(顶背驰,HHV(CCI,5),'←面积顶背'),COLORCYAN;

?

更多最新股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top