0,MACD,0,3,1),COLORRED; ?W2:STICKLINE(MACD ?VA1:=HHVBARS(M" />
最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 股票指标公式都有哪些?通达信简单买卖游刃有余公式源码

股票指标公式都有哪些?通达信简单买卖游刃有余公式源码

来源:网络 点击: 时间:2019-05-11

股票指标公式都有哪些通达信简单买卖游刃有余公式源码 www.igojr.com小编为您提供

?

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
?DEA:EMA(DIF,9);
?MACD:"MACD.MACD",NODRAW;
?W1:STICKLINE(MACD>0,MACD,0,3,1),COLORRED;
?W2:STICKLINE(MACD<0,MACD,0,3,1),COLORCYAN;
?VA1:=HHVBARS(MACD,BARSLAST(MACD<0)+1);
?VA2:=CROSS(BACKSET(CROSS(0,MACD),REF(VA1,1)+2),0.5);
?QG:=CROSS(BACKSET(CROSS(0,MACD) OR (ISLASTBAR AND MACD>0),REF(VA1,1)+2),0.5);
前高:DRAWLINE(VA2,MACD,REF(VA2,1),REF(MACD,1),1),COLORMAGENTA;
?VA3:=LLVBARS(MACD,BARSLAST(MACD>0)+1);
?VA4:=CROSS(BACKSET(CROSS(MACD,0),REF(VA3,1)+2),0.5);
?BD1:=BARSLAST(FILTERX(CROSS(0,MACD),BARSCOUNT(C)));
前低A:DRAWLINE(VA4,MACD,REF(VA4,1),REF(MACD,1),1);
?BDTJ:=IF(MACD<0,FILTERX(MACD=LLV(MACD,BARSLAST(MACD>0)),
?BARSCOUNT(C)),DRAWNULL);{www.buyhaogu.com}
?TSBDTJ:=BARSLAST(BDTJ);
?BDZH:=FILTERX(MACD ?BDTS:=BARSLAST(BDZH);
本低:IF(BD1+1>=1,CONST(LLV(MACD,BD1+1)),DRAWNULL);
?BDCL:=CROSS(COUNT(CROSS(MACD>本低/2 AND MACD<0,0.5),TSBDTJ)=1,0.5) AND TSBDTJ>=0;
终点:=IF(ISLASTBAR AND MACD>0 AND MACD=HHV(MACD,BARSLAST(MACD<0)),1,
?IF(FILTERX(QG,BARSCOUNT(C)),2,DRAWNULL));
?UU:=(终点=1 OR 终点=2) AND MACD>0;
?ZZ:=FILTERX(UU,BARSCOUNT(C));
本高:DRAWLINE(ZZ,MACD,REF(ZZ,1),REF(MACD,1),1),COLORWHITE;
横线:=CONST(REF(MACD,BARSLAST(ZZ)));
?WW:=MACD>横线;
起始点:=FILTERX(REFX(BARSLAST(WW),1)=1,BARSCOUNT(C));
天数:BARSLAST(起始点),COLORYELLOW,NODRAW;
上横线:DRAWLINE(起始点,横线,ZZ,横线,0),COLORGREEN,DOTLINE;
下横线:DRAWLINE(BDZH,CONST(LLV(MACD,BD1+1)),BDTJ=1,MACD,0),COLOR8080FF,DOTLINE;
?DRAWNUMBER(BDTJ,CONST(LLV(MACD,BD1+1))*0.9,BDTS);
?DRAWNUMBER(ZZ,上横线*1.1,天数);
TJ:=IF(起始点,BARSNEXT(ZZ),DRAWNULL);
红柱数量:IF(天数>0 AND 天数<=REF(TJ,天数),SUM(MACD>0,天数),DRAWNULL),COLORWHITE,NODRAW;
横线起始价:REF(C,天数),NODRAW;
空间评估:(横线起始价-C)/C*100,NODRAW;
?TT:=BARSLAST(ZZ);
?WQG:=CROSS(COUNT(CROSS(MACD<本高/2 AND MACD>0,0.5),ZZ)=1,0.5) AND ZZ>=0;
?STICKLINE(MACD>前高 AND 本高>前高 AND BARSLAST(CROSS(MACD<本高/2,0.5))>0 AND
?MACD>(前高+本高)/2,MACD,前高,1,0),COLORYELLOW;
前高本高二分位:IF(MACD>0 AND 本高!=前高,DRAWLINE(WQG,(前高+本高)/2,REF(WQG,1),REF((前高+本高)/2,1),1)?,DRAWNULL),COLORC0C000,DOTLINE;
?AA:=STRCAT(STRCAT(STRCAT('〖','上升空间'),'〗'),CON2STR(IF(空间评估,空间评估,DRAWNULL),2));
?DRAWTEXT(WQG,MACD*1.1,'本高成立'),COLORWHITE;
?DRAWTEXT(BDCL,MACD*1.1,'本低成立'),COLORWHITE;
?STICKLINE(MACD>前高,MACD,前高,1,0),COLORYELLOW;
?STICKLINE(WQG,MACD,0,1,0),COLORGREEN;
?STICKLINE(MACD<0 AND MACD<前低A AND 前低A<0,MACD,前低A,1,0),COLORBLUE;
?B1:=IF(CROSS(MACD<0,0.5),BARSNEXT(BDTJ),DRAWNULL);
?TSB1:=BARSLAST(MACD>0)-1;
?STICKLINE(BARSLAST(BDCL)>=0 AND MACD<前低A AND MACD<0,MACD,前低A,1,0),COLORGREEN;
?STICKLINE(BDCL,MACD,0,1,0),COLORWHITE;
?STICKLINE(MACD>前高 AND 本高>前高 AND BARSLAST(WQG)>0,
?MACD,前高,1,0),COLORRED;
?DRAWTEXT(VA2 AND VA2!=UU,(MACD/10)*9,'前');
DRAWTEXT(VA2 AND VA2!=UU,MACD/10,'高');
DRAWTEXT(ZZ,(MACD/10)*9,'本'),COLORWHITE;
?DRAWTEXT(ZZ,MACD/10,'高'),COLORWHITE;
?DRAWTEXT(BDTJ,(MACD/10)*9,'低'),COLORRED;
?DRAWTEXT(BDTJ,MACD/10,'本'),COLORRED;
?IF(BARSLAST(BDCL)>=0,本低/2,DRAWNULL),COLORRED,DOTLINE;
?0,COLORBLUE,LINETHICK2;
?DIF0:EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK2;
?DEA0:EMA(DIF0,9),LINETHICK2;
?MACD0:"MACD.MACD",NODRAW;
?W10:STICKLINE(MACD>0,MACD,0,3,1),COLORRED;
?W20:STICKLINE(MACD<0,MACD,0,3,1),COLORCYAN;
?VA01:=HHVBARS(MACD,BARSLAST(MACD<0)+1);
?VA02:=CROSS(BACKSET(CROSS(0,MACD),REF(VA01,1)+2),0.5);

QG0:=CROSS(BACKSET(CROSS(0,MACD) OR (ISLASTBAR AND MACD>0),REF(VA01,1)+2),0.5);

VA03:=LLVBARS(MACD,BARSLAST(MACD>0)+1);
?VA04:=CROSS(BACKSET(CROSS(MACD,0),REF(VA03,1)+2),0.5);
?BD:=BARSLAST(FILTERX(CROSS(0,MACD),BARSCOUNT(C)));
前低0:DRAWLINE(VA04,MACD,REF(VA04,1),REF(MACD,1),1),LINETHICK2;
?BDTJ1:=IF(MACD<0,FILTERX(MACD=LLV(MACD,BARSLAST(MACD>0)),
?BARSCOUNT(C)),DRAWNULL);
?TSBDTJ1:=BARSLAST(BDTJ);
?BDZH1:=FILTERX(MACD ?BDTS1:=BARSLAST(BDZH1);
本低2:IF(BD+1>=1,CONST(LLV(MACD,BD+1)),DRAWNULL),LINETHICK2;
?BDCL2:=CROSS(COUNT(CROSS(MACD>本低2/2 AND MACD<0,0.5),TSBDTJ)=1,0.5) AND TSBDTJ>=0;
持仓段:0,COLOR00CFFF;
空仓段:0,COLORFFCCFF;
?DRAWTEXT(CROSS(DIF,DEA),DIF-0,'建仓'),COLORRED;
?DRAWTEXT(CROSS(DEA,DIF),DIF+0,'空仓'),COLORGREEN;
?MACD彩柱:(DIF-DEA)*2,COLORSTICK;
?STICKLINE(((MACD彩柱0)),0,MACD彩柱,1,0),LINETHICK2;
?STICKLINE(((MACD彩柱>REF(MACD彩柱,1)) AND (MACD彩柱<0)),0,MACD彩柱,1,0),COLORFF00FF,LINETHICK2;
建仓:IF(DIF<0,DIF,0),COLORYELLOW,LINETHICK2;
加仓:IF(DIF<0,0,DIF),COLORRED,LINETHICK2;
白线破仓:IF(DIF 趋势强弱:IF(DIF>DEA,DEA,DEA),COLORFF937F,LINETHICK2;
?0,COLORBLUE,LINETHICK2;DRAWICON(CROSS(MACD,0),MACD,1);
?DRAWICON(CROSS(DEA0,前低0),DEA0,1);DRAWICON(CROSS(DIF0,0),DIF0,1);
?DRAWICON(CROSS(DIF,DEA),DEA,1); {5日上穿10日做记号}
DRAWICON(CROSS(DEA,DIF),DEA,2); {5日下穿10日做记号};

?

?

更多股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top