最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 股票选股公式编写教程 通达信如虎添翼副图源码

股票选股公式编写教程 通达信如虎添翼副图源码

来源:网络 点击: 时间:2019-03-19

股票选股公式编写教程 通达信如虎添翼副图源码 www.igojr.com小编为您提供

?

OBV:SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE ?B1:=REF(OBV,1);
?B2:=REF(OBV,2);
?B3:=REF(OBV,3);
?B4:=REF(OBV,4);?
?CMAX:=MAX(MAX(MAX(OBV,B1),B2),B3);
?CMIN:=MIN(MIN(MIN(OBV,B1),B2),B3);?
持股:=STICKLINE(OBV=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND OBV>=B2 OR?
?B2=CMAX AND B3=CMIN AND OBV>=B1 OR B3=CMAX AND OBV>=B1 AND OBV>=B2,B1,OBV,3,0),COLORMAGENTA;?
变盘:STICKLINE(OBV=CMAX AND B1=CMIN,B2,OBV,3,0),COLORFFFFFF;
下跌:=STICKLINE(OBV=CMIN AND (B1 ?B2=CMIN AND B3=CMAX AND OBV ?STICKLINE(B1=CMAX AND OBV=CMIN,B2,OBV,3,0),COLOR009900 ;
买入:STICKLINE(B1=CMIN AND OBV>=B2 OR (B2=CMIN AND B1<=B3 OR?
?B3=CMIN AND B1<=B2) AND B2=B1,B1,B2,3,0),COLORRED;?
抛售:STICKLINE(B1=CMAX AND OBVB3 OR?
?B3=CMAX AND B1>B2) AND B2>=B4 AND OBV ?V1:HHV(OBV,0);
?V3:=HHV(OBV,5);
?IF(OBV=V3,OBV,DRAWNULL),COLORYELLOW,LINETHICK3;
?IF(OBV=V1,OBV,DRAWNULL),COLORRED,LINETHICK3;
?MA(OBV,7),COLORWHITE;
?MA(OBV,21),COLORLIBLUE;

{DRAWTEXT(((((COUNT((CLOSE < REF(CLOSE,1)),30) > 18) AND (COUNT((CLOSE < REF(CLOSE,1)),3) = 3)) AND ((COUNT((OBV > REF(OBV,1)),30) > 18) AND (COUNT((OBV > REF(OBV,1)),3) = 3))) AND ((COUNT((VOL > REF(VOL,1)),30) > 3) AND ((VOL / CAPITAL) <= (10 / 100)))),OBV,'买盘较强');
DRAWTEXT(((((COUNT((CLOSE > REF(CLOSE,1)),30) > 18) AND (COUNT((CLOSE > REF(CLOSE,1)),3) = 3)) AND ((COUNT((OBV > REF(OBV,1)),30) > 18) AND (COUNT((OBV > REF(OBV,1)),3) = 3))) AND ((COUNT((VOL > REF(VOL,1)),30) > 3) AND ((VOL / CAPITAL) <= (10 / 100)))),OBV,'买盘逐渐加强');}
DRAWTEXT((((COUNT((CLOSE > REF(CLOSE,1)),30) > 18) AND (COUNT((CLOSE > REF(CLOSE,1)),3) = 3)) AND ((COUNT((OBV < REF(OBV,1)),30) > 18) OR (COUNT((OBV < REF(OBV,1)),3) = 3))),OBV,'买盘无力');
DRAWTEXT((CROSS(OBV,0) AND (COUNT((REF(OBV,1) < 0),3) = 3)),OBV,'由负转正买入');
DRAWTEXT((CROSS(0,OBV) AND (COUNT((REF(OBV,1) > 0),3) = 3)),OBV,'由正转负卖出。');
DRAWTEXT(((HHV(HIGH,20) = HIGH) AND NOT((HHV(OBV,20) = OBV))),OBV,'顶背离卖'),COLORGREEN;
?DRAWTEXT(((LLV(LOW,20) = LOW) AND NOT((LLV(OBV,20) = OBV))),OBV,'底背离买'),COLORRED;
?DRAWTEXT((((ABS((OBV - REF(OBV,1))) / ABS(MA(OBV,5))) > 0.07) AND (OBV > REF(OBV,1))),OBV,'异常');

?

更多股票公式相关资讯请关注www.igojr.com

?

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top