最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 最新通达信指标公式 通达信全周期净量公式源码

最新通达信指标公式 通达信全周期净量公式源码

来源:网络 点击: 时间:2018-08-14

最新通达信指标公式 通达信全周期净量公式源码 www.igojr.com小编为您提供

?

?

T00:=200;
AF1:=300;
FX:=IF(C>REF(C,1),1,IF(C TT:=IF(PERIOD=0,BARSLAST(HOUR=9 AND MINUTE=31)+1,T00);
最高价:=CONST(HHV(H,TT));
最低价:=CONST(LLV(L,TT));
单位:=CONST((最高价-最低价)/40);
DRAWGBK(1,RGB(0,50,100),RGB(0,50,100),1,0,0);
K线数目:CURRBARSCOUNT,NODRAW;
采样数:T00,NODRAW;
M00:=最低价;
M01:=最低价+01*单位;M02:=最低价+02*单位;M03:=最低价+03*单位;M04:=最低价+04*单位;M05:=最低价+05*单位;
M06:=最低价+06*单位;M07:=最低价+07*单位;M08:=最低价+08*单位;M09:=最低价+09*单位;M10:=最低价+10*单位;
M11:=最低价+11*单位;M12:=最低价+12*单位;M13:=最低价+13*单位;M14:=最低价+14*单位;M15:=最低价+15*单位;
M16:=最低价+16*单位;M17:=最低价+17*单位;M18:=最低价+18*单位;M19:=最低价+19*单位;M20:=最低价+20*单位;
M21:=最低价+21*单位;M22:=最低价+22*单位;M23:=最低价+23*单位;M24:=最低价+24*单位;M25:=最低价+25*单位;
M26:=最低价+26*单位;M27:=最低价+27*单位;M28:=最低价+28*单位;M29:=最低价+29*单位;M30:=最低价+30*单位;
M31:=最低价+31*单位;M32:=最低价+32*单位;M33:=最低价+33*单位;M34:=最低价+34*单位;M35:=最低价+35*单位;
M36:=最低价+36*单位;M37:=最低价+37*单位;M38:=最低价+38*单位;M39:=最低价+39*单位;M40:=最低价+40*单位;
B01:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M00),CONST(M01) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B02:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M01),CONST(M02) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B03:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M02),CONST(M03) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B04:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M03),CONST(M04) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B05:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M04),CONST(M05) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B06:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M05),CONST(M06) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B07:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M06),CONST(M07) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B08:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M07),CONST(M08) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B09:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M08),CONST(M09) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B10:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M09),CONST(M10) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B11:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M10),CONST(M11) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B12:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M11),CONST(M12) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B13:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M12),CONST(M13) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B14:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M13),CONST(M14) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B15:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M14),CONST(M15) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B16:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M15),CONST(M16) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B17:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M16),CONST(M17) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B18:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M17),CONST(M18) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B19:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M18),CONST(M19) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B20:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M19),CONST(M20) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B21:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M20),CONST(M21) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B22:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M21),CONST(M22) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B23:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M22),CONST(M23) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B24:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M23),CONST(M24) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B25:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M24),CONST(M25) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B26:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M25),CONST(M26) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B27:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M26),CONST(M27) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B28:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M27),CONST(M28) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B29:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M28),CONST(M29) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B30:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M29),CONST(M30) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B31:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M30),CONST(M31) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B32:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M31),CONST(M32) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B33:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M32),CONST(M33) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B34:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M33),CONST(M34) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B35:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M34),CONST(M35) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B36:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M35),CONST(M36) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B37:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M36),CONST(M37) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B38:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M37),CONST(M38) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B39:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M38),CONST(M39) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
B40:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M39),CONST(M40+MINDIFF) ),IF( FX=1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S01:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M00),CONST(M01) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S02:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M01),CONST(M02) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S03:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M02),CONST(M03) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S04:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M03),CONST(M04) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S05:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M04),CONST(M05) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S06:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M05),CONST(M06) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S07:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M06),CONST(M07) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S08:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M07),CONST(M08) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S09:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M08),CONST(M09) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S10:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M09),CONST(M10) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S11:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M10),CONST(M11) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S12:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M11),CONST(M12) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S13:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M12),CONST(M13) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S14:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M13),CONST(M14) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S15:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M14),CONST(M15) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S16:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M15),CONST(M16) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S17:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M16),CONST(M17) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S18:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M17),CONST(M18) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S19:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M18),CONST(M19) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S20:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M19),CONST(M20) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S21:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M20),CONST(M21) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S22:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M21),CONST(M22) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S23:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M22),CONST(M23) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S24:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M23),CONST(M24) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S25:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M24),CONST(M25) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S26:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M25),CONST(M26) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S27:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M26),CONST(M27) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S28:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M27),CONST(M28) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S29:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M28),CONST(M29) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S30:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M29),CONST(M30) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S31:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M30),CONST(M31) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S32:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M31),CONST(M32) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S33:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M32),CONST(M33) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S34:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M33),CONST(M34) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S35:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M34),CONST(M35) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S36:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M35),CONST(M36) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S37:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M36),CONST(M37) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S38:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M37),CONST(M38) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S39:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M38),CONST(M39) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
S40:=CONST(SUM(IF(RANGE(C,-MINDIFF+CONST(M39),CONST(M40+MINDIFF) ),IF( FX=-1,0.9*V,IF(FX=0,0.5*V,0.1*V)),0),TT));
BS01:=B01-S01;BS02:=B02-S02;BS03:=B03-S03;BS04:=B04-S04;BS05:=B05-S05;
BS06:=B06-S06;BS07:=B07-S07;BS08:=B08-S08;BS09:=B09-S09;BS10:=B10-S10;
BS11:=B11-S11;BS12:=B12-S12;BS13:=B13-S13;BS14:=B14-S14;BS15:=B15-S15;
BS16:=B16-S16;BS17:=B17-S17;BS18:=B18-S18;BS19:=B19-S19;BS20:=B20-S20;
BS21:=B21-S21;BS22:=B22-S22;BS23:=B23-S23;BS24:=B24-S24;BS25:=B25-S25;
BS26:=B26-S26;BS27:=B27-S27;BS28:=B28-S28;BS29:=B29-S29;BS30:=B30-S30;
BS31:=B31-S31;BS32:=B32-S32;BS33:=B33-S33;BS34:=B34-S34;BS35:=B35-S35;
BS36:=B36-S36;BS37:=B37-S37;BS38:=B38-S38;BS39:=B39-S39;BS40:=B40-S40;
MAXBS1:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(ABS(BS01),ABS(BS02)),ABS(BS03))
,ABS(BS04)),ABS(BS05)),ABS(BS06)),ABS(BS07)),ABS(BS08)),ABS(BS09)),ABS(BS10));
MAXBS2:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(ABS(BS11),ABS(BS12)),ABS(BS13))
,ABS(BS14)),ABS(BS15)),ABS(BS16)),ABS(BS17)),ABS(BS18)),ABS(BS19)),ABS(BS20));
MAXBS3:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(ABS(BS21),ABS(BS22)),ABS(BS23))
,ABS(BS24)),ABS(BS25)),ABS(BS26)),ABS(BS27)),ABS(BS28)),ABS(BS29)),ABS(BS30));
MAXBS4:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(ABS(BS31),ABS(BS32)),ABS(BS33))
,ABS(BS34)),ABS(BS35)),ABS(BS36)),ABS(BS37)),ABS(BS38)),ABS(BS39)),ABS(BS40));
MAXBS:=MAX(MAX(MAX(MAXBS1,MAXBS2),MAXBS3),MAXBS4);
DRAWRECTREL(1000-ABS(BS01)/MAXBS*300,980,1000,1000,IF(BS01>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS02)/MAXBS*300,955,1000,975,IF(BS02>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS03)/MAXBS*300,930,1000,950,IF(BS03>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS04)/MAXBS*300,905,1000,925,IF(BS04>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS05)/MAXBS*300,880,1000,900,IF(BS05>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS06)/MAXBS*300,855,1000,875,IF(BS06>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS07)/MAXBS*300,830,1000,850,IF(BS07>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS08)/MAXBS*300,805,1000,825,IF(BS08>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS09)/MAXBS*300,780,1000,800,IF(BS09>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS10)/MAXBS*300,755,1000,775,IF(BS10>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS11)/MAXBS*300,730,1000,750,IF(BS11>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS12)/MAXBS*300,705,1000,725,IF(BS12>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS13)/MAXBS*300,680,1000,700,IF(BS13>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS14)/MAXBS*300,655,1000,675,IF(BS14>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS15)/MAXBS*300,630,1000,650,IF(BS15>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS16)/MAXBS*300,605,1000,625,IF(BS16>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS17)/MAXBS*300,580,1000,600,IF(BS17>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS18)/MAXBS*300,555,1000,575,IF(BS18>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS19)/MAXBS*300,530,1000,550,IF(BS19>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS20)/MAXBS*300,505,1000,525,IF(BS20>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS21)/MAXBS*300,480,1000,500,IF(BS21>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS22)/MAXBS*300,455,1000,475,IF(BS22>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS23)/MAXBS*300,430,1000,450,IF(BS23>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS24)/MAXBS*300,405,1000,425,IF(BS24>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS25)/MAXBS*300,380,1000,400,IF(BS25>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS26)/MAXBS*300,355,1000,375,IF(BS26>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS27)/MAXBS*300,330,1000,350,IF(BS27>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS28)/MAXBS*300,305,1000,325,IF(BS28>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS29)/MAXBS*300,280,1000,300,IF(BS29>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS30)/MAXBS*300,255,1000,275,IF(BS30>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS31)/MAXBS*300,230,1000,250,IF(BS31>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS32)/MAXBS*300,205,1000,225,IF(BS32>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS33)/MAXBS*300,180,1000,200,IF(BS33>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS34)/MAXBS*300,155,1000,175,IF(BS34>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS35)/MAXBS*300,130,1000,150,IF(BS35>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS36)/MAXBS*300,105,1000,125,IF(BS36>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS37)/MAXBS*300,080,1000,100,IF(BS37>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS38)/MAXBS*300,055,1000,75,IF(BS38>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS39)/MAXBS*300,030,1000,50,IF(BS39>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(1000-ABS(BS40)/MAXBS*300,005,1000,25,IF(BS40>0,RGB(200,0,0),RGB(0,200,0)));
DRAWRECTREL(0,0,250,170,RGB(50,50,100));
多方:=SUM(IF(FX=1,V,0),TT)/SUM(V,TT)*100;
空方:=SUM(IF(FX=-1,V,0),TT)/SUM(V,TT)*100;
平衡:=SUM(IF(FX=0,V,0),TT)/SUM(V,TT)*100;
DRAWRECTREL(0,0,CONST(多方*2.5),100,RGB(200,50,50));
DRAWRECTREL(CONST(多方*2.5),0,CONST(多方*2.5+平衡*2.5),100,RGB(200,200,50));
DRAWRECTREL(CONST(多方*2.5+平衡*2.5),0,250,100,RGB(50,200,50));
DRAWTEXT_FIX(1,0,0.1,0,STRCAT(STRCAT(STRCAT(多方:,CON2STR(多方,1)),
STRCAT(平衡:,CON2STR(平衡,1))),STRCAT(空方:,CON2STR(空方,1)))),COLORYELLOW;
DRAWTEXT_FIX(1,0,0,0,STRCAT(最小单位:,CON2STR(单位,3))),COLORLIGRAY;
分时线:IF(PERIOD=0,C,DRAWNULL),COLORWHITE,LINETHICK3;
均价:SUM(AMOUNT/100,T00)/SUM(V,T00),COLORYELLOW,LINETHICK2;
DRAWKLINE(H,O,L,C);
DRAWTEXT_FIX(1,0.5,0,1,STRCAT(STRCAT(行业:,HYBLOCK),STRCAT(◆◆,DYBLOCK))),COLORYELLOW;
DRAWTEXT_FIX(1,0.5,0.05,1,STRCAT(风格,FGBLOCK)),COLORLIGRAY;
DRAWTEXT_FIX(1,0.5,0.1,1,STRCAT(流通盘(亿元):,CON2STR(FINANCE(7)/100000000,3))),COLORGREEN;
DRAWTEXT_FIX(1,0,1,0,分析图中除一分钟分析图之外,更改T00设置不同选取周期,0是全周期,默认200),COLORLIGRAY;
DRAWTEXT_FIX(1,0,0.9,0,仅供股票与公式成员研究使用),COLORMAGENTA;

?

?

更多股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top