最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 最新通达信主图指标 通达信波浪操作主图公式

最新通达信主图指标 通达信波浪操作主图公式

来源:网络 点击: 时间:2018-08-15

最新通达信主图指标 通达信波浪操作主图公式 www.igojr.com小编为您提供

?

{波浪操作主图公式};
波浪线:ZIG(C,13),LINETHICK1,COLORYELLOW;
?DRAWTEXT(CROSS(ZIG(3,5) ,REF(ZIG(3 ,5),1)) ,LOW*0.999,'↖买'),COLORYELLOW;
?DRAWTEXT(CROSS(REF(ZIG(3,5),1),ZIG(3,5)) ,HIGH*1.002,'↙卖'),COLORGREEN;
?ZJ1953:=ZIG(C,15);
粉丝:=MA(ZJ1953,3);
?DRAWTEXT(CROSS(ZJ1953,粉丝),LOW*1.025,'↖基金入场 '),COLORMAGENTA;
?DRAWTEXT(CROSS(粉丝,ZJ1953),HIGH*0.988,'←基金清仓 '),COLORFFFFFF;

阻力价:HHV(HIGH,19),COLORGREEN,LINETHICK1,NODRAW;
?A:=(3*C+L+O+H)/6;
?X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF

(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF

(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
主力成本线:EMA(X,13),COLORMAGENTA,LINETHICK0;

DRAWTEXT_FIX(1,0.00,0.920,0,'操作前先来回敲敲电脑的↑↓键'),COLOR00EEFF;

? {加入,轨迹主图};

UR:=2;{调节轨迹宽度};? LR:=4;
?TC1:=IF(H=HHV(H,8*UR),H,DRAWNULL);
?TC2:=CONST(BARSLAST(TC1=H))+1;
?UPPER:=CONST(IF(TC2=1,H,REF(H,TC2-1)));
?BC1:=IF(L=LLV(L,8*LR),L,DRAWNULL);
?BC2:=CONST(BARSLAST(BC1=L))+1;
?LOWER:=CONST(IF(BC2=1,L,REF(L,BC2-1)));
?LP:=CURRBARSCOUNT<=BC2 AND L=LOWER;{低点定位}
HP:=CURRBARSCOUNT<=TC2 AND H=UPPER;{高点定位}
NOD:=(IF(TC2>BC2,TC2,BC2)-IF(TC2>BC2,BC2,TC2));{用时}
LR1:=FORCAST(C,NOD+1);
?NP:=IF(CURRBARSCOUNT<=MAX(BC2,TC2),CONST(IF(MIN(TC2,BC2)=1,LR1,REF(LR1,MIN(TC2,BC2)-

1))),DRAWNULL),POINTDOT,COLOR93BDA8,NODRAW;{近点}{隐藏}
LR2:=SLOPE(C,NOD+1);
?LR3:=CONST(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)-1)));
?FP:=NP-LR3*(NOD),POINTDOT,COLOR93BDA8,NODRAW;{远点}{隐藏}
EQU:=(NP+FP)/2,POINTDOT,COLOR93BDA8,NODRAW;{隐藏}
AD:=ABS(NP-FP);{高差};
DBL:=BARSLAST(BC1!=DRAWNULL)+1;
?DBH:=BARSLAST(TC1!=DRAWNULL)+1;
?BSP:=IF(BC2>TC2,DBL,DBH)-1;
?LRL:=IF(NP>FP,FP+AD/NOD*BSP,FP-AD/NOD*BSP);
?AT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND H>LRL,H,LRL);
?AT2:=HHV(AT1-LRL,MAX(BC2,TC2));
?AT3:=CONST(BARSLAST(AT1-LRL=AT2));
?AT4:=CONST(IF(AT3=0,H,REF(H,AT3)));
?AT5:=CONST(IF(AT3=0,AT1-LRL,REF(AT1-LRL,AT3)));
?ATL:=LRL+AT5;
?UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L ?UT2:=HHV(LRL-UT1,MAX(BC2,TC2));
?UT3:=CONST(BARSLAST(LRL-UT1=UT2));
?UT4:=CONST(IF(UT3=0,H,REF(H,UT3)));
?UT5:=CONST(IF(UT3=0,LRL-UT1,REF(LRL-UT1,UT3)));
?UTL:=LRL-UT5;
?RH:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,ATL,CONST(REF(ATL,MIN(BC2,TC2)-11)));{限制高}
RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)-10,UTL,CONST(REF(UTL,MIN(BC2,TC2)-11)));{限制低}
中轨:IF(NP>FP,IF(LRL<=RH,LRL,DRAWNULL),IF(LRL>=RL,LRL,DRAWNULL)),COLOR666666,LINETHICK2;
上轨:IF(NP>FP,IF(ATL<=RH,ATL,DRAWNULL),IF(ATL>=RL,ATL,DRAWNULL)),COLOR666666,LINETHICK2;
下轨:IF(NP>FP,IF(UTL<=RH,UTL,DRAWNULL),IF(UTL>=RL,UTL,DRAWNULL)),COLOR666666,LINETHICK2;
?VAR1:=(C+H+O+L)/4;
顶阴影线:=XMA(VAR1,20)*(1+1/8),COLORGREEN,LINETHICK1;
?DRAWTEXT(CROSS(HIGH,顶阴影线),HIGH*0.990,'↙逃'),COLORGREEN;

?

?

?

更多股票公式相关资讯请关注www.igojr.com


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top