最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通信达公式编写 通达信股仙主图指标公式

通信达公式编写 通达信股仙主图指标公式

来源:网络 点击: 时间:2018-08-16

通信达公式编写 通达信股仙主图指标公式 www.igojr.com小编为您提供

?

MA55:=MA(C,55);
M1:=15;
HR:=HHV(HIGH,M1);
HRY:=LLV(LOW,M1);
HRY11:=HR*HRY;
HRY33:SQRT(HRY11),COLORGREEN,LINETHICK2;
IF(C>HRY33 AND HRY33 >=REF(HRY33 ,1), HRY33 ,DRAWNULL),LINETHICK2,COLORRED;
WLT1:=EMA(C,3);
WLT2:=EMA(C,5);
WLT3:=EMA(WLT2,5);
HP:=(HHV(CLOSE,10)-LLV(CLOSE,10))/CLOSE<0.10;
LB:=VOL/MA(VOL,5);
X1:=(C+L+H)/3;

BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10),
LOW*0.99,'★∠45'),COLORFFFFFF;

TT:=FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10);{45度上升}
MM:=WLT1>REF(WLT1,1) AND REF(WLT1,1)均线向上转折}
GG1:=CROSS(WLT1,WLT2);
TYP:= (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=(CCI1+CCI2+CCI3+CCI4+CCI5)/2,COLORRED,LINETHICK2;
WLT91:=HHV(CCI,13);{CCI的13日内最高}
WLT92:=LLV(CCI,13)<-100;{CCI的13日内最低值小于-100}
WLT95:=COUNT(WLT92,13)>=3;{CCI的13日内最低值小于-100的情况不少于3次}
WLT93:=CCI>WLT91;{CCI大于前13日内最高}
WLT96:=CROSS(CCI,100);{CCI上穿100}
TJ91:=WLT95 AND WLT96;
JLP:=FILTER(TJ91,5);

超买:=MA(C,10)*IF(CAPITAL=0,1.04,1.1),POINTDOT,COLORGREEN,LINETHICK2;
超卖:=MA(C,10)*IF(CAPITAL=0,0.95,0.9),POINTDOT,COLORRED,LINETHICK2;
TEND:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK4;

DD:=TEND>REF(TEND,1) AND REF(TEND,1) >REF(TEND,2);{趋势线向上转折}
GG2:=CROSS(WLT1,TEND);{均线与趋势线向上金叉}
HRY1:=LLV(LOW,55);
HRY2:=HHV(HIGH,21);
GG3:=CHRY33;
JJ1:=C TJ1:=GG1;{均线向上金叉}
TJ2:=GG2 AND JJ1;
TJ3:=GG1 AND GG3 ;
XG:=TJ1 OR TJ3 ;
XG2:=C1;
XG1:=XG AND XG2 AND C>HRY33 AND JLP;
XG3:=XG AND C XG11:=XG1 OR XG3;
DRAWICON(XG11,LOW*0.97,23);
DRAWTEXT(XG1,LOW*0.95,'全'),COLORFFFFFF;
DRAWTEXT(XG1,LOW*0.93,'仓'),COLORFFFFFF;
SAL1:=HIGH>超买;
SAL2:=C0.03;
QQ:= C QQ1:=CROSS(WLT2,WLT1);
QQ3:=HIGH>HRY1*1.38;
SAL01:= SAL1 AND SAL2 AND QQ AND QQ3;
SAL02:=QQ3 AND QQ1;
SAL:=SAL01 OR SAL02;
DRAWICON(SAL,HIGH*1.03,15);
{红色K线,持股}
STICKLINE(C>TEND AND C>O,C,O,3,1),COLOR0000FF;
STICKLINE(C>TEND AND C STICKLINE(C>TEND AND C {兰色K线,持币}
STICKLINE(CO,C,O,3,1),COLORFFFF00;
STICKLINE(CO,C,O,1.7,0),COLOR6800FD;
STICKLINE(CO,L,H,0,0),COLOR0000FF;
{紫色K线,注意}
STICKLINE(CWLT1 AND C>O,C,O,3,0),COLORAA00AA;
STICKLINE(CWLT1 AND C>O,C,O,1,0),COLORDD00DD;
STICKLINE(CWLT1 AND C>O,C,O,0.3,0),COLORFF00FF;
{黄色K线,注意买入}
STICKLINE(XG,C,O,4,0),COLOR009999;
STICKLINE(XG,C,O,3,0),COLOR00BBBB;
STICKLINE(XG,C,O,1.5,0),COLOR00DDDD;
STICKLINE(XG,C,O,0.3,0),COLOR00FFFF;
{绿色K线,卖出}
STICKLINE(SAL,C,O,4,0),COLOR009900;
STICKLINE(SAL,C,O,3,0),COLOR00BB00;
STICKLINE(SAL,C,O,1.5,0),COLOR00DD00;
STICKLINE(SAL,C,O,0.3,0),COLOR00FF00;
DRAWBAND(WLT1,RGB(255,255,0),WLT2,RGB(0,0,220));

HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);


DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MMM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1)
COLORGREEN,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);


DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1)
COLORRED,LINETHICK1;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2 中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),
COLORFF55FF,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,
REF(L,DDCS1-1),1),COLORFF00FF,POINTDOT,;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,
REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;

V1:=CLOSE/REF(CLOSE,3)>=1.1;
V2:=BACKSET(V1,2);
DRAWICON((V2 AND COUNT(V2,2)=1),L,26);

TF:=MA(C,250),LINETHICK2,COLOR0000FF;
BBB:=REF(TF,1);
CCC:=REF(TF,2);
EEE:=LLV(LOW,500)*1.618;
TJ333:=C TJ11:=BBB>CCC;
TJ22:=FILTER(COUNT(CROSS(C,TF),21)>=1,55);
XG18:=TJ11 AND TJ22 AND TJ333;
DRAWTEXT(XG18,LOW*0.98,'万'),COLOR00FFFF;
DRAWTEXT(XG18,LOW*0.97,'能'),COLOR00FFFF;

TJ88:=CROSS(C,HRY33) AND MA55>REF(MA55,1);
BUY1:=LAST(CLOSE>MA(CLOSE,M1),0,5);
BUY2:=EXIST(CLOSE BUY:=CLOSE>MA(CLOSE,M1)&&BUY1&&BUY2;
DRAWICON(TJ88 OR BUY,LOW*0.97,17);

?

?

?

更多股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top