最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通信达公式破解 通达信MACD显示在主图指标公式

通信达公式破解 通达信MACD显示在主图指标公式

来源:网络 点击: 时间:2019-05-18

通信达公式破解 通达信MACD显示在主图指标公式 www.igojr.com小编为您提供

?

DIFZ:=EMA(C,12)-EMA(C,26);
DEAZ:=EMA(DIFZ,9);
MACDZ:=8*(DIFZ-DEAZ);

TYNNN:=60;


A1:=REF(HIGH,TYNNN)=HHV(HIGH,2*TYNNN+1); B1:=FILTER(A1,TYNNN);
C1:=BACKSET(B1,TYNNN+1); D1:=FILTER(C1,TYNNN);
A2:=REF(LOW,TYNNN)=LLV(LOW,2*TYNNN+1); B2:=FILTER(A2,TYNNN);
C2:=BACKSET(B2,TYNNN+1); D2:=FILTER(C2,TYNNN);
E1:=(REF(LLV(LOW,2*TYNNN),1)+REF(HHV(HIGH,2*TYNNN),1))/2; E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1 X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);
UU:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
RCC:=REF(L,BARSLAST(VV));
DRAWBAND(DIFZ*4+RCC,RGB(155,50,50),EMA(DIFZ*4+RCC,9),RGB(0,50,150));{此句4.0以下版本要删除}
STICKLINE((RCC+MACDZ)>RCC AND (RCC+MACDZ)<=REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,0),COLOR400080;
STICKLINE((RCC+MACDZ)>RCC AND (RCC+MACDZ)>REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,0),COLOR00FFFF;
STICKLINE((RCC+MACDZ)<=RCC AND (RCC+MACDZ)<=REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,0),COLOR008080;
STICKLINE((RCC+MACDZ)<=RCC AND (RCC+MACDZ)>REF(RCC+MACDZ,1),RCC,RCC+MACDZ,1,0),COLORC080FF;
IF(C,EMA(DIFZ*4+RCC,9),DRAWNULL),COLORFFFFFF,LINETHICK1;
IF(C,DIFZ*4+RCC,DRAWNULL),COLORRED,LINETHICK1;
IF(DIFZ<=REF(DIFZ,1),DIFZ*4+RCC,DRAWNULL),COLORFFF000;



STICKLINE(C>O,H,L,0,0),COLORRED;
STICKLINE(C>O,C,O,3.1,1),COLORRED;
STICKLINE(C<=O,H,L,0,0),COLORCYAN;
STICKLINE(C<=O,C,O,3.1,1),COLORCYAN;

{均线状态}
MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
MA30:MA(C,30);
MA60:MA(C,60);
?

?

?

?

更多股票公式相关资讯请关注www.igojr.com


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top