最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 最新通达信主图指标 通达信DMI超级股转向公式源码

最新通达信主图指标 通达信DMI超级股转向公式源码

来源:网络 点击: 时间:2018-08-22

最新通达信主图指标 通达信DMI超级股转向公式源码 www.igojr.com小编为您提供

?

?

N:=14;M:=5;M1:=5;M2:=5;M3:=6;RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

TT:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),

ABS(LOW-REF(CLOSE,1))),N,1);

HD:=HIGH-REF(HIGH,1);

LD:=REF(LOW,1)-LOW;

DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);

DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);

TJ:=1;

PDI:DMP*100/TT,COLORRED;

MDI:DMM*100/TT,COLORGREEN;

ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,M,1),COLORYELLOW,LINETHICK1;

ADXR:(ADX+REF(ADX,M))/2,COLORFF9900,LINETHICK1;


DRAWBAND(PDI,RGB(100,0,10),MDI,RGB(0,80,0));

DRAWBAND(ADX,RGB(180,180,0),ADXR,RGB(0,10,150));

DRAWBAND(SMA(RSV,5,1),RGB(180,10,180),SMA(SMA(RSV,5,1),5,1),RGB(10,150,10));

K:SMA(RSV,5,1),COLORMAGENTA,LINETHICK1;

D:SMA(K,5,1),COLORLIGREEN,LINETHICK1;

逢低买入:IF(CROSS(PDI,MDI) OR REF(CROSS(PDI,MDI),1) AND PDI>REF(PDI,1) AND ADX <30 AND K>D,1,DRAWNULL),COLORYELLOW,NODRAW;

短线卖出:IF(CROSS(ADXR,ADX) AND PDI>MDI AND ADX>55,1,DRAWNULL),COLOR00FF00,NODRAW;

牛市:IF(PDI > MDI AND ADX >= 30,1,DRAWNULL),COLOR0000FF,NODRAW;

熊市:IF(PDI < MDI AND ADX >= 30,1,DRAWNULL),COLOR00FF00,NODRAW;

略牛市:IF(PDI > MDI AND ADX >=16 AND ADX < 30,1,DRAWNULL),COLORFF00FF,NODRAW;

略熊市:IF(PDI < MDI AND ADX >=16 AND ADX < 30,1,DRAWNULL),COLORFFFF00,NODRAW;

静寂期:IF(ADX <=16 AND (PDI > MDI OR PDI < MDI),1,DRAWNULL),COLORFFFFFF,NODRAW;

抄底1:=16,COLORWHITE,POINTDOT;

抄底2:=30,COLORYELLOW,POINTDOT;

逃顶1:=60,COLORGREEN,POINTDOT;

逃顶2:=80,COLORMAGENTA,POINTDOT;

多头线:PDI,COLORRED, LINETHICK1;

空头线:MDI,COLORGREEN, LINETHICK1;

DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,'在一轮大牛市中,我们是可以看见空头线跌落至0位的,如果多头线在空头线上方,这时候的市场为强势市场。反之,就是空头市场。'),COLOR00FF00;

DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,'当ADX线大于60的时候,庄家就开始计划行动了。'),COLORRED;

DRAWTEXT_FIX(ISLASTBAR,0,0.15,0,'特别说明:当ADX到达60附近时,都要禁止按市场现有的方向顺势操作。在上涨过程中,要停止买进,而在下跌过程中,不能因为市场的恐慌而继续做空。'),COLORWHITE;

DRAWTEXT_FIX(ISLASTBAR,0,0.2,0,'当ADX进入60到80的区域以后,市场就进入了真正的高风险区域,提示头部或底部已经很近了。'),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0,0.3,0,'(1)强的上升趋势(牛市): PDI > MDI AND ADX >= 30 。(2)强的下降趋势(熊市):PDI < MDI AND ADX >= 30 。(3)略牛的盘整期:PDI > MDI AND 16 < ADX < 30。 '),COLORMAGENTA;

DRAWTEXT_FIX(ISLASTBAR,0,0.35,0,'(4)略熊的盘整期:PDI < MDI AND 16 < ADX < 30。(5)静寂期: ADX < =16 AND (PDI > MDI OR PDI < MDI) 。(6)在牛市ADX越大越强,但是大于60就要注意了,牛市将可能要回调。 '),COLORMAGENTA;

DRAWRECTREL(610,50,790,250,RGB(20,20,100));

DRAWTEXT_FIX(ISLASTBAR AND TJ>0 ? ,0.62,0.07,0,'趋势:'),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR AND 强牛市>0,0.66,0.07,0,'强的上升趋势(牛市)'),COLORRED;


DRAWTEXT_FIX(ISLASTBAR AND 强熊市>0,0.66,0.07,0,'强的下降趋势(熊市)'),COLOR00FF00;

DRAWTEXT_FIX(ISLASTBAR AND 略牛市>0,0.66,0.07,0,'略牛的盘整期(弱牛)'),COLORFF00FF;

DRAWTEXT_FIX(ISLASTBAR AND 略熊市>0,0.66,0.07,0,'略熊的盘整期(弱熊)'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND 静寂期>0,0.66,0.07,0,'静寂期(空仓观察期)'),COLORFFFFFF;

STICKLINE(逢低买入>0 ,0,30,0.1,0),COLOR00FFFF;

STICKLINE(短线卖出>0 ,0,30,0.1,0),COLORFF0000;

?

?

更多股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top