最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 最新通达信主图指标 通达信简明立体K线主图公式源码

最新通达信主图指标 通达信简明立体K线主图公式源码

来源:网络 点击: 时间:2019-05-12

最新通达信主图指标 通达信简明立体K线主图公式源码 www.igojr.com小编为您提供

DRAWKLINE(H,O,L,C);{重绘K线}
RC1:=REF(C,1);
CS:=5/IF(C>=1,1000,10000);
C涨停10:=1.10*RC1-CS;
C涨停5 :=1.05*RC1-CS;
C跌停10:=0.90*RC1+CS;
C跌停5 :=0.95*RC1+CS;
ST:=NAMELIKE('S') OR NAMELIKE('*S');
涨停:= IF(ST, C>=C涨停5, C>=C涨停10);
跌停:= IF(ST, C<=C跌停5, C<=C跌停10);
盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);

盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);
STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}
STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}
大阳线:=C>O AND (C>=C涨停5 OR O<(0.95*C+CS) ) OR (C>1000 AND C>=RC1*1.025);
STICKLINE(大阳线,O,C,1,0),COLOR0000BB;
大阴线:=C1000 AND C STICKLINE(大阴线,O,C,1,0),COLORLIGREEN;
STICKLINE(涨停,O,C,1,0),COLORMAGENTA;
STICKLINE(跌停,O,C,1,0),COLORLICYAN;
{均价:=IF(C>1000,C,AMOUNT/VOL/100);}
假阴1:= CREF(C,1);{显式-假阴真阳};

STICKLINE(假阴1,O,C,0,0),COLORRED;{假阴柱};
均价:=AMOUNT/VOL/100;
假阴2:= CRC1 AND C<=RC1 AND 均价<=H;{隐式-假阴真阳};
STICKLINE(假阴2,均价,均价,1,0),COLORRED;{假阴柱};
假阳:=C>O AND C STICKLINE(假阳,O,C,0,0),COLORGREEN;{假阳柱};
{跳空}
STICKLINE(REF(L,1)>H,H,REF(L,1),5,0),COLORGRAY;
STICKLINE(REF(H,1) C_:CONST(C),COLORLIRED,POINTDOT;{现价线}
K中: (H+L)/2,COLORYELLOW,NODRAW;
MA5:=MA(C,5);
MA5角度: ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,NODRAW;
AA:=C/REF(C,1)>1.05;
STICKLINE(AA,H,L,0,1),COLORYELLOW;
STICKLINE(AA,C,O,3.2,0),COLOR117777;
STICKLINE(AA,C,O,2.6,0),COLOR119999;
STICKLINE(AA,C,O,1.9,0),COLOR11BBBB;
STICKLINE(AA,C,O,1.1,0),COLOR11DDDD;
STICKLINE(AA,C,O,0.3,0),COLOR44FFFF;

?


更多股票公式相关资讯请关注www.igojr.com


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top