最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 2016通达信指标公式 通达信升升升降降降副图公式源码

2016通达信指标公式 通达信升升升降降降副图公式源码

来源:网络 点击: 时间:2019-03-29

2016通达信指标公式 通达信升升升降降降副图公式源码 www.igojr.com小编为您提供

?

线4:20,COLOR545454,DOTLINE;
线3:10,COLOR545454,DOTLINE;
线2:0,COLOR545454,DOTLINE;
线1:-10,COLOR545454,DOTLINE;
RSV:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*50-20;
K:SMA(RSV,9,1),COLOR4D4DFF,LINETHICK1;
D:SMA(K,3,1),COLOR00FF00,LINETHICK1;
J:EMA(K,9),DOTLINE,COLORFF2400;
VARK:K,COLORWHITE,LINETHICK2;
上升K:IF(VARK>REF(VARK,1),VARK,DRAWNULL),COLORRED,LINETHICK2;
走平K:IF(VARK=REF(VARK,1),VARK,DRAWNULL),COLORFFFFFF,LINETHICK2;
下降K:IF(VARK VARD:D,COLORWHITE,LINETHICK2;

上升D:IF(VARD>REF(VARD,1),VARD,DRAWNULL),COLORFF00FF,LINETHICK2;
走平D:IF(VARD=REF(VARD,1),VARD,DRAWNULL),COLORFFFFFF,LINETHICK2;
下降D:IF(VARD VARJ:J,COLORWHITE;
上升J:IF(VARJ>REF(VARJ,1),VARJ,DRAWNULL),COLORRED;
走平J:IF(VARJ=REF(VARJ,1),VARJ,DRAWNULL),COLORFFFFFF;
下降J:IF(VARJ STICKLINE(VARK>=0 AND VARK>=REF(VARK,1),0,0+VARD,0,1),COLOR9F9F5F;
STICKLINE(VARK>=0 AND VARK>=REF(VARK,1),0,0+VARJ,0,1),COLOR9F9F5F;
STICKLINE(VARD>=0 AND VARD>=REF(VARD,1),0,0+VARK,0,1),COLOR9F9F5F;
STICKLINE(VARD>=0 AND VARD>=REF(VARD,1),0,0+VARJ,0,1),COLOR9F9F5F;
STICKLINE(VARJ>=0 AND VARJ>=REF(VARJ,1),0,0+VARK,0,1),COLOR9F9F5F;
STICKLINE(VARJ>=0 AND VARJ>=REF(VARJ,1),0,0+VARD,0,1),COLOR9F9F5F;
STICKLINE(VARK>=0 AND VARK>=REF(VARK,1),0,0+VARK,0,1),COLOR9F9F5F;
STICKLINE(VARD>=0 AND VARD>=REF(VARD,1),0,0+VARD,0,1),COLOR9F9F5F;
STICKLINE(VARJ>=0 AND VARJ>=REF(VARJ,1),0,0+VARJ,0,1),COLOR9F9F5F;
STICKLINE(VARJ<=0 AND VARK>=REF(VARD,1),0,0+VARD,0,1),COLOR9F9F5F;
N:=60;
K值:="KDJ.K";
DD:=C=LLV(C,N);{120日最低点}
DDSJ:=BARSLAST(REF(DD,1));{上一低点时间}
DDGJ:=REF(CLOSE,DDSJ+1)>CLOSE;{股价趋势}
KDZB:=REF(K值,DDSJ+1) K底背离:=DDGJ AND KDZB;
GD:=C=HHV(C,N);{120日最高点}
GDSJ:=BARSLAST(REF(GD,1));{上一高点时间}
GDGJ:=REF(CLOSE,GDSJ+1) KGZB:=REF(K值,GDSJ+1)>K值;
K顶背离:=GDGJ AND KGZB;
MACD:="MACD.MACD";
MDZB:=REF(MACD,DDSJ+1) M底背离:=DDGJ AND MDZB;
MGZB:=REF(MACD,GDSJ+1)>MACD;
M顶背离:=GDGJ AND MGZB;
RSI:="RSI.RSI1";
RDZB:=REF(RSI,DDSJ+1) R底背离:=DDGJ AND RDZB;
RGZB:=REF(RSI,GDSJ+1)>RSI;
R顶背离:=GDGJ AND RGZB;
TYP:=(HIGH + LOW + CLOSE)/3;

CCI:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
CDZB:=REF(CCI,DDSJ+1) C底背离:=DDGJ AND CDZB;
CGZB:=REF(CCI,GDSJ+1)>CCI;
C顶背离:=GDGJ AND CGZB;
REFLINE: -5,15,30,COLORBLACK;
DRAWICON(K顶背离,IF(ISLASTBAR,20.5,20),2),LINETHICK2 ;
DRAWICON(M顶背离,(ISLASTBAR,10.5,10),2),LINETHICK2 ;
DRAWICON(R顶背离,(ISLASTBAR,0.5,0),2),LINETHICK2 ;
DRAWICON(C顶背离,(ISLASTBAR,-10.6,-10),2),LINETHICK2 ;
DRAWTEXT(ISLASTBAR,-10.1 ,CCI ),LINETHICK2,COLORGREEN;
DRAWICON(C底背离,IF(ISLASTBAR,12,-10.1 ),1),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR,0,RSI ),LINETHICK2,COLORRED;
DRAWICON(R底背离,IF(ISLASTBAR,8.5,0),1),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR,10,MACD ),LINETHICK2,COLORMAGENTA;
DRAWICON(M底背离,IF(ISLASTBAR,4.5,10),1),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR,20,KDJ ),LINETHICK2,COLORRED;
DRAWICON(K底背离,IF(ISLASTBAR,1.5,20),1),LINETHICK2,COLORRED;

?

?

?

更多股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top