最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 2017通达信指标公式 通达信自动标记数波浪主图公式源码

2017通达信指标公式 通达信自动标记数波浪主图公式源码

来源:网络 点击: 时间:2019-05-17

2017通达信指标公式 通达信自动标记数波浪主图公式源码 www.igojr.com小编为您提供

?

?

GET:ZIG(3,5),COLORAAAAAA;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,13);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,26);

EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,55);
走强一:=BARSLAST(PL5 走弱一:=BARSLAST(PL5>REF(PL5,1));
走强二 :=BARSLAST(PL10 走弱二:=BARSLAST(PL10>REF(PL10,1));
走强三:=BARSLAST(PL20 走弱三:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强二 ),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强二 ),0);
DTJZ5:=IF(PL10 DTJD5:=IF(PL10 ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强三),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强三),0);
DTJZ10:=IF(PL20 DTJD10:=IF(PL20
DRAWTEXT(EN1 AND DTJZ5=1,LOW*0.97,'(Ⅰ)'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,HIGH*1.03,'(Ⅱ)'),COLORFFFF00;
DRAWTEXT(EN2 AND ZTJZ5=1,LOW*0.97,'(Ⅲ)'),COLORFFFF00;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,HIGH*1.02,'⑴'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,LOW*0.98,'⑵'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,HIGH*1.02,'⑶'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,LOW*0.98,'⑷'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,HIGH*1.02,'⑸'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,LOW*0.94,'【A】'),COLOR00FF00;
DRAWTEXT(EX2 AND DTJD10=2,HIGH*1.05,'【B】'),COLOR00FF00;
DRAWTEXT(EN3 AND ZTJZ10=1,LOW*0.94,'【C】'),COLOR00FF00;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,HIGH*1.04,'①'),COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,LOW*0.96,'②'),COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,HIGH*1.04,'③'),COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,LOW*0.96,'④'),COLOR00FFFF;

?

?

更多股票公式相关资讯请关注www.igojr.com


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top