最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通信达公式指标大全 通达信精品操盘主图指标公式

通信达公式指标大全 通达信精品操盘主图指标公式

来源:网络 点击: 时间:2019-03-24

通信达公式指标大全 通达信精品操盘主图指标公式 www.igojr.com小编为您提供

BOLL:MA(C,30),COLORRED ,POINTDOT; 上升:IF(BOLL>REF(BOLL,1),BOLL,DRAWNULL),COLORRED ,POINTDOT; 下降:IF(BOLL短线:VAR1AA,COLORGREEN,LINETHICK1,DOTLINE; 短线角度比率:短线/REF(短线,1)*100-100 ,NODRAW; IF(短线REF(短线,1),短线,DRAWNULL),LINETHICK1, COLORYELLOW,DOTLINE; IF(短线 龙魅:=REF(短线,1)=REF(中线,1) AND 短线>REF(短线,1) AND 短线>中线 ; 下跌:IF(VAR1AA=VAR6A,VAR6A,DRAWNULL),COLORLIGREEN,LINETHICK1,DOTLINE; ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停} CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);

上:=(1+7/100)*DD,DOTLINE,COLORRED; 下:=(1-7/100)*DD,DOTLINE,COLORRED; 中:=(上+下)/2,DOTLINE,COLORRED; 顶:=(1+14/100)*DD,LINETHICK2,COLORBLACK; 底:=(1-14/100)*DD,LINETHICK2,COLORBLACK; 触底:=L<下 AND ZT ; STICKLINE(触底,C,O,6,1),COLORRED; STICKLINE(触底,C,O,5,1),COLORRED; STICKLINE(触底,C,O,4,1),COLORYELLOW; STICKLINE(触底,C,O,1,0),COLORRED; 渡劫:=CROSS(C,上) AND ZT; DRAWTEXT(渡劫,L*0.96,'↖渡劫'),COLORYELLOW; 飞仙:=O>上 AND ZT AND COUNT(REF(O>上 AND C/REF(C,1)>=1.099,1),2)<1; STICKLINE(飞仙,C,O,3,1),COLORMAGENTA; STICKLINE(飞仙,C,O,1,0),COLORRED; DRAWTEXT(飞仙,O*0.985,'↖飞仙'),COLORLIRED; JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6; VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
短买:=VAR19 AND 下>=REF(下,1) AND 短线角度比率>0 AND C>=O,COLOR33AACC,NODRAW; CO:=(C-O);
启爆:=CROSS(C,上) AND ZT; 预爆:= CROSS(C,中) AND ZT; STICKLINE(启爆,C,O,3,1),COLORWHITE; STICKLINE(启爆,C,O,1,0),COLORGREEN; 乖离涨停1:=H>上 AND ZT AND CROSS(C,上);
STICKLINE(乖离涨停1,C,O,3,1),COLORYELLOW; 乖离涨停2:=O>上 AND ZT AND COUNT(REF(O>上 AND C/REF(C,1)>=1.099,1),2)<1; STICKLINE(乖离涨停2,C,O,3,1),COLORMAGENTA; STICKLINE(乖离涨停2,C,O,1,0),COLORRED; STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555; STICKLINE(短买,O,O+CO/3,2,0),COLOR338888; STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA; STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC; STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE; DRAWTEXT(龙魅,L*0.99,'↑'),COLORYELLOW; T1:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1));
CCVV:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST((CURRBARSCOUNT >(CCVV+T1)) AND (HIGH>T1HIGH)));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST((CURRBARSCOUNT >(CCVV+T2)) AND (HIGH>T2HIGH)));
T3HIGH:=CONST(REF(HIGH,T3));
凹口线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK1,COLORWHITE,DOTLINE; DRAWTEXT(ISLASTBAR, T3HIGH*1.003, ' ...............凹口线')LINETHICK1,COLORWHITE; DRAWICON(CROSS(C,凹口线),凹口线*1,11);
TY:=C; A11:=REF(TY,10)=HHV(TY,2*10+1);
B11:=FILTER(A11,10);
C11:=BACKSET(B11,10+1);
HD11:=FILTER(C11,10);

A21:=REF(TY,10)=LLV(TY,2*10+1);
B21:=FILTER(A21,10);
C21:=BACKSET(B21,10+1);
LD1:=FILTER(C21,10);
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通比例: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
利润同比:=STRCAT(' 利润同比: ',CON2STR(FINANCE(43),2));
收入同比:=STRCAT(' 收入同比: ',CON2STR(FINANCE(44),2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT({STRCAT(}STRCAT(市盈率,净资收益率){,毛利率)},净利润率),主营利润率), 利润同比));
DRAWTEXT_FIX(ISLASTBAR,0.02,0.01,0,当前业绩),COLORLIMAGENTA; DRAWTEXT_FIX(ISLASTBAR,0.02,0.06,0,股本市值),COLORYELLOW; {所属板块、概念} DRAWTEXT_FIX(1,0.02,0.115,0,'所属行业地域概念:'),COLORYELLOW; DRAWTEXT_FIX(1,0.13,0.115,0,HYBLOCK),COLOR0000FF;{所属行业} DRAWTEXT_FIX(1,0.18,0.115,0,DYBLOCK),COLORFF00FF;{所属地域} DRAWTEXT_FIX(1,0.23,0.115,0,GNBLOCK),COLOR0088FF;{所属概念} DRAWTEXT_FIX(1,0.02,0.17,0,'所属风格板块:'),COLOR00FFAA; DRAWTEXT_FIX(1,0.10,0.17,0,FGBLOCK),COLOR00FFFF;{所属风格板块}; {控盘系数} ZLCM:=EMA(WINNER(CLOSE)*70,3);
{//主力筹码估算} SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
{//散户筹码估算} ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率} 控盘系数%:=INTPART(ZZLKP),NODRAW; 高度控盘:=CROSS(控盘系数%,50);
DRAWTEXT_FIX(1,0.02,0.23,0,STRCAT('控盘系数%:',CON2STR(控盘系数%,2))),COLORYELLOW; {筹码峰} DRAWTEXT_FIX(1,0.07,0.23,0,EXTERNSTR(0,2))COLORFF00FF; DRAWTEXT_FIX(1,0.15,0.23,0,'筹码峰:')COLORWHITE; DRAWNUMBER_FIX(1,0.21,0.23,0,WINNER(C)*100)COLORWHITE; N:=5;N1:=30;N2:=3;P1:=15;P2:=3; A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2; H1:=(D1 AND NOT(D2 AND E1>=E2)) OR CURRBARSCOUNT=2 OR BARSCOUNT(C)=1; L1:=(D2 AND NOT(D1 AND E1>=E2)) ;H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS (IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR CURRBARSCOUNT=2 OR BARSCOUNT(C)=1; X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS (IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
R1:=BACKSET(CURRBARSCOUNT=2,BARSLAST(HD)+1);
S1:=R1>REF(R1,1);
T1A:=BACKSET(CURRBARSCOUNT=2,BARSLAST(LD)+1);
U1:=T1A>REF(T1A,1);
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1);
T2A:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2A>REF(T2A,1);
买线1:=EMA(CLOSE,2);
卖线1:=EMA(((SLOPE(CLOSE,12) * 20) + CLOSE),43);
STICKLINE((CROSS(买线1,卖线1)),OPEN,CLOSE,0.5,0),COLORYELLOW; STICKLINE((CROSS(卖线1,买线1)),OPEN,CLOSE,1.1,0),COLORBLACK; STICKLINE((CROSS(卖线1,买线1)),OPEN,CLOSE,0.3,0),COLORGREEN; DRAWICON(CROSS(C,凹口线),凹口线*1,11);
爆发点:=(DCLOSE-REF(C,1))/REF(C,1)*100; XB:=CROSS(爆发点,20);
DRAWTEXT(XB,L,'↖启爆'),COLORWHITE; 金叉:=CROSS(KDJ.J,KDJ.D);
死叉:=CROSS(KDJ.D,KDJ.J);
CO1:=(C-O);
STICKLINE(金叉,O,O+CO1/3,2.8,0),COLOR335555; STICKLINE(金叉,O,O+CO1/3,2,0),COLOR338888; STICKLINE(金叉,O,O+CO1/3,1.5,0),COLOR33AAAA; STICKLINE(金叉,O,O+CO1/3,1,0),COLOR33CCCC; STICKLINE(金叉,O,O+CO1/3,0,0),COLOR33EEEE; STICKLINE(金叉,O,C,0,0),COLORYELLOW; STICKLINE(死叉,OPEN,CLOSE,0,0),COLORBLUE; STICKLINE(死叉,O,O+CO1/3,2.8,0),COLOR550055; STICKLINE(死叉,O,O+CO1/3,2,0),COLOR880088; STICKLINE(死叉,O,O+CO1/3,1.5,0),COLORAA00AA; STICKLINE(死叉,O,O+CO1/3,1,0),COLORCC00CC; STICKLINE(死叉,O,O+CO1/3,0.5,0),COLOREE00EE; 短期压力:DRAWLINE(S2,H,S1,H,1),COLORRED,LINETHICK2{,DOTLINE}; 短期支撑:DRAWLINE(U2,L,U1,L,1),COLORGREEN,LINETHICK2{,DOTLINE}; DRAWTEXT(ISLASTBAR,短期支撑*0.99,'↖短撑')LINETHICK1,COLORGRAY; DRAWICON(CROSS(C,短期压力),短期压力*1,11);
DRAWTEXT(ISLASTBAR,短期压力*1.008,'↙短压')LINETHICK1,COLORGRAY; 高内:=20;
高前一:=10; 高:=1; H11:=CONST(FINDHIGH(C,高前一,高内,高));
TH1:=CONST(FINDHIGHBARS(C,高前一,高内,高))+1; 高1:DRAWLINE(CURRBARSCOUNT=TH1,H11,CURRBARSCOUNT=1,H11,1),COLORLIGRAY,LINETHICK2; DRAWICON(CROSS(C,高1),高1*1,11);
DRAWTEXT(ISLASTBAR,高1*1.0025,'........T 线')LINETHICK,COLORGRAY; DRAWICON(CROSS(C,凹口线),凹口线*1,11);

?


更多股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top