最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通信达公式怎么用?通达信炒股如音符副图公式源码

通信达公式怎么用?通达信炒股如音符副图公式源码

来源:网络 点击: 时间:2018-08-30

通信达公式怎么用通达信炒股如音符副图公式源码 www.igojr.com小编为您提供

轴1:0,COLORYELLOW;
轴2:5,COLORWHITE,POINTDOT;
轴3:10,COLORWHITE,POINTDOT;
轴4:15,COLORWHITE,POINTDOT;
轴5:20,COLORWHITE,POINTDOT;
轴6:25,COLORWHITE,POINTDOT;
轴7:30,COLORYELLOW;
N:=9;
N1:=6;
M:=14;
AAATYP := (HIGH + LOW + CLOSE)/3;
AAA1:=(AAATYP-MA(AAATYP,M))/(0.015*AVEDEV(AAATYP,M));
C1:=SMA(AAA1,3,1);
C2:=SMA(C1,3,1);
C3:=3*C1-2*C2;
CB1:=EMA(C3,5);
CB2:=REF(CB1,1);
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI:=(RSI1-50)*5;
R1:=SMA(RSI,3,1);
D1:=SMA(R1,3,1);
J1:=3*R1-2*D1;
RR1:=EMA(J1,5);
RR2:=REF(RR1,1);
RR:=RR1>RR2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
K1:=(K-50)*5;
K2:=SMA(K1,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
三宝:RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,COLORGREEN,NODRAW;
STICKLINE(三宝,5,0,3,0)COLORGREEN;

VA1:=HHV(HIGH,9)-LLV(LOW,9);
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(CLOSE+HIGH+LOW)/3;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
领先:=EMA(B1,5);
生命线:=EMA(VARD,1);
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=CROSS(A1,A2);
A4:=A1 A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*
SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1);
安全位:=20;
低位转强:=CROSS(A5,安全位);
开始拉升:=CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O;
A6:=LLV(C,500)=LLV(C,5) AND C/REF(C,1)>(1+9.8/100);
极地上涨:=A6;
极地:开始拉升>0 AND 开始拉升<400 OR 极地上涨>0 AND 极地上涨<400
OR (低位转强>0 AND 低位转强<400) OR (低位转强>0),COLORYELLOW,NODRAW;
STICKLINE(极地,10,15,3,0),COLORYELLOW;
{好底}
D:=EMA((C*3+H+L+O)/6,5);
买卖:=D,COLORGREEN,LINETHICK2;
A线:=HHV(D,13)COLORYELLOW,LINETHICK2;
B线:=LLV(D,13)COLORYELLOW,LINETHICK2;日平:="MACD.MACD#DAY"(12,26,9);
周平:="MACD.MACD#WEEK"(12,26,9);

JC:=(A线-B线);
壹:=COUNT(JC>REF(JC,1)AND A线>REF(A线,1),5)=1 AND JC>REF(JC,1)AND A线>REF(A线,1)AND D>=REF(D,1);
G1:=FILTER(壹=1,10);
G2:=BARSLAST(G1>0);
G3:=IFF(G2>0 AND G2<=10,1,0)=1 AND ((C-REF(C,G2))/REF(C,G2))*100>=5;
概壹:=(SUM(FILTER(G3,10),0)/SUM(G1>0,0))*100;
加1:=COUNT(日平>=0 AND 周平>=0,5)=1 AND 日平>=0 AND 周平>=0;
加2:=FILTER(D=A线 AND REF(D,1) ①:=FILTER(加1=1,10);
②:=BARSLAST(①>0);
③:=IFF(②>0 AND ②<=10,1,0)=1 AND ((C-REF(C,②))/REF(C,②))*100>=5;
概加1:=(SUM(FILTER(③,10),0)/SUM(①>0,0))*100;
好底:FILTER(COUNT(D=B线,3)>=2 AND D>B线,5),COLORBLUE,NODRAW;
STICKLINE(好底,15,20,3,0),COLORBLUE;
{抄底}
MMM:=1;
SVOL:=INTPART(SUM(V,0)/CAPITAL);
TJ0:=SVOL>REF(SVOL,1) OR BARSSINCE(CLOSE)=0;
S1:=BARSLAST(TJ0)+1;
TJJ2:=S1 S2:=IF(TJJ2,REF(S1,1)+1,S1);
S3:=SUM(TJJ2,0);
ZK1:="KD.K#WEEK"(9,3,3);
ZD2:="KD.D#WEEK"(9,3,3);
ZF1:="MACD.DIF#WEEK"(12,26,9);
ZA2:="MACD.DEA#WEEK"(12,26,9);
换手:=V/CAPITAL*100,LINETHICK0;
JCD:=CROSS(ZK1,ZD2) AND REF(ZD2,1)<30;
抄底:EXIST(JCD,MMM),COLORCYAN,NODRAW;
STICKLINE(抄底,20,25,3,0),COLORCYAN;
{只做牛市}
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
WLT1:=EMA(C,3);
WLT2:=EMA(C,5);
WLT3:=EMA(WLT2,5);
HP:=(HHV(CLOSE,10)-LLV(CLOSE,10))/CLOSE<0.10;
LB:=VOL/MA(VOL,5);
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
EMA3:=EMA(C,3);
TT:=FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10);
MM:=WLT1>REF(WLT1,1) AND REF(WLT1,1) GG1:=CROSS(WLT1,WLT2);
TYP:= (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=(CCI1+CCI2+CCI3+CCI4+CCI5)/2,COLORRED,LINETHICK2;
WLT91:=HHV(CCI,13);
WLT92:=LLV(CCI,13)<-100;
WLT95:=COUNT(WLT92,13)>=3;
WLT93:=CCI>WLT91;
WLT96:=CROSS(CCI,100);
TJ91:=WLT95 AND WLT96;
JLP:=FILTER(TJ91,5);
超买:=MA(C,10)*IF(CAPITAL=0,1.04,1.1);
超卖:=MA(C,10)*IF(CAPITAL=0,0.95,0.9);
TEND:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42);
DD:=TEND>REF(TEND,1) AND REF(TEND,1) >REF(TEND,2);
GG2:=CROSS(WLT1,TEND);
HRY1:=LLV(LOW,55);
HRY2:=HHV(HIGH,21);
GG3:=CHRY33;
JJ1:=C TJ1:=GG1;
TJ2:=GG2 AND JJ1;
TJ3:=GG1 AND GG3 ;
XG:=TJ1 OR TJ3 ;
XG2:=C1;
XG1:=XG AND XG2 AND C>HRY33 AND JLP;
XG3:=XG AND C XG11:=XG1 OR XG3;
W8:=XG11 OR XG1;
GET:=ZIG(3,5),COLORFFFFFF;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5 走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10 走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20 走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10 DTJD5:=IF(PL10 ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20 DTJD10:=IF(PL20 WLT11:=EN1 AND DTJZ5=1;
WLT22:=EN2 AND ZTJZ5=1;
WLT33:=WLT11 OR WLT22;
WLT01:=EN2 AND DTJZ10=1;
WLT02:=EN3 AND ZTJZ10=1;
WLT03:=WLT01 OR WLT02;
WLT:=WLT33 AND WLT03;
未来牛:W8 OR WLT,COLORLIMAGENTA,NODRAW;
STICKLINE(未来牛,5,10,3,0),COLORLIMAGENTA;
{底}
M5:=MA(CLOSE,5);
M4:=MA(CLOSE,4);
MA3:=MA(CLOSE,3);
VOL5:=MA(VOL,5);
底:M5>M4 AND SLOPE(M5,5)<0 AND SLOPE(M4,4)<0 AND SLOPE(MA3,3) AND REF(M4>MA3,1) AND CROSS(MA3,M4) AND VOL>VOL5,COLORRED,NODRAW;
STICKLINE(底,25,30,3,0),COLORRED;
?


更多股票公式相关资讯请关注www.igojr.com


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top