最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通信达公式编写 通达信清仓和减仓主图公式源码

通信达公式编写 通达信清仓和减仓主图公式源码

来源:网络 点击: 时间:2018-08-31

通信达公式编写 通达信清仓和减仓主图公式源码 www.igojr.com小编为您提供

【操盘线】:MA(((SLOPE(C,20)*5)+C),20),COLORRED,LINETHICK3;
IF(【操盘线】 DRAWNUMBER(ISLASTBAR,【操盘线】,CONST(MA(((SLOPE(C,20)*5)+C),20))),COLORMAGENTA;
Z2:=XMA((C+L)/2,3),LINETHICK2,COLORRED;
【高压】:XMA(Z2,20)*(1+80/1000),COLORCYAN,CIRCLEDOT;
【低撑】:XMA(Z2,32)*(1-100/1000),COLORYELLOW,CIRCLEDOT;
【超卖】:XMA(Z2,20)*(1-65/1000),COLORYELLOW,DOTLINE;
【超买】:XMA(Z2,32)*(1+50/1000),COLORWHITE,DOTLINE;
DRAWICON(ISLASTBAR,【高压】,15);
DRAWICON(ISLASTBAR,【低撑】,15);
【中轨】:(【高压】+【低撑】)/2,COLORLIGRAY,POINTDOT;
AA05:=MA(C,5),COLOR0099CC;

五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10);AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30),COLORMAGENTA;
三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR21:=(AA30-AA20) BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05 JC:=CROSS(0,五日乖离率) AND 三拾日乖离率REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1) 买入2:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;
DRAWTEXT(买入2,LOW*0.97,'←青云买入'),COLORRED;
DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;

?


更多股票公式相关资讯请关注www.igojr.com


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top