最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 通达信最新指标公式 通达信MACD波段线副图公式源码

通达信最新指标公式 通达信MACD波段线副图公式源码

来源:网络 点击: 时间:2019-05-18

通达信最新指标公式 通达信MACD波段线副图公式源码 www.igojr.com小编为您提供

?

?

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DPYJ:=(K+D)/2,LINETHICK2 ;
基本线:=EMA(DPYJ,5)/1.5 ;
基本线2:=EMA(DPYJ,2)/1.5,COLORRED;
AAA:=(C*2+H+L)/4*10;
DF:=EMA(AAA,13)-EMA(AAA,34);
DEAA:=EMA(DF,5);
MACD:2*(DF-DEAA)*5.5,COLOR00FFFF,LINETHICK1;
MACDFS:= IF(MACD<=0,MACD,0),COLOR00FF00,LINETHICK2;
STICKLINE(MACDFS>REF(MACDFS,1),MACDFS,0,0.5,0),COLOR00FF00;
MACDZS:=IF(MACD>=0,MACD,0),COLORFF00FF,LINETHICK2;
STICKLINE(MACDZS>REF(MACDZS,1),MACDZS,0,0.5,0),COLORFF00FF;
VAR2AAA:=REF(LOW,1);
VAR3AAA:=SMA(ABS(LOW-VAR2AAA),13,1)/SMA(MAX(LOW-VAR2AAA,0),13,1)*100;
VAR4AAA:=EMA(IF(CLOSE*1.2,VAR3AAA*13,VAR3AAA/13),13);
VAR5AAA:=LLV(LOW,34);

VAR6AAA:=HHV(VAR4AAA,34);
VAR7AAA:=IF(LLV(LOW,56),1,0);
VAR8AAA:=EMA(IF(LOW<=VAR5AAA,(VAR4AAA+VAR6AAA*2)/2,0),3)/618*VAR7AAA;
VAR9AAA:=EMA(CLOSE,5);
VAR10A:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(10);
VAR11A:=EMA(IF(LOW<=VAR5AAA,(VAR4AAA+VAR6AAA*2)/2,0),3)/618*VAR7AAA*(-1);
VAR12A:=EMA(CLOSE,5)*(-1);
减仓:=IF(VAR12A 增仓:IF(VAR9AAA 主力进场:IF(VAR8AAA>REF(VAR8AAA,1),VAR8AAA*8,0),COLOR10FFFF,LINETHICK1;
洗盘:IF(VAR11A>REF(VAR11A,1),VAR11A*8,0),COLORFFF810,LINETHICK1;
主力持仓:=LOW,COLORFF10FF,LINETHICK0;
?增减力度:=VAR10A*5,COLORWHITE;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:REF(XL1,1) STICKLINE(XL3,0,VAR8AAA*3,4,0),COLOR006EFF;
DRAWTEXT(XL3,VAR8AAA*2,'买'),COLOR0000FF;
↑买:DRAWICON(XL3,VAR8AAA*3,4),COLORRED;
V0:0,COLORFFA2AF;
洗盘启动 :=(MACD>0 AND MACD AND 增减力度>REF(增减力度,1) AND 增减力度>0 )*10;
强区:增减力度>REF(增减力度,1) AND MACD>REF(MACD,1);
TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
A:=REF(C,1);
RSI:=SMA(MAX(C-A,0),6,1)/SMA(ABS(C-A),6,1)*100;
A1:=(C/MA(C,5)-1)*100<-10;
A2:=(C/MA(C,13)-1)*100<-10;
A3:=(C/MA(C,34)-1)*100<-15;
A4:=RSI<18;
A5:=CCI<-120;
A6:=COUNT(ABS(C/REF(C,1)-1)*100>=6,30)>=1;
底部:(A1 AND A2 AND A3 AND A4 AND A5 AND A6)*20,COLOR00FFFF,LINETHICK2;
波段线:=5*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA
((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA
((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),LINETHICK1,COLORRED;
M1:=EMA(MA(波段线,5),3);
STICKLINE(波段线>108 AND 波段线>=M1,MACD,MACD,5,0),COLORF0F000;
STICKLINE(波段线<0 AND 波段线 启动:(FILTER((CROSS((EMA(CLOSE,2)-EMA(CLOSE,10)),EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2))
AND EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2)<0 AND CROSS(C,MA(C,20))),90))*20;

?

?

更多股票公式相关资讯请关注www.igojr.com


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top