最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 通达信公式 > 2017通达信指标公式 通达信副图买卖说清楚指标公式

2017通达信指标公式 通达信副图买卖说清楚指标公式

来源:网络 点击: 时间:2019-03-20

2017通达信指标公式 通达信副图买卖说清楚指标公式 www.igojr.com小编为您提供

?

?

?

YM:=MA(((WINNER((CLOSE * 0.9)) * 100) * CLOSE),3);

DC:=(IF((YM > 10),YM,0) / 2);

主力资金:DC,STICK,LINETHICK4,COLORRED;

资金均量:MA(DC,5),COLORGREEN;

资金流入线:DC,COLORYELLOW,LINETHICK1;

资金均量线:MA(DC,5),COLORMAGENTA;

盘1:=COST(0.33);

盘2:=COST(5);

盘3:=COST(15);

盘4:=COST(55);

盘5:=COST(97);

获利:=WINNER(CLOSE)*100;

套牢:=100-WINNER(CLOSE)*100;

DRAWTEXT_FIX(1,0.02,0,0,EXTERNSTR(0,1)),COLOR719FFF;

DRAWTEXT_FIX (1,0.4,0,1,'升浪:'),COLOR00FFFF;

DRAWNUMBER_FIX(1,0.41,0,0,CONST(COST(55))),COLOR007DFB;

DRAWTEXT_FIX (1,0.5,0,0,'预测:'),COLOR00FFFF;

DRAWNUMBER_FIX(1,0.55,0,0,CONST(COST(97))),COLOR007DFB;

{DRAWTEXTABS(675,25,'升浪:'+NUMTOSTRN(盘4,2)),COLOR00FFFF;

DRAWTEXTABS(520,40,'获利:'+NUMTOSTRN(获利,2)+'%'),COLOR00FFFF;

DRAWTEXTABS(600,40,'套牢:'+NUMTOSTRN(套牢,2)+'%'),COLOR00FFFF;

DRAWTEXTABS(675,40,'预测:'+NUMTOSTRN(盘5,2)),COLOR00FFFF;}

MA1:=MA(CLOSE,5);

MA2:=MA(CLOSE,10);

MA3:=MA(CLOSE,20);

MA4:=MA(CLOSE,30);

多头排列:= MA1>MA2 AND MA2>MA3 AND MA3>MA4 ;

MA60:=MA(C,60),COLORFFCC66; MA13:=MA(C,13),COLORFFCC66;

MA75:=MA(C,75),COLORFFCC66;

空头排列:= MA1

下跌趋势:=MA4

上升趋势:=MA4>REF(MA4,3) AND MA4>REF(MA4,1) ;

下降成:=CONST(IF(下跌趋势 AND MA1

上升成:=CONST(IF(上升趋势 AND REF(NOT(上升趋势),1),1,0));

DRAWTEXT_FIX(ISLASTBAR AND 下降成=1,0.8,0.2,0,'下降趋势成'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND 上升成=1,0.8,0.2,0,'上升趋势成'),COLOR8080FF;

一阴穿2线:=C/O<0.985 AND H>MA1 AND C

一阳穿2线:=C/O>1.016 AND LMAX(MA1,MA3);

发散度:=MA1/MA4;

均线下发散:=下跌趋势 AND 发散度<0.9 AND 发散度<0.99*REF(发散度,1);

均线上发散:=MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND MA4>REF(MA4,1) AND MA1>MA2 AND MA2>MA3 AND MA3>MA4;

AAAA1:=MAX(MAX(MA(V,5),MA(V,10)),MA(V,60))/MIN(MIN(MA(V,5),MA(V,10)),MA(V,60))<=1.4;

AAAA2:=MAX(MA(C,5),MA(C,10))/MIN(MA(C,5),MA(C,10))<=1.4;

DIFF:=EMA(C,12)-EMA(C,26);

DEA:=EMA(DIFF,9);

升:=CONST(IF( DIFF>0,1,0)),COLORRED;

DRAWTEXT_FIX(ISLASTBAR AND 升=1,0.1,0.35,0,'处于上升趋势'),COLOR8080FF;

降:=CONST(IF( DIFF<-0,1,0)),COLORRED;

DRAWTEXT_FIX(ISLASTBAR AND 降=1,0.1,0.35,0,'处于下降趋势'),COLORFFFF00;

VARF:=LOW*0.9;

MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);

MA20:=MA(CLOSE,20);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

均线密集:=DIFF>DEA AND K >D AND(MA5-MA10)<0.05 AND (MA20-MA5)<0.05 AND (MA10-MA5)<0.05 AND (MA5-MA20)<0.05;

A:=MA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),19);

B:=-100*(HHV(H,14)-C)/(HHV(H,14)-LLV(L,14));

DD:=EMA(-100*(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34)),4);

长线:=A+100;

短线:=B+100;

中线:=DD+100;

见顶:=(REF(中线,1)>85 AND REF(短线,1)>85 AND REF(长线,1)>65 AND CROSS(长线,短线));

顶区:=(中线 >REF(中线,1) AND REF(中线,1)>80 AND REF(短线,1)>95 OR REF(短线,2)>95

AND 长线>60 AND 短线<83.5 AND 短线<中线 AND 短线<长线+4);

底区:=长线<20 AND 中线<18 AND 短线<40 AND REF(短线,1)<5 AND 中线 >REF(中线,1)AND 短线 >REF(短线,1);

顶部:=FILTER(顶区,4);

{STICKLINE(见顶,H,(H+L)/2,3,0), ,COLORRED;

STICKLINE(顶部,H,(H+L)/2,3,0), ,COLORRED;}

VAR2N:=LLV(LOW,3)<=LLV(LOW,60);

VAR3N:= C>O AND (C/O>1.03 OR C>1.03*REF(C,1));

绝地反击:=IF(VAR2N AND VAR3N,90,0),COLORYELLOW,LINETHICK2;

LC := REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

A1:=SMA(MAX(C-LC,0),6,1);

B1:=SMA(ABS(C-LC),6,1);

界:=IF(C>LC,(REF(A1,1)*5-REF(B1,1)*5*0.5)/(0.5-1)+LC,LC+REF(B1,1)*5-REF(A1,1)*5/0.5),COLORWHITE;

MACD:=4*(DIFF-DEA);

{STICKLINE(MACD>0,中轴,中轴+MACD,0,1),COLORRED;

STICKLINE(MACD<0,中轴,中轴+MACD,0,1),COLORLIBLUE;

STICKLINE(MACD0,中轴,中轴+MACD,0,0 ),COLOR00BBFF;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,中轴,中轴+MACD,0,0 ),COLOR0011BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,中轴,中轴+MACD,0,0),COLORBB11BB;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,中轴,中轴+MACD,0,0),COLORFFBB11;}

缩头:=IF(MACD>0 AND REF(MACD,1)>REF(MACD,2) AND MACD< REF(MACD,1),1,0);

缩脚:=IF(MACD<0 AND REF(MACD,1)< REF(MACD,2) AND MACD>REF(MACD,1),1,0);

{ DRAWICON( 缩脚,(中轴+MACD)-0.1,1),COLOR00FF00;

DRAWICON(FILTER(缩头,3) AND 缩头,(中轴+MACD)+0.1,2),COLORFF00FF;

SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100,COLORRED;

DRAWICON(SAT>=100 AND MACD>0,(中轴+MACD)+0.2,12);}

ZDIF:=EMA(INDEXC,12)-EMA(INDEXC,26);

ZHIDEA:=EMA(ZDIF,9);

ZEMACD:=(ZDIF-ZHIDEA)*2/100,COLORSTICK;DK:=ZEMACD;

{STICKLINE(DK0,RC,RC+DK,0,0 ),COLOR00BBFF;

STICKLINE(DK>=REF(DK,1)AND DK>0,RC,RC+DK,0,0 ),COLOR0011BB;

STICKLINE(DK>REF(DK,1)AND DK<0,RC,RC+DK,0,0),COLORBB11BB;

STICKLINE(DK<=REF(DK,1)AND DK<0,RC,RC+DK,0,0),COLORFFBB11;}

Z缩头:=IF(DK>0 AND REF(DK,1)>REF(DK,2) AND DK< REF(DK,1),1,0);

Z缩脚:=IF(DK<0 AND REF(DK,1)< REF(DK,2) AND DK>REF(DK,1),1,0);

{ DRAWICON( Z缩脚,(RC+DK)-0.1,1),COLOR00FF00;

DRAWICON(FILTER(Z缩头,3) AND Z缩头,(RC+DK)+0.1,2),COLORFF00FF; }

TT:=240/FROMOPEN;

比:=TT;

J12:=(HIGH - ((HIGH - LOW) / 3));

J23:=(LOW + ((HIGH - LOW) / 3));

AAA1:=CONST(HHV(H,90));

BBB:=CONST(LLV(L,30))+2;

T1:=CONST(IF(CLOSE>界,1,0));

T2:=CONST(IF(CLOSE<界,1,0));

T3:=CONST(IF(C

T4:=CONST(IF(CROSS(CLOSE,界),1,0));

T5:=CONST(IF(CROSS(MA(CLOSE,13),CLOSE),1,0));

T6:=CONST(IF(C>=MA(C,5) AND C

T7:=CONST(IF(C>=MA(C,75),1,0));

VAR1Y:=VOL/CAPITAL*100;

VAR2Y:=LLVBARS(LOW,10);

VAR3Y:=(CLOSE-REF(OPEN,VAR2Y))/REF(OPEN,VAR2Y)*100;

VAR4Y:=REF(CLOSE,2)*0.865;

VAR5Y:=REF(CLOSE,13)*0.772;

VAR6Y:=MAX(VAR4Y,VAR5Y);

T9:=(CLOSE-VAR6Y)/CLOSE>0.2 AND VAR3Y<50 AND SUM(VAR1Y,5)/5>5;

T10:=CONST(IF(VAR2N AND VAR3N,1,0));

T11:=CONST(IF(缩脚,1,0));

T12:=CONST(IF( ZDIF<0 ,1,0));

T14:=CONST(IF(ZEMACD>=REF(ZEMACD,1) AND ZEMACD>0 AND ZDIF>=0 ,1,0));

DRAWTEXT_FIX(ISLASTBAR ,0.01,0.2,0,'看 均 线★'),COLORFFFFFF;

DRAWTEXT_FIX(ISLASTBAR ,0.01,0.35,0,'看MACD★'),COLORFFFFFF;

DRAWTEXT_FIX(ISLASTBAR ,0.01,0.5,0,'看 大 盘★'),COLORFFFFFF;

DRAWTEXT_FIX(ISLASTBAR ,0.01,0.65,0,'看 买 卖★'),COLORFFFFFF;

DRAWTEXT_FIX(ISLASTBAR AND T1=1,0.26,0.2,0,'短线上升持股'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND T2=1,0.26,0.2,0,'短线下降持币'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND T3=1,0.38,0.2,0,'长线下降持币'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND T7=1,0.38,0.2,0,'长线上升持股'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND T6=1,0.1,0.65,0,'低买点持股信号'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND T4=1,0.65,0.65,0,'加买点信号'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND T5=1,0.65,0.65,0,'短线卖出信号'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND T14=1,0.1,0.5,0,'处于上升趋势'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND T12=1,0.1,0.5,0,'处于下降趋势'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND T9=1,0.2,0.65,0,'阳线卖点'),COLOR00FFFF;

LC1:=REF(INDEXC,1);

ZRSI:=SMA(MAX(INDEXC-LC1,0),6,1)/SMA(ABS(INDEXC-LC1),6,1)*100,COLORD9D900;

X:=INDEXC;

Y:=INDEXO;

Z:=INDEXL;

I:=INDEXH;

急速超跌:=(X-MA(X,34))/MA(X,34)*100<-5;

当日收阳:=(I-Z)/Z>0.01 AND (X-Y)/Y>0.01 AND X/REF(X,1)>1.01;

超跌收阳:=CONST(IF(急速超跌 AND 当日收阳,1,0));

DRAWTEXT_FIX(ISLASTBAR AND 超跌收阳=1 ,0.65,0.5,0,'大盘短底,少量买'),COLOR8080FF;

A1W:=SMA(MAX(X-LC1,0),6,1);

B1W:=SMA(ABS(X-LC1),6,1);

界1:=IF(X>LC1,(REF(A1W,1)*5-REF(B1W,1)*5*0.5)/(0.5-1)+LC1,LC1+REF(B1W,1)*5-REF(A1W,1)*5/0.5),COLORWHITE;

TYP := (Z +I + X)/3;

YY:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;

BB:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

超卖:=CONST(IF(CROSS(BB,-200),1,0));

DRAWTEXT_FIX(ISLASTBAR AND 超卖=1 ,0.65,0.5,0,'大盘超卖,少量买'),COLOR8080FF;

KS:=(C-MA(C,17))/MA(C,17)*(-100);

RKS:=REF(KS,1);

MLS:=RKS/KS>=1.23 AND RKS>=8 AND C/REF(C,1)>=1.01;

大盘4:=CONST(IF(X>界1,1,0));

大盘3:=CONST(IF(X<界1,1,0));

大盘12{M13}:=CONST(IF(ZEMACD>REF(ZEMACD,1) AND ZEMACD>0 AND ZDIF<0 ,1,0));

大盘13:=CONST(IF(ZEMACD<0 AND ZDIF>0 ,1,0));

M整理:=CONST(IF( MACD<0 AND DIFF>0,1,0));

M走缓:=CONST(IF(MACD0 AND DIFF>0 ,1,0));

DRAWTEXT_FIX(ISLASTBAR AND M整理=1 ,0.26,0.35,0,'股价升途整理'),COLOR00FFFF;

DRAWTEXT_FIX(ISLASTBAR AND M走缓=1 ,0.26,0.35,0,'股价上升走缓'),COLOR00FFFF;

大盘16:=CONST(IF(ZEMACD0 ,1,0));

大盘11:=CONST(IF(KS>=17 ,1,0));

大盘2:=CONST(IF(MLS=1,1,0));

DRAWTEXT_FIX(ISLASTBAR AND 大盘4=1 ,0.26,0.5,0,'短线持股'),COLOR8080FF;

DRAWTEXT_FIX(大盘3=1 AND ISLASTBAR,0.26,0.5,0,'短线持币'),COLORFFFF00;

DRAWTEXT_FIX(大盘13=1 AND ISLASTBAR,0.3,0.5,0,'上升趋势,升途整理,谨慎'),COLOR00FFFF;

DRAWTEXT_FIX(大盘11=1 AND ISLASTBAR,0.2,0.65,0,'今日价超跌'),COLORFFFF00;

DRAWTEXT_FIX(大盘2=1 AND ISLASTBAR,0.2,0.65,0,'今日价反弹'),COLOR8080FF;

M弹:=CONST(IF(MACD>REF(MACD,1) AND MACD>0 AND DIFF<0,1,0));

{DRAWTEXT_FIX(大盘12=1 AND ISLASTBAR,0.3,0.5,0,'大盘下降趋势,反弹,谨慎'),COLORWHITE ;}

DRAWTEXT_FIX(大盘12 AND ISLASTBAR,0.5,0.5,0,'处于反弹区'),COLOR8080FF;

DRAWTEXT_FIX(M弹=1 AND ISLASTBAR,0.26,0.35,0,'反弹阶段小心'),COLORYELLOW;

MM3:=CONST(IF(RSI1

MM4:=CONST(IF((RSI1>=ZRSI),1,0));

DRAWTEXT_FIX(ISLASTBAR AND MM3=1,0.1,0.2,0,'弱于大盘走势'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND MM4=1,0.1,0.2,0,'强于大盘走势'),COLOR8080FF;

WJ:=(H+L+C)/3;

V1:=IF(H=L,1,H-MAX(O,C));

V2:=IF(H=L,1,MAX(C,O)-WJ);

V3:=IF(H=L,1,MIN(O,C)-L);

V4:=IF(H=L,1,WJ-MIN(C,O));

V5:=VOL/IF(H=L,4,H-L);

V6:=(V1*V5);

V7:=(V2*V5);

V8:=(V3*V5);

V9:=(V4*V5);

买盘1:=DYNAINFO(23)*比;

卖盘1:=DYNAINFO(22)*比;

买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));

卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));

买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);

卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);MFI:=(HIGH-LOW)*1000000/(VOL*比);

绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);

M1:=CONST(IF(空头排列 AND 均线下发散,1,0));

M2:=CONST(IF(多头排列 AND 均线上发散,1,0));

M3:=CONST(IF(空头排列 AND NOT(均线下发散),1,0));

M9:=CONST(IF(空头排列 ,1,0));

M10:=CONST(IF(多头排列 ,1,0));

MM1:=CONST(IF(均线密集,1,0));

MM2:=CONST(IF(上升趋势 AND NOT(一阴穿2线) AND REF(上升趋势,1),1,0));

M4:=CONST(IF(下跌趋势 AND NOT(一阳穿2线),1,0));

MM5:=CONST(IF(DIFF<0 AND MACD<0 AND MACD>REF(MACD,1),1,0));

MM7:=CONST(IF(ZEMACD>REF(ZEMACD,1) AND ZEMACD<0,1,0));

MM8:=CONST(IF(下跌趋势 AND REF(下跌趋势,1) AND NOT(一阳穿2线),1,0));

MM9:=CONST(IF(ZEMACD0,1,0));

量大:=(卖盘+买盘)/REF(VOL,1)>2;

M5:=CONST(量大);

量缩:=REF(VOL,1)/(卖盘+买盘)>1.5;

M6:=CONST(量缩);

卖量大:=(卖盘-买盘)/买盘>0.4;

M7:=CONST(卖量大);

买量大:=(买盘-卖盘)/卖盘>0.4;

M8:=CONST(买量大);

DRAWTEXT_FIX(ISLASTBAR AND M2=1,0.7,0.2,0,'多头发散,注意13日线得失'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND M7=1,0.7,0,0,'☆卖出量大于买入量40%以上'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND M8=1,0.7,0,0,'☆买入量大于卖出量40%以上'),COLOR8080FF;

{{DRAWTEXT_FIX(ISLASTBAR AND MM1=1,0.2,0,7,'均线密集,注意方向变化'),COLORYELLOW;}

DRAWTEXT_FIX(ISLASTBAR AND M1=1,0.4,0.2,0,'有加速下跌趋势'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND M2=1,0.4,0.2,0,'有加速上升趋势'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND M4=1,0.5,0.2,0,'下跌趋势未变,'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND MM2=1,0.5,0.2,0,'上升趋势未变'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND M9=1,0.8,0.2,0,'空头排列'),COLORFFFF00;

DRAWTEXT_FIX(ISLASTBAR AND M10=1,0.8,0.2,0,'多头排列'),COLOR8080FF;

DRAWTEXT_FIX(ISLASTBAR AND MM5=1,0.25,0.35,0,'下跌趋势趋缓,可能转折'),COLOR00FFFF;

{DRAWTEXT(VAR2N AND VAR3N,L*0.99,'反击'),COLOR00FF00;}

BIAS1:=(C-MA(C,6))/MA(C,6)*100;

BIAS2:=(C-MA(C,12))/MA(C,12)*100;

BIAS3:=(C-MA(C,24))/MA(C,24)*100;

BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;

乖离:=MA(BIAS,3);

乖:=CONST(IF(CROSS(BIAS,乖离) AND 乖离<-9,1,0)),COLOR00FFFF;

DRAWTEXT_FIX(ISLASTBAR AND 乖=1,0.65,0.35,0,'乖离买点'),COLOR8080FF;

坑:=CONST(IF( 乖离<-19,1,0)),COLORRED;

DRAWTEXT_FIX(ISLASTBAR AND 坑=1,0.65,0.5,0,'深坑买点'),COLOR8080FF;

?

更多股票公式相关资讯请关注www.igojr.com

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top