最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 同花顺公式 > 同花顺短线之王主图指标公式

同花顺短线之王主图指标公式

来源:网络 点击: 时间:2018-08-22

  趋势线:MA(CLOSE,21),COLORFFFFFF,LINETHICK2;

  生命线:MA(CLOSE,43),COLOR00FFFF,LINETHICK2;

  牛熊分界线:MA

  (CLOSE,250),COLOR0000FF,LINETHICK3;

  TY:=C;

  HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV

  (TY,2*10+1),10),10+1),10);

  LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV

  (TY,2*10+1),10),10+1),10);

  A:=REF(C,BARSLAST(HD));

  B:=REF(C,BARSLAST(LD));

  T1:=BARSLAST(HD)《BARSLAST(LD) AND NOT(HD) ;

  T2:=BARSLAST(HD)》BARSLAST(LD) AND NOT(LD);

  压力线:IF

  (T1,A,A),COLORFF00FF,POINTDOT,LINETHICK1;

  STICKLINE(T1,A,A,9,0),COLORFF00FF;

  支撑线:IF

  (T2,B,B),COLOR80FF00,POINTDOT,LINETHICK1;

  VAR3:=LLV(HIGH,240);

  VAR4:=100*(CLOSE-VAR3)/VAR3;

  VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV

  (LOW,528))*100;

  VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-

  LLV(CLOSE,530))*100;

  VAR7:=0;

  VAR8:=MA(HHV(CLOSE-REF(CLOSE,1),0),34)/MA(ABS

  (CLOSE-REF(CLOSE,1)),7)*100;

  VAR9:=MA(HHV(CLOSE-REF(CLOSE,1),0),13)/MA(ABS

  (CLOSE-REF(CLOSE,1)),13)*100;

  VARA:=BARSCOUNT(CLOSE);

  VARB:=VAR8《20 AND VAR9《23 AND VARA》35;

  VARC:=VARB AND COUNT(VARB,1)=1;

  VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);

  VARE:=EMA(VARD,5);

  VARF:=TROUGH(3,6,1)《4 AND CROSS(VARD,VARE);

  VAR10:=IF(TROUGH(3,16,1)=0 AND

  HIGH》LOW+0.04,4,0);

  VAR11:=ZIG(3,6)》REF(ZIG(3,6),1) AND REF(ZIG

  (3,6),1)《=REF(ZIG(3,6),2)

  AND REF(ZIG(3,6),2)《=REF(ZIG(3,6),3);

  VAR12:=ZIG(3,6)《REF(ZIG(3,6),1) AND REF(ZIG

  (3,6),1)》=REF(ZIG(3,6),2)

  AND REF(ZIG(3,6),2)》=REF(ZIG(3,6),3);

  VAR13:=ZIG(3,22)》REF(ZIG(3,22),1) AND REF(ZIG

  (3,22),1)《=REF(ZIG(3,22),2)

  AND REF(ZIG(3,22),2)《=REF(ZIG(3,22),3);

  VAR14:=ZIG(3,22)《REF(ZIG(3,22),1) AND REF(ZIG

  (3,22),1)》=REF(ZIG(3,22),2)

  AND REF(ZIG(3,22),2)》=REF(ZIG(3,22),3);

  VAR15:=ZIG(3,51)》REF(ZIG(3,51),1) AND REF(ZIG

  (3,51),1)《=REF(ZIG(3,51),2)

  AND REF(ZIG(3,51),2)《=REF(ZIG(3,51),3);

  VAR16:=ZIG(3,51)《REF(ZIG(3,51),1) AND REF(ZIG

  (3,51),1)》=REF(ZIG(3,51),2)

  AND REF(ZIG(3,51),2)》=REF(ZIG(3,51),3);

  VAR17:=ZIG(3,72)》REF(ZIG(3,72),1) AND REF(ZIG

  (3,72),1)《=REF(ZIG(3,72),2)

  AND REF(ZIG(3,72),2)《=REF(ZIG(3,72),3);

  VAR18:=ZIG(3,72)《REF(ZIG(3,72),1) AND REF(ZIG

  (3,72),1)》=REF(ZIG(3,72),2)

  AND REF(ZIG(3,72),2)》=REF(ZIG(3,72),3);

  VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

  VAR1A:=EMA(VAR19,100);

  VAR1B:=2*(VAR19-VAR1A);

  VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);

  VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

  VAR1E:=EMA(VAR1D*0.97,3);

  VAR1F:=(HIGH+LOW+CLOSE)/3;

  VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV

  (VAR1F,14));

  VAR21:=CROSS(VAR1E,LOW);

  买点1:=VAR10;

  买点2:=(VAR11+VAR13+VAR15+VAR17);

  卖点1:=(VAR12+VAR14+VAR16+VAR18),LINETHICK2;

  VAR22:=买点1 AND VARF AND VARC AND VAR21 AND

  VAR4《0 AND VAR5=0

  AND VAR6=0 AND VAR20《(-110);

  VAR1:=MA(CLOSE,5);

  VAR2:=MA(CLOSE,10);

  VAR31:=MA(CLOSE,30);

  VARB1:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);

  VARC1:=INTPART(VARB1*100)/100;

  VARD1:=EMA(CLOSE,5)-EMA(CLOSE,10);

  VARE1:=EMA(VARD1,9);

  VAR131:=REF(VARE1,1);

  VAR141:=VARE1;

  VAR151:=VAR141-VAR131;

  VAR161:=REF(VARD1,1);

  VAR171:=VARD1;

  VAR181:=VAR171-VAR161;

  VAR191:=OPEN;

  VAR1A1:=CLOSE;

  DRAWTEXT(买点1》0,L-0.01,‘▲爱心出击’),colorred;

  DRAWTEXT(买点2》0,L-0.01,‘▲爱心出击’),COLORFF00FF;

  DRAWTEXT(卖点1》0,H+0.1,‘▼卖点’),COLOR00FF00;

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top