最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 同花顺公式 > 同花顺股票公式:黑码二

同花顺股票公式:黑码二

来源:网络 点击: 时间:2019-03-26

  同花顺股票公式有哪些?同花顺有哪些股票公式?下面股票知识网为您介绍同花顺股票公式。

  黑码二

  攻击线:MA(CLOSE,5),LINETHICK1;

  操盘线:MA(CLOSE,10),LINETHICK1;

  魔鬼线:MA(CLOSE,20),LINETHICK1;

  生命线:MA(CLOSE,30),LINETHICK2;

  决策线:MA(CLOSE,60),LINETHICK1;

  趋势线:MA(CLOSE,120),LINETHICK2;

  牛熊线:MA(CLOSE,250),LINETHICK3;

  STICKLINE(C/REF(C,1)》1.07,O,C,2,0),COLORRED;

  STICKLINE(REF(C,1)/C》1.07,O,C,2,0),COLOR00FF00;

  C2:=REF(C,1);

  涨停:=IF((C-C2)*100/C2》=(10-0.01*100/C2),1,0);

  STICKLINE(涨停,OPEN,CLOSE,-1,0),COLORYELLOW;

  STICKLINE(涨停,H,L,0,0),COLORYELLOW;

  跌停:=IF((C2-C)*100/C2》=(10-0.01*100/C2),1,0);

  STICKLINE(跌停,OPEN,CLOSE,-1,0),COLORBLUE;

  STICKLINE(跌停,H,L,0,1),COLORBLUE;

  大阳线:=IF((C-C2)*100/C2》=5,1,0)&&IF((C-C2)*100/C2《(10-0.01*100/C2),1,0) OR IF((C-O)*100/O》=5,1,0)&&IF((C-C2)*100/C2《(10-0.01*100/C2),1,0);

  STICKLINE(大阳线,OPEN,CLOSE,-1,0),COLORRED;

  STICKLINE(大阳线,H,L,0,1),COLORRED;

  大阴线:=IF((C2-C)*100/C2》=5,1,0)&&IF((C2-C)*100/C2《(10-0.01*100/C2),1,0) OR IF((O-C)*100/O》=5,1,0)&&IF((C2-C)*100/C2《(10-0.01*100/C2),1,0);

  STICKLINE(大阴线,OPEN,CLOSE,-1,0),COLORGREEN;

  STICKLINE(大阴线,H,L,0,1),COLORGREEN;

  TY:=C;

  AA1:=REF(TY,10)=HHV(TY,2*10+1); BB1:=FILTER(AA1,10); C1:=BACKSET(BB1,10+1); HD:=FILTER(C1,10);

  AA2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(AA2,10); CC2:=BACKSET(B2,10+1); LD:=FILTER(CC2,10);

  前期高位:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT,LINETHICK3;

  前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT,LINETHICK3;

  DRAWICON(CROSS(MA(C,5),MA(C,24)) ,MA(C,5),1);

  W1:=C=HHV(C,20);

  W2:=BARSLAST(W1);

  W3:=IF(W2》0,REF(C,W2),REF(C,W2));

  W4:=CROSS(C,REF(W3,1));

  DRAWICON(W4 AND COUNT(W4,5)=1,LOW,3);

  BB:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);

  分水岭:=IF(MA(CLOSE,17)《BB,BB,MA(CLOSE,17));

  操作线:=分水岭-(EMA(C,3)-分水岭);

  DRAWTEXT(CROSS(分水岭,操作线),分水岭-0.5,‘B’);

  MAJ2:=EMA(C,3);

  MAJ5:=EMA(C,7);

  MAJ13:=EMA(C,13);

  MAJ34:=EMA(C,34);

  MAJ55:=EMA(C,55);

  YCXJ:=MAJ5》=REF(MAJ5,1);

  H1:=MAX(MAX(MAJ5,MAJ13),MAJ34);

  L1:=MIN(MIN(MAJ5,MAJ13),MAJ34);

  DRAWTEXT(H1《C AND O《L1 AND YCXJ AND MAJ2》REF(MAJ2,1),LOW*0.96,‘◇’);

  {回归卖出图标}

  RSV回归:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;

  K回归:=SMA(RSV回归,3,1);

  D回归:=SMA(K回归,3,1);

  J回归:=3*K回归-2*D回归;

  VAR回归3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}

  VAR回归4:=EMA(EMA(EMA(VAR回归3,4),4),4);{可将3该为4,信号少点}

  E回归:=(VAR回归4-REF(VAR回归4,1))/REF(VAR回归4,1)*100;

  F回归:=MA(E回归,3)+0.03;

  G回归:=MA(E回归,1);

  DRAWICON(CROSS(F回归,G回归) AND J回归》65,HIGH*1.02,15),COLORGREEN;

  {双底买入部分}

  VAR10A:=IF(TROUGH(3,16,1)=0 AND HIGH》LOW+0.04,4,0);

  VAR11B:=ZIG(3,6)》REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)《=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)《=REF(ZIG(3,6),3);

  VAR13C:=ZIG(3,22)》REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)《=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)《=REF(ZIG(3,22),3);

  VAR15D:=ZIG(3,51)》REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)《=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)《=REF(ZIG(3,51),3);

  VAR17E:=ZIG(3,72)》REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)《=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)《=REF(ZIG(3,72),3);

  买点1A:=VAR10A;

  买点2A:=(VAR11B+VAR13C+VAR15D+VAR17E);

  买入:=COUNT(买点1A OR 买点2A,15)=2 AND (买点1A OR 买点2A) AND COUNT(C/REF(C,1)》1.07,15)》=1;

  DRAWICON(买入,LOW*0.97,18);

  {猎豹出击智能选股指标源码} VARR1:=(SUM(H,8)-SUM(L,8))/2;

  RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  KC:=SMA(RSVC,3,1);

  DC:=SMA(KC,3,1);

  JC:=3*KC-2*DC,COLORRED,LINETHICK1;

  强势:=80,COLORMAGENTA,LINETHICK1;

  平衡:=50,COLORRED,LINETHICK1;

  弱势:=20,COLORBLUE,LINETHICK1;

  RSV:=(CLOSE-LLV(LOW,40))/(HHV(HIGH,40)-LLV(LOW,40))*100;

  K:=SMA(RSV,3,1),COLORWHITE;

  D1:=SMA(K,3,1),COLORYELLOW;

  K1:=SMA(RSV,10,1),COLORWHITE;

  D:=SMA(K1,10,1),COLORRED;

  J:=3*K-2*D1,COLORFF00FF;

  压力线:=REF(HHV(K,20),20),COLORYELLOW;

  AA:=CROSS(JC,强势) AND CROSS(JC,平衡){ AND J》压力线} AND C/REF(C,1)》1.05 AND REF(C,1)/REF(C,2)《1.059;

  BB0412:=CROSS(JC,平衡) AND CROSS(JC,20){ AND J》压力线} AND C/REF(C,1)》1.05 AND REF(C,1)/REF(C,2)《1.059;

  起跳1:=CROSS(JC,强势) AND C》EXPMA(CLOSE,12) AND JC-REF(JC,1)》30 OR AA;

  起跳2:=CROSS(JC,20) AND MA(C,5)》MA(C,30) AND C/REF(C,1)》1.014 OR BB;

  起跳3:=CROSS(JC,平衡) AND C》EXPMA(C,12) AND C/REF(C,1)》1.014;

  起跳4:=AA AND C》EXPMA(C,12) AND C/REF(C,1)》1.014;

  起跳5:=BB AND C/REF(C,1)》1.014;

  起跳6:=JC-REF(JC,1)》30 AND C/REF(C,1)》1.05{ AND J》压力线} AND REF(C,1)/REF(C,2)《1.059; {红三兵:=CROSS(JC,80) AND REF(CROSS(JC,50),1) AND REF(CROSS(JC,20),2) AND C/REF(C,1)》1.014;}

  DRAWICON(AA OR BB0412 OR 起跳6,L*0.98,11){ OR 红三兵};

  AAA1:=MA(CLOSE,5);

  AAA2:=MA(CLOSE,20);

  AAA3:=MA(CLOSE,30);

  A偏离度:=(CLOSE-HHV(HIGH,250))/HHV(HIGH,250)*100;

  B偏离度:=(CLOSE-HHV(HIGH,120))/HHV(HIGH,120)*100;

  C偏离度:=(LOW-MA(CLOSE,13))/MA(CLOSE,13)*100;

  N日内13日线走向:=(MA(CLOSE,13)-REF(MA(CLOSE,13),5))/REF(MA(CLOSE,13),5)*100;

  DRAWTEXT(“KDJ.D”》(REF(“KDJ.D”,1)+1) AND A偏离度= B偏离度 AND COUNT(AAA1》AAA2 AND AAA2》AAA3 ,2)=2 AND “KDJ.J”》20 AND “MACD.MACD”》0 AND C偏离度》-12 AND B偏离度-REF(B偏离度,1)》1 AND N日内13日线走向-C偏离度《12 AND B偏离度》(C偏离度-1.3),LOW*0.97,‘吻’),COLORRED;

  DRAWTEXT(“KDJ.D”》(REF(“KDJ.D”,1)+1) AND B偏离度》A偏离度 AND B偏离度》C偏离度,LOW*0.95,‘飞吻’),COLORRED;

  更多同花顺股票公式知识请关注股票知识网

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top