最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 同花顺公式 > 同花顺股票公式:变异MACD指标

同花顺股票公式:变异MACD指标

来源:网络 点击: 时间:2019-05-18

  同花顺股票公式有哪些?同花顺股票公式是什么?下面股票知识网为您介绍:同花顺股票公式。

  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  K:=SMA(RSV,3,1),colorwhite;

  D:=SMA(K,3,1),coloryellow;

  J:=3*K-2*D,COLORFF00FF;

  A:=250;

  DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));

  DEA:=EMA(DIFF,9),colorblue,LINETHICK0;

  MACD:=2*(DIFF-DEA);

  MM:=IF(MACD《 0,MACD,0);

  JJ:=MM》 REF(MM,1);

  ZZ:=REF(JJ,1)=1;

  准备:=(JJ AND ZZ)*DEA;

  STICKLINE(准备=DEA,1,-1,2,1),COLORFFFF00;

  JH:=HHV(MAX(K,MAX(D,J)),A);

  DH:=HHV(MAX(DIFF,DEA),A);

  SH:=INTPART(JH/DH)/2;

  DIFF50:=SH*DIFF+50,COLORFFFF00;

  DEA50:=SH*DEA+50,colorblue;

  STICKLINE(DIFF50》DEA50,0,1.5*(DIFF50-DEA50),0,0),colorred;

  STICKLINE(DIFF50《DEA50,0,1.5*(DIFF50-DEA50),0,0),COLORFFFF00;

  红柱:IF(1.5*(DIFF50-DEA50)》REF(1.5*(DIFF50-DEA50),1),1.5*(DIFF50-DEA50),0),

  STICK,;

  绿柱:IF(1.5*(DIFF50-DEA50)《REF(1.5*(DIFF50-DEA50),1),

  1.5*(DIFF50-DEA50),0),STICK,colorgreen;

  缩头:=IF(1.5*(DIFF50-DEA50)》0 AND REF(1.5*(DIFF50-DEA50),1)》REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)《 REF(1.5*(DIFF50-DEA50),1),1,0);

  缩脚:=IF(1.5*(DIFF50-DEA50)《0 AND REF(1.5*(DIFF50-DEA50),1)《 REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)》REF(1.5*(DIFF50-DEA50),1),1,0);

  杀多:=IF(1.5*(DIFF50-DEA50)《0 AND REF(1.5*(DIFF50-DEA50),1)》 REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)《REF(1.5*(DIFF50-DEA50),1),1,0);

  诱空:=IF(1.5*(DIFF50-DEA50)》0 AND REF(1.5*(DIFF50-DEA50),1)《 REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)》REF(1.5*(DIFF50-DEA50),1),1,0);

  阻力:=IF(CROSS(C,MA(C,20)) OR CROSS(C,MA(C,60)),1,0);

  DRAWTEXT(FILTER(杀多,3) AND 杀多,1.5*(DIFF50-DEA50),‘杀多’),COLORFF00FF;

  DRAWTEXT(FILTER(缩头,3) AND 缩头,1.5*(DIFF50-DEA50)+0.2,‘卖’),COLORFF00FF;

  DRAWTEXT(FILTER(诱空,3) AND 诱空,1.5*(DIFF50-DEA50),‘?洗盘’),COLOR00FF00;

  DRAWTEXT(FILTER(缩脚,3) AND 缩脚,1.5*(DIFF50-DEA50)-0.2,‘买’),COLOR00FF00;

  DRAWTEXT(FILTER(阻力,16) AND 1.5*(DIFF50-DEA50)》=0,1.5*(DIFF50-DEA50)+0.01,‘¤阻力’),COLOR00FFFF;

  VRA:=REF(CLOSE,1);

  VRB:=SMA(MAX(CLOSE-VRA,0),6,1)/SMA(ABS(CLOSE-VRA),6,1)*100;

  VRC:=(2*CLOSE+HIGH+LOW)/4;

  VR0:=LLV(LOW,34);

  VR1:=HHV(HIGH,34);

  VR2:=EMA((VRC-VR0)/(VR1-VR0)*100,6);

  VR3:=EMA(0.667*REF(VR2,1)+0.333*VR2,4);

  VA1:=(REF(HIGH,1)+REF(LOW,1))/2;

  VA2:=MA(CLOSE,20)+2*STD(CLOSE,20);

  VA3:=REF(CLOSE,1);

  VA4:=SMA(MAX(CLOSE-VA3,0),7,1)/SMA(ABS(CLOSE-VA3),7,1)*100;

  VA5:=CROSS(79,VA4);

  VA6:=FILTER(VA5,4);

  VVD:=MA(CLOSE,80)-MA(CLOSE,10)/3;

  VA7:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

  X1:=CROSS(VA1,VA2) OR VA6;

  X2:=CROSS(84,VRB);

  STICKLINE(X1 OR X2,1.5*(DIFF50-DEA50)*1.05,1.5*(DIFF50-DEA50)*1.08,3,0);

  Y1:=IF(COUNT(CLOSE《REF(CLOSE,1),8)/8》0.3 AND COUNT(VA2》VA3,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE》OPEN,1,0);

  Y2:=IF(CLOSE《VVD AND VOL/240》MA(VOL,5)/240 AND CLOSE》REF(CLOSE,1)*1.08 AND CLOSE《MA(CLOSE,13)*1.3,1,0);

  Y3:=CROSS(VA7,10);

  Y4:=IF(COUNT(CLOSE《REF(CLOSE,1),8)/8》0.3 AND COUNT(VR2》VR3,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE》OPEN,1,0);

  STICKLINE(Y1 OR Y2 OR Y3 OR Y4,1.5*(DIFF50-DEA50)*0.90,1.5*(DIFF50-DEA50)*0.99,3,0);

  DD:=C=HHV(C,180);

  EE:=DEA《 REF(DEA,1) AND REF(DEA《 REF(DEA,1),1)=1;

  CC:=C》 REF(C,1) AND REF(C》 REF(C,1),1)=1;

  上升背离:(CC AND EE)*1.5*(DIFF50-DEA50),LINETHICK2,colorwhite;

  顶背离:(DD AND EE AND DEA《 HHV(DEA,180))*3*ABS(DIFF50-DEA50),STICK,LINETHICK3,colorgreen;

  FF:=C=LLV(C,180);

  GG:= DEA》 REF(DEA,1) AND REF(DEA》 REF(DEA,1),1)=1;

  LL:=C《 REF(C,1) AND REF(C《 REF(C,1),1)=1;

  下降背离:(LL AND GG)*1.5*(DIFF50-DEA50),LINETHICK2,coloryellow;

  底背离:(FF AND GG AND DEA》 LLV(DEA,180))*3*(DIFF50-DEA50),STICK,LINETHICK3,colorred

  更多同花顺股票公式知识请关注股票知识网

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top