最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 同花顺公式 > 同花顺选股指标 同花顺选股指标合集:

同花顺选股指标 同花顺选股指标合集:

来源:网络 点击: 时间:2019-03-25

www.igojr.com带来同花顺选股指标 同花顺选股指标合集:

  次日涨停

  W1:=C=HHV(C,20);

  W2:=BARSLAST(W1);

  W3:=IF(W2》0,REF(C,W2),REF(C,W2));

  W4:=CROSS(C,REF(W3,1));

  W4 AND COUNT(W4,5)=1;

  黄转紫选股

  DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);

  DEA:=EMA(DIFF,9);

  MACD:=(DIFF-DEA)*2;

  紫柱:MACD《0 AND MACD》REF(MACD,1) AND REF(MACD,1)《REF(MACD,2);

  低位金叉选股

  DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);

  DEA:=EMA(DIFF,9);

  MACD:=(DIFF-DEA)*2;

  低位金叉:CROSS(DIFF,DEA) AND DIFF《-0.1;

  二次金叉选股

  DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);

  DEA:=EMA(DIFF,9);

  MACD:=(DIFF-DEA)*2;

  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA》=0));

  二次金叉:CROSS(DIFF,DEA) AND DEA《0 AND COUNT(JCCOUNT=2,21)=1;

  绝地反弹

  (1)

  VAR1:=REF(LOW,1);

  VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),13,1)*100;

  VAR3:=EMA(IF(CLOSE*1.2,VAR2*13,VAR2/13),13);

  VAR4:=LLV(LOW,34);

  VAR5:=HHV(VAR3,34);

  VAR6:=IF(LLV(LOW,55),1,0);

  VAR7:=EMA(IF(LOW《=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;

  XL1:=MA(LOW,2)*0.96;

  XL2:=MA(LOW,26)*0.85;

  XL3:=REF(XL1,1)《XL2 AND REF(XL1,1)《XL1 AND REF(XL1,1)《REF(XL1,2);

  启动:=IF(XL3,0,VAR7*3),COLORRED;

  XG:启动》25;

  (2)

  BACKSET( (REF(CLOSE,1)《REF(OPEN,1) AND

  CLOSE》OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE《0.002),2);

  A2:=FILTER(A1《=V3,10);

  ND CAPITAL《300000000

  REF(V,1) = LLV(V,4) AND V 》=REF(V,1)

  HHV(V,3)=REF(V,1) AND HHV(V,5)=REF(V,1) AND HHV(V,21)=REF(V,1)

  AND V 》=REF(V,1)

  01》0 AND T02》0;

  1.三线粘合

  M:=1;

  M5:=MA(CLOSE,5);

  M10:=MA(CLOSE,10);

  M20:=MA(CLOSE,20);

  K1:=MAX(MAX(M5,M10),MAX(M10,M20));

  K2:=MIN(MIN(M5,M10),MIN(M10,M20));

  A:=MAX(M5,MAX(M10,M20))/MIN(M5,MIN(M10,M20))《1+0.03*M;

  A1:=(K1/K2-1)《0.005;

  A2:=(K1/K2-1)《0.005;

  A3:=V》REF(V,1)*1.5 AND V》MA(V,5);

  XG:A AND A1 AND A2 AND A3 AND C》O AND V》 REF(V,1) AND CAPITAL《=300000000;

  2.三条线粘合

  N1:=5;N2:=10;N3:=20;M:=1;

  MA1:=MA(C,N1);MA2:=MA(C,N2);MA3:=MA(C,N3);

  A3:=V》REF(V,1)*1.5 AND V》MA(V,5);

  MAX(MA1,MAX(MA2,MA3))/MIN(MA1,MIN(MA2,MA3))《1+0.01*M

  AND C》O AND V》 REF(V,1) AND FINANCE(7)《=300000000

  AND A3 AND CAPITAL《=300000000;

  3.均线粘合

  M:=1;

  M5:=MA(CLOSE,5);

  M10:=MA(CLOSE,10);

  M20:=MA(CLOSE,20);

  K1:=MAX(MAX(M5,M10),MAX(M10,M20));

  K2:=MIN(MIN(M5,M10),MIN(M10,M20));

  A:=MAX(M5,MAX(M10,M20))/MIN(M5,MIN(M10,M20))《1+0.01*M;

  A1:=(K1/K2-1)《0.005;

  A2:=(K1/K2-1)《0.005;

  A3:=V》REF(V,1)*1.5 AND V》MA(V,5);

  XG:A AND A1 AND A2 AND A3 ;

  3. 金叉选股指标

  快线:=EMA(EMA(EMA(EMA(CLOSE,2),2),2),2);

  慢线:=EMA(REF(快线,1),2);

  A3:=V》REF(V,1)*1.5 AND V》MA(V,5);

  XG:CROSS(快线,慢线) AND C》O AND

  V》=MA(V,21) AND V》 REF(V,1) AND CAPITAL《=300000000 ;

  4.角度

  MA5:=MA(C,5);

  MA10:=MA(C,10);

  MA20:=MA(C,20);

  V0:CROSS(MA5,MA10) AND CROSS(MA10,MA20) AND

  CROSS(MA5,MA20) ;

  IF(角度MA3》45 AND 角度MA5》40 AND 角度MA10》10

  AND 角度MA20》20 AND MA(C,135)》REF(MA(C,135),1),

  1,0),COLOR00FF00

  1.聚宝盆

  DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);

  DEA:=EMA(DIFF,M);

  MACD2:=2*(DIFF-DEA);

  HHV(MACD2,4)《0 AND MACD2》REF(MACD2,1) AND REF(MACD2,1)《REF(MACD2,2) AND REF(MACD2,2)《REF

  (MACD2,3);

  2.强势股

  {SJXXG四均线选股}

  MA3:=MA(C,3);

  MA5:=MA(C,5);

  MA10:=MA(C,10);

  MA20:=MA(C,20);

  V0:=MA(C,3)》REF(MA(C,3),1) AND MA(C,5)》REF(MA(C,5),1) AND C》MA(C,3)

  AND MA(C,3)》MA(C,5) ; {均线C,MA3,MA5多头排列并向上;}

  角度MA3:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;

  角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

  角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

  角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;

  选股MA20:IF(角度MA3》45 AND 角度MA5》45 AND 角度MA10》60 AND 角度MA20》45 AND MA(C,250)》REF(MA(C,250),1),

  1,0),COLOR00FF00;

  {设计思路:

  1.3日均线角度大于45度;

  2:5日均线角度大于45度;

  3:10日均线角度大于60度;

  4.20日均线角度大于45度;

  5.MA250向上;};

  3。紫色冲关

  (1)。

  CROSS( CLOSE,MA(C,30))

  AND CLOSE》MA(C,22) AND CLOSE》MA(C,30)AND

  COUNT(MA(CLOSE,13)》REF(MA(CLOSE,13),1),1)

  AND COUNT(MA(CLOSE,8)》REF(MA(CLOSE,8),1),1)

  AND COUNT(MA(CLOSE,20)》REF(MA(CLOSE,20),1),1)

  AND CLOSE/OPEN》1.015

  AND DYNAINFO(37)》0.2% COLORLIBLUE;

  (2)。

  QSXS:=MA(CLOSE,8)》REF(MA(CLOSE,8),1) AND MA(CLOSE,3)》REF(MA(CLOSE,3),1) AND MA(CLOSE,5)》REF(MA(CLOSE,5),1);

  DXJC:=CROSS(CLOSE,MA(C,21)) AND CLOSE》MA(C,13) AND CLOSE/OPEN》1.015;

  HSL:=VOL/CAPITAL*100;

  选股:QSXS AND DXJC AND HSL》2;

  (3)。

  {SJXXG四均线选股}

  MA3:=MA(C,1);

  MA5:=MA(C,3);

  MA10:=MA(C,5);

  MA20:=MA(C,10);

  V0:=MA(C,1)》REF(MA(C,1),0.5) AND MA(C,3)》REF(MA(C,3),0.5) AND C》MA(C,1)

  AND MA(C,1)》MA(C,1) ; {均线C,MA3,MA5,MA10,MA20多头排列并向上;}

  角度MA3:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;

  角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

  角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

  角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;

  选股MA20:IF(角度MA3》50 AND 角度MA5》40 AND 角度MA10》30

  AND 角度MA20》20 AND MA(C,250)》REF(MA(C,250),1),

  1,0),COLOR00FF00;

  {设计思路:

  1.1日均线角度大于40度;

  2:3日均线角度大于40度;

  3:5日均线角度大于50度;

  4.10日均线角度大于40度;

  5.MA135向上;};

  (4)。

  {SJXXG四均线选股}

  MA3:=MA(C,5);

  MA5:=MA(C,10);

  MA10:=MA(C,15);

  MA20:=MA(C,20);

  V0:=MA(C,5)》REF(MA(C,10),1) AND MA(C,10)》REF(MA(C,15),1)

  AND MA(C,15)》MA(C,20) ; {均线C,MA3,MA5多头排列并向上;}

  角度MA3:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;

  角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

  角度MA10:=ATAN((MA10/REF(MA3,1)-1)*100)*180/3.1416;

  角度MA20:=ATAN((MA20/REF(MA5,1)-1)*100)*180/3.1416;

  选股MA20:IF(角度MA3》42 AND 角度MA5》25 AND 角度MA10》15 AND 角度MA20》10

  AND MA(C,135)》REF(MA(C,135),1),

  1,0),COLOR00FF00;

  {设计思路:

  1.3日均线角度大于30度;

  2:5日均线角度大于40度;

  3:10日均线角度大于45度;

  4.20日均线角度大于40度;

  5.MA135向上;};

  (5).5日最底

  V5:=LLV(V,5);

  QSXS:=MA(CLOSE,5)》REF(MA(CLOSE,5),1) AND MA(CLOSE,8)》REF(MA(CLOSE,8),1)

  AND MA(CLOSE,21)》REF(MA(CLOSE,21),1);

  DXJC:=CROSS(CLOSE,MA(C,21)) AND CLOSE》MA(C,21) AND CLOSE/OPEN》1.015;

  HSL:=VOL/CAPITAL*100;

  选股:V5 AND QSXS AND DXJC AND HSL》2;

  1.。..{蓄势待发}

  V0:=EMA(C,5);

  EMA10:=EMA(C,10);

  EMA20:=EMA(C,20);

  EMA30:=EMA(C,30);

  EMA60:=EMA(C,60);

  M1:=1000*EMA10/EMA60《=1015 AND 1000*EMA10/EMA60》=975;

  M2:=1000*EMA20/EMA60《=1020 AND 1000*EMA20/EMA60》=980;

  M3:=1000*EMA30/EMA60《=1015 AND 1000*EMA30/EMA60》=985;

  M4:=M1 AND M2 AND M3 AND CROSS(V0,EMA10);

  M5:=M1 AND M2 AND M3 AND CROSS(V0,EMA30);

  T1:=1000*EMA10/EMA30《=1010 AND 1000*EMA10/EMA30》=990;

  T2:=1000*EMA20/EMA30《=1010 AND 1000*EMA20/EMA30》=990;

  T3:=T1 AND T2 AND CROSS(V0,EMA10);

  T4:=T1 AND T2 AND CROSS(V0,EMA30);

  M4 OR M5 OR T3 OR T4;

  2.短线之王

  VAR1:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));

  CROSS(VAR1,-87) AND OPEN《MA(CLOSE,5) AND CLOSE》=1.099*REF(CLOSE,1) AND INDEXC》0.98*REF(INDEXC,1) AND CLOSE《=1.47*LLV

  (CLOSE,58);

  3.枪挑小梁王

  W1:=C=HHV(C,20);

  W2:=BARSLAST(W1);

  W3:=IF(W2》0,REF(C,W2),REF(C,W2));

  W4:=CROSS(C,REF(W3,1));

  枪挑小梁王:W4 AND COUNT(W4,5)=1;

  4.短线之王

  VAR1:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));

  CROSS(VAR1,-87) AND OPEN《MA(CLOSE,5) AND CLOSE》=1.099*REF(CLOSE,1) AND INDEXC》0.98*REF(INDEXC,1) AND CLOSE《=1.47*LLV

  (CLOSE,58);

  5.财务突破选股

  {财务突破选股公式-创幻闲云孤鹤-通信达专用}

  年认同价:=MA(C,240);

  价格中枢:=(SUM(年认同价,0)/(BARSSINCE(年认同价》0)+239));

  箱顶:=价格中枢*1.2;

  箱底:=价格中枢*0.8;

  毛利润率:=FINANCE(21)/FINANCE(20);

  成长价值:=年认同价*(1+毛利润率);

  收益价值:=年认同价+FINANCE(33);

  回调认同:=EMA(EXPMA(C,20),13);

  多头:=(回调认同》REF(回调认同,1))AND(成长价值》REF(成长价值,1))AND(收益价值》REF(收益价值,1))AND(DYNAINFO(7)》0);

  回调条件:=COUNT(C《回调认同,5)》=3;

  回调突破:=(REF(C,1)《=REF(回调认同,1))AND(C》回调认同)AND(回调条件)AND 多头;

  成长条件:=COUNT(C《成长价值,5)》=3;

  成长突破:=(REF(C,1)《=REF(成长价值,1))AND(C》成长价值)AND(成长条件)AND 多头;

  收益条件:=COUNT(C《收益价值,5)》=3;

  收益突破:=(REF(C,1)《=REF(收益价值,1))AND(C》收益价值)AND(收益条件)AND 多头;

  箱底条件:=COUNT(C《箱底,5)》=3;

  箱底突破:=(REF(C,1)《=REF(箱底,1))AND(C》箱底)AND(箱底条件)AND 多头;

  价格条件:=COUNT(C《价格中枢,5)》=3;

  价格突破:=(REF(C,1)《=REF(价格中枢,1))AND(C》价格中枢)AND(价格条件)AND 多头;

  箱顶条件:=COUNT(C《箱顶,5)》=3;

  箱顶突破:=(REF(C,1)《=REF(箱顶,1))AND(C》箱顶)AND(箱顶条件)AND 多头;

  突破买点:(回调突破+成长突破+收益突破+箱底突破+价格突破+箱顶突破);

  6.横盘是银

  VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  VAR2:=SMA(VAR1,3,1);

  VAR3:=SMA(VAR2,3,1);

  VAR4:=EMA(CLOSE,12)-EMA(CLOSE,26);

  VAR5:=EMA(VAR4,9);

  VAR6:=2*(VAR4-VAR5);

  COUNT(CROSS(VAR2,VAR3),2)》=1 AND COUNT(CROSS(VAR6,0),5)》=1 AND MA(CLOSE,5)》MA(CLOSE,10) AND MA(CLOSE,10)》MA(CLOSE,20) AND

  CLOSE》MA(CLOSE,5);

  {“短线是银”的使用说明:

  此组合选择比较简单,初学者易于掌握,短线有一定可操作性与准确性。但只适合于3天内的短线炒作,不能确定长期趋势

  选股设置:

  2日内KD金叉,5日内MACD金叉,均线5日,10日,20日多头排列,收盘价涨过5日均线。};

  7.黑马起步选股1

  VAR5:=EMA(SMA((CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100,8,1),3);

  选股:CROSS(VAR5,15) OR CROSS(VAR5,20) OR CROSS(VAR5,25);

  8.起攀选股

  {起攀选股}

  VAR6:=(2*C+H+L)/4;

  VAR7:=LLV(L,27);

  VAR8:=HHV(H,27);

  攀登:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13)-50;

  金山:=EMA(0.618*REF(攀登,1)+0.382*攀登,3);

  起攀:CROSS(攀登,金山) AND C/REF(C,1)》1.02;

  {根据起攀图指标改编,这是精简后的指标};

  9.中短波选股

  {中短波选股}

  HZ:=EMA(CLOSE,13);

  短波:=EMA(HZ,1);

  中波:=EMA(HZ,26);

  均线148天:=EMA(C,148);

  成本:=SUM(AMOUNT,0)/SUM(VOL,0)/100;

  HZ2:=EMA(HZ,8);

  CROSS(短波,HZ2);

  {结合中短波主图使用};

  10.黑马摇篮之大

  {黑马摇篮之大黑马}

  SS1:=(LOW+HIGH+CLOSE*2)/4;

  SS2:= MA(SS1,4);

  SS3:=HHV(SS2,10);

  SS4:=MA(SS3,3);

  SS5:=1.25*SS4-0.25*SS3;

  XKKJ:=IF(SS5》SS3,SS3,SS5);

  FF1:=LLV(SS2,10);

  FF2:=MA(FF1,3);

  FF3:=1.25*FF2-0.25*FF1;

  DKKJ:=IF(FF3《FF1,FF1,FF3);

  MA13:=MA(C,13);

  ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);

  ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);

  大黑马:ZDHM OR ZHM;

  11.黑马摇篮之小

  {黑马摇篮之小黑马}

  A:=(3*CLOSE+LOW+OPEN+HIGH)/6;

  D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)

  +13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)

  +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+

  REF(A,20))/211;

  D2:=EMA(D1,2);

  D3:=EMA(D2,2);

  K1:=EMA(D3,2);

  小黑马:CROSS(D1,K1);

  12.蓄势待发

  {蓄势待发}

  V0:=EMA(C,5);

  EMA10:=EMA(C,10);

  EMA20:=EMA(C,20);

  EMA30:=EMA(C,30);

  EMA60:=EMA(C,60);

  M1:=1000*EMA10/EMA60《=1015 AND 1000*EMA10/EMA60》=975;

  M2:=1000*EMA20/EMA60《=1020 AND 1000*EMA20/EMA60》=980;

  M3:=1000*EMA30/EMA60《=1015 AND 1000*EMA30/EMA60》=985;

  M4:=M1 AND M2 AND M3 AND CROSS(V0,EMA10);

  M5:=M1 AND M2 AND M3 AND CROSS(V0,EMA30);

  T1:=1000*EMA10/EMA30《=1010 AND 1000*EMA10/EMA30》=990;

  T2:=1000*EMA20/EMA30《=1010 AND 1000*EMA20/EMA30》=990;

  T3:=T1 AND T2 AND CROSS(V0,EMA10);

  T4:=T1 AND T2 AND CROSS(V0,EMA30);

  M4 OR M5 OR T3 OR T4;

  13.四线粘合

  {四线粘合}

  V0:=EMA(C,5);

  V1:=EMA(C,10);

  V2:=EMA(C,15);

  V3:=EMA(C,30);

  V4:=EMA(C,60);

  M1:=1000*V1/V4《=1015 AND 1000*V1/V4》=975;

  M2:=1000*V2/V4《=1020 AND 1000*V2/V4》=980;

  M3:=1000*V3/V4《=1015 AND 1000*V3/V4》=985;

  M4:=M1 AND M2 AND M3 AND CROSS(V0,V1);

  M5:=M1 AND M2 AND M3 AND CROSS(V0,V3);

  M4 OR M5;

  14.拉升在即

  {拉升在即}

  ABV:=MA(SUM(IF(CLOSE》REF(CLOSE,1),VOL,IF(CLOSE《REF(CLOSE,1),-VOL,0)),0)/25000,2);

  M1:=EMA(ABV,12);

  M2:=EMA(ABV,26);

  MTM:=CLOSE-REF(CLOSE,1);

  MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));

  MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));

  MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));

  A:=((VOL)/(CAPITAL))*(100);

  S:=((MA(A,30))/(MA(INDEXA,10)))*(MA(INDEXA,60));

  Y:=((MA(A,120))/(MA(INDEXA,10)))*(MA(INDEXA,60));

  X:=1;

  拉升在即:S《X AND Y《X AND MMS》MML AND ABV》M1 AND CROSS(S,Y);

  15.HMYZ黑马易找

  VAR1:=MA(CLOSE,5);

  VAR2:=MA(CLOSE,10);

  VAR3:=MA(CLOSE,30);

  VAR4:=MA(CLOSE,60);

  VAR5:=EMA(COST(85),7);

  VAR6:=EMA(COST(15),7);

  VAR7:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);

  VAR8:=INTPART(VAR7*100)/100;

  VAR9:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);

  VARA:=INTPART(VAR9*100)/100;

  VARB:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);

  VARC:=INTPART(VARB*100)/100;

  VARD:=EMA(CLOSE,5)-EMA(CLOSE,10);

  VARE:=EMA(VARD,9);

  VARF:=(-100)*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;

  VAR10:=(-100)*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;

  VAR11:=(-100)*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;

  VAR12:=(-100)*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;

  VAR13:=REF(VARE,1);

  VAR14:=VARE;

  VAR15:=VAR14-VAR13;

  VAR16:=REF(VARD,1);

  VAR17:=VARD;

  VAR18:=VAR17-VAR16;

  VAR19:=OPEN;

  VAR1A:=CLOSE;

  黑马易找选股: VAR19《=VAR1 AND VAR19《=VAR2 AND VAR19《=VAR3 AND VAR1A》=VAR1 AND VAR1A》=VARC AND VAR15》0 AND VAR18》0;

  16.黑马起步选股2

  VAR5:=EMA(SMA((CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100,8,1),3);

  选股:CROSS(VAR5,30) OR CROSS(VAR5,35) OR CROSS(VAR5,40);

  17.黑马起步选股1

  VAR5:=EMA(SMA((CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100,8,1),3);

  选股:CROSS(VAR5,15) OR CROSS(VAR5,20) OR CROSS(VAR5,25);

  二。主图指标

  三。三线买卖

  快线:EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK2,COLOR0000FF;

  慢线:EMA(REF(快线,1),2),LINETHICK2,COLOR00FFFF;

  总趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,55),2),2),2),2),LINETHICK2,COLORFF00FF;

  HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;

  AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);

  QY:=BACKSET(AA,HIGHN+1);

  CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);

  DRAWICON(CC,H*1.02,2);

  DDD:=BARSLAST(CC);

  GDTS:=IF(CC,CURRBARSCOUNT,0);

  DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}

  DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

  DINGBU1:=REF(DINGBU,DDD+1);

  GDCS1:=CONST(DINGBUTS);

  DINGBUTS1:=REF(DINGBUTS,DDD+1);

  GDCS2:=CONST(DINGBUTS1);

  DINGBU2:=REF(DINGBU1,DDD+1);

  MM:=IF(CURRBARSCOUNT》GDCS2,0,1);

  高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;

  DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;

  DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;

  AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);

  QY1:=BACKSET(AA1,LOWN+1);

  CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);

  DRAWICON(CC1,L*0.98,1);

  DD1:=BARSLAST(CC1);

  DDTS:=IF(CC1,CURRBARSCOUNT,0);

  YDB:=IF(DD1,REF(L,DD1),L);

  DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

  DDCS1:=CONST(DDTS1);

  ZDB:=REF(YDB,DD1+1);

  DDTS2:=REF(DDTS1,DD1+1);

  DDCS2:=CONST(DDTS2);

  低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;

  ZGSTAR:=(高点压力+低点支撑)/2;

  ZGEND:=CONST((高点压力+低点支撑)/2);

  STARDAY:=IF(DDCS2《GDCS2,DDCS2,GDCS2);

  中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK2;

  DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT,;

  DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;

  四。3线粘合

  MA3:EMA(C,3),linethick2; MA5:EMA(C,5),linethick2; MA7:EMA(C,7),linethick2; MA14:EMA(C,14),linethick1,STICK; MA114:EMA

  (C,14),linethick2; DRAWICON (cross(MA3,MA7),L*0.985,1);

  五。三线乾坤

  快线:EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK2,COLOR0000FF;

  慢线:EMA(REF(快线,1),2),LINETHICK2,COLOR00FFFF;

  总趋势:EMA(EMA(EMA(EMA(EMA(CLOSE,55),2),2),2),2),LINETHICK2,COLORFF00FF;

  A1:=REF(H,8)=HHV(H,2*8+1);

  B1:=FILTER(A1,8);

  C1:=BACKSET(B1,8+1);

  D1:=FILTER(C1,8);{高点}

  R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11》REF(R11,1);

  DRAWLINE(D1,H,S11,H,1),COLORBLUE;

  A2:=REF(L,8)=LLV(L,2*8+1);

  B2:=FILTER(A2,8);

  C2:=BACKSET(B2,8+1);

  D2:=FILTER(C2,8);{低点}

  T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11》REF(T11,1);

  DRAWLINE(D2,L,U11,L,1),COLORBLUE;

  M:=INTPART(3*8/5);

  A12:=REF(H,M)=HHV(H,2*M+1);

  B12:=FILTER(A12,M);

  C12:=BACKSET(B12,M+1);

  D12:=FILTER(C12,M);{高点}

  R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112》REF(R112,1);

  DRAWLINE(D12,H,S112,H,1),COLORRED;

  A22:=REF(L,M)=LLV(L,2*M+1);

  B22:=FILTER(A22,M);

  C22:=BACKSET(B22,M+1);

  D22:=FILTER(C22,M);{低点}

  T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112》REF(T112,1);

  DRAWLINE(D22,L,U112,L,1),COLORRED;

  VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);

  VAR2222:=CROSS(VAR1111,0.9);

  VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);

  VAR4444:=CROSS(VAR3333,0.9);

  压力:= REF(HIGH,BARSLAST(VAR2222));

  STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST(VAR2222)),0.5,1),COLOREA91B5,LINETHICK3;

  支撑:= REF(LOW,BARSLAST(VAR4444));

  STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4444)),REF(LOW,BARSLAST(VAR4444)),0.5,1),COLOR00B4FF,LINETHICK3;

  下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);

  RRRSV:=SMA(下档线,3,1);

  KKK:=SMA(RRRSV,3,1);

  DDD:=((3 * RRRSV) - (2 * KKK));

  JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);

  RSV24:=SMA(JJ12,3,1);

  K24:=SMA(RSV24,3,1);

  D24:=((3 * RSV24) - (2 * K24));

  压力2:=IF(CROSS(D24,DDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD)))),COLORFFFFFF;

  底部:=LLV(HIGH,30),COLOR00FF00;

  DRAWICON(L《=支撑 AND H》支撑,L,0);

  DRAWICON(H》=压力 AND L《压力,H,0);

  DRAWICON(CROSS(快线,慢线),L*0.95,5);

  DRAWICON(CROSS(慢线,快线),H*1.05,6);

  三。副图指标

  1。黄金坑

  DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);

  DEA:=EMA(DIFF,M);

  MACD2:=2*(DIFF-DEA);

  (CLOSE《0 AND CROSS(DIFF,0),H*1.3),COLOR000080,NODRAW;

  (CLOSE《0 AND CROSS(MACD2,0),H*1.3),COLOR000080,NODRAW;

  (CLOSE《0 AND CROSS(0,DIFF),H*1.3),COLOR808080,NODRAW;

  (CLOSE《0 AND CROSS(0,MACD2),H*1.3),COLOR808080,NODRAW;

  DU0:=CROSS(DIFF,0);

  UD0:=CROSS(0,DIFF);

  TDU0:=BARSLAST(DU0);

  TUD0:=BARSLAST(UD0);

  DU3:=REF(DU0,1);

  UD3:=REF(UD0,1);

  TDU3:=BARSLAST(DU3);

  TUD3:=BARSLAST(UD3);

  UDGLINE:=IF(TDU3《TUD3,REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));

  JDU0:=REF(CLOSE,1)《=REF(UDGLINE,1) AND CLOSE》UDGLINE AND TDU0《TUD0;

  JUD0:=REF(CLOSE,1)》=REF(UDGLINE,1) AND CLOSE《UDGLINE AND TUD0《TDU0;

  JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;

  JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;

  JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)《REF(BARSLAST(JDU1),1);

  JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)》REF(BARSLAST(JDU1),1);

  JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)》REF(BARSLAST(JDU1),1);

  JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)《REF(BARSLAST(JDU1),1);

  BSLINE:=IF(BARSLAST(JDU2)《BARSLAST(JUD2),IF(REF(CROSS(0,MACD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS

  (0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));

  STICKLINE(MACD2》=0,0,MACD2,2,1),COLOR0000FF;

  STICKLINE(MACD2》=0 AND MACD2《REF(MACD2,1),0,MACD2,2,0),COLOR0000FF;

  STICKLINE(MACD2《0,0,MACD2,2,0),COLORFFFF00;

  STICKLINE(MACD2《0 AND MACD2》REF(MACD2,1),0,MACD2,2,1),COLORFFFF00;

  DIF:DIFF,LINETHICK2,COLOR0000FF;

  MACD:DEA,COLORFF0000;

  DEF:MACD2,LINETHICK0,COLORFFFF00;

  STICKLINE(CLOSE》0,0,0,2,0),COLOR808080;

  DEFUT:=BARSLAST(CROSS(MACD2,0));

  DEFDT:=BARSLAST(CROSS(0,MACD2));

  DEFUL:=IF(MACD2》=0,HHV(MACD2,DEFUT+1),REF(HHV(MACD2,DEFUT+1),DEFDT+1));

  DEFDL:=IF(MACD2《0,LLV(MACD2,DEFDT+1),REF(LLV(MACD2,DEFDT+1),DEFUT+1));

  DEFU2L:=REF(DEFUL,DEFUT+1);

  DEFD2L:=REF(DEFDL,DEFDT+1);

  DRAWICON(LLV(MACD2,4)》0 AND MACD2《REF(MACD2,1) AND REF(MACD2,1)》REF(MACD2,2) AND REF(MACD2,2)》REF(MACD2,3),MACD2,2);

  DRAWICON(HHV(MACD2,4)《0 AND MACD2》REF(MACD2,1) AND REF(MACD2,1)《REF(MACD2,2) AND REF(MACD2,2)《REF(MACD2,3),MACD2,1);

  DRAWICON((JUD1 OR BARSLAST(JDU1)》BARSLAST(JUD1)) AND MACD2》=0 AND REF(MACD2,1)《REF(DEFU2L,1) AND MACD2》DEFU2L,MACD2,5);

  DRAWICON((JDU1 OR BARSLAST(JDU1)《BARSLAST(JUD1)) AND MACD2《0 AND REF(MACD2,1)》REF(DEFD2L,1) AND MACD2《DEFD2L,MACD2,3);

  VAR111:=JDU1 OR BARSLAST(JDU1)《BARSLAST(JUD1);

  VAR112:=HHV(MACD2,4)《0 AND MACD2》REF(MACD2,1) AND REF(MACD2,1)《REF(MACD2,2) AND REF(MACD2,2)《REF(MACD2,3);

  2.资金流向

  DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);

  DEA:=EMA(DIFF,M);

  MACD2:=2*(DIFF-DEA);

  (CLOSE《0 AND CROSS(DIFF,0),H*1.3),COLOR000080,NODRAW;

  (CLOSE《0 AND CROSS(MACD2,0),H*1.3),COLOR000080,NODRAW;

  (CLOSE《0 AND CROSS(0,DIFF),H*1.3),COLOR808080,NODRAW;

  (CLOSE《0 AND CROSS(0,MACD2),H*1.3),COLOR808080,NODRAW;

  DU0:=CROSS(DIFF,0);

  UD0:=CROSS(0,DIFF);

  TDU0:=BARSLAST(DU0);

  TUD0:=BARSLAST(UD0);

  DU3:=REF(DU0,1);

  UD3:=REF(UD0,1);

  TDU3:=BARSLAST(DU3);

  TUD3:=BARSLAST(UD3);

  UDGLINE:=IF(TDU3《TUD3,REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));

  JDU0:=REF(CLOSE,1)《=REF(UDGLINE,1) AND CLOSE》UDGLINE AND TDU0《TUD0;

  JUD0:=REF(CLOSE,1)》=REF(UDGLINE,1) AND CLOSE《UDGLINE AND TUD0《TDU0;

  JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;

  JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;

  JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)《REF(BARSLAST(JDU1),1);

  JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)》REF(BARSLAST(JDU1),1);

  JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)》REF(BARSLAST(JDU1),1);

  JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)《REF(BARSLAST(JDU1),1);

  BSLINE:=IF(BARSLAST(JDU2)《BARSLAST(JUD2),IF(REF(CROSS(0,MACD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS

  (0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));

  STICKLINE(MACD2》=0,0,MACD2,2,1),COLOR0000FF;

  STICKLINE(MACD2》=0 AND MACD2《REF(MACD2,1),0,MACD2,2,0),COLOR0000FF;

  STICKLINE(MACD2《0,0,MACD2,2,0),COLORFFFF00;

  STICKLINE(MACD2《0 AND MACD2》REF(MACD2,1),0,MACD2,2,1),COLORFFFF00;

  DIF:DIFF,LINETHICK2,COLOR0000FF;

  MACD:DEA,COLORFF0000;

  DEF:MACD2,LINETHICK0,COLORFFFF00;

  STICKLINE(CLOSE》0,0,0,2,0),COLOR808080;

  DEFUT:=BARSLAST(CROSS(MACD2,0));

  DEFDT:=BARSLAST(CROSS(0,MACD2));

  DEFUL:=IF(MACD2》=0,HHV(MACD2,DEFUT+1),REF(HHV(MACD2,DEFUT+1),DEFDT+1));

  DEFDL:=IF(MACD2《0,LLV(MACD2,DEFDT+1),REF(LLV(MACD2,DEFDT+1),DEFUT+1));

  DEFU2L:=REF(DEFUL,DEFUT+1);

  DEFD2L:=REF(DEFDL,DEFDT+1);

  DRAWICON(LLV(MACD2,4)》0 AND MACD2《REF(MACD2,1) AND REF(MACD2,1)》REF(MACD2,2) AND REF(MACD2,2)》REF(MACD2,3),MACD2,2);

  DRAWICON(HHV(MACD2,4)《0 AND MACD2》REF(MACD2,1) AND REF(MACD2,1)《REF(MACD2,2) AND REF(MACD2,2)《REF(MACD2,3),MACD2,1);

  DRAWICON((JUD1 OR BARSLAST(JDU1)》BARSLAST(JUD1)) AND MACD2》=0 AND REF(MACD2,1)《REF(DEFU2L,1) AND MACD2》DEFU2L,MACD2,5);

  DRAWICON((JDU1 OR BARSLAST(JDU1)《BARSLAST(JUD1)) AND MACD2《0 AND REF(MACD2,1)》REF(DEFD2L,1) AND MACD2《DEFD2L,MACD2,3);

  VAR111:=JDU1 OR BARSLAST(JDU1)《BARSLAST(JUD1);

  VAR112:=HHV(MACD2,4)《0 AND MACD2》REF(MACD2,1) AND REF(MACD2,1)《REF(MACD2,2) AND REF(MACD2,2)《REF(MACD2,3);

  3. 变色MACD

  (1)

  DIFIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);

  DEAEA1:=EMA(DIFIF1,9);

  MACD1:=2*(DIFIF1-DEAEA1),STICK;

  MACD2:=EMA(MACD1,3);

  STICKLINE(MACD1》MACD2 AND MACD1》0,0,MACD1,1,0),COLORRED;

  STICKLINE(MACD1》MACD2 AND MACD1《0,0,MACD1,1,0),COLORGREEN;

  STICKLINE(MACD1《MACD2,0,MACD1,1,0),COLORCBCBC0;

  STICKLINE(MACD1》=0 OR MACD1《=0,0,0,50,1),COLORWHITE;

  DIFIF1,COLOR33FF33,LINETHICK2;

  DEAEA1,COLORYELLOW,LINETHICK2;

  MACD:MACD1,NODRAW,COLORMAGENTA;

  强:IF(DIFIF1》=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;

  弱:IF(DEAEA1》=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2;

  DRAWICON(CROSS(DIFIF1,DEAEA1),DIFIF1+0.1,1);

  DRAWICON(CROSS(DEAEA1,DIFIF1),-0.5,2);

  DRAWTEXT(CROSS(DIFIF1,DEAEA1),DIFIF1,‘○’),LINETHICK2, COLORYELLOW;

  (2)

  DIFIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);

  DEAEA1:=EMA(DIFIF1,9);

  MACD1:=2*(DIFIF1-DEAEA1),STICK;

  MACD2:=EMA(MACD1,3);

  STICKLINE(MACD1》MACD2 AND MACD1》0,0,MACD1,1,0),COLORRED;

  STICKLINE(MACD1》MACD2 AND MACD1《0,0,MACD1,1,0),COLORGREEN;

  STICKLINE(MACD1《MACD2,0,MACD1,1,0),COLORCBCBC0;

  STICKLINE(MACD1》=0 OR MACD1《=0,0,0,50,1),COLORWHITE;

  DIFIF1,COLOR33FF33,LINETHICK2;

  DEAEA1,COLORYELLOW,LINETHICK2;

  MACD:MACD1,NODRAW,COLORMAGENTA;

  强:IF(DIFIF1》=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;

  弱:IF(DEAEA1》=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2;

  DRAWICON(CROSS(DIFIF1,DEAEA1),DIFIF1+0.1,1);

  DRAWICON(CROSS(DEAEA1,DIFIF1),-0.5,2);

  DRAWTEXT(CROSS(DIFIF1,DEAEA1),DIFIF1,‘○’),LINETHICK2, COLORYELLOW;

  4. 至尊MACD

  DIFF:EMA(DCLOSE,12)-EMA(DCLOSE,26);

  DEA:EMA(DIFF,9),COLORFFFF00;

  MACD:(DIFF-DEA)*2;

  STICKLINE(MACD》=0 AND MACD》=REF(MACD,1),0,MACD,1,0),COLORRED;

  STICKLINE(MACD》=0 AND MACD《=REF(MACD,1),0,MACD,1,0),COLORGREEN;

  STICKLINE(MACD《=0 AND MACD》=REF(MACD,1),0,MACD,1,0),COLORFF00FF;

  STICKLINE(MACD《=0 AND MACD《=REF(MACD,1),0,MACD,1,0),COLOR00FFFF;

  多转空:=((((LLV(MACD,4)》0) AND (MACD《REF(MACD,1))) AND (REF(MACD,1)》REF(MACD,2))) AND (REF(MACD,2)》REF(MACD,3)));

  空转多:=((((HHV(MACD,4)《0) AND (MACD》REF(MACD,1))) AND (REF(MACD,1)《REF(MACD,2))) AND (REF(MACD,2)《REF(MACD,3)));

  DRAWICON(多转空,MACD,2);

  DRAWICON(空转多,MACD,1);

  低位金叉:=CROSS(DIFF,DEA) AND DIFF《-0.1;

  DRAWTEXT(低位金叉,DEA,‘ 低位金叉’),COLORFF00FF;

  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA》=0));

  二次金叉:=CROSS(DIFF,DEA) AND DEA《0 AND COUNT(JCCOUNT=2,21)=1;

  STICKLINE(二次金叉,0,0.2,2,0),COLORFF00FF;

  DRAWTEXT(二次金叉,DEA*1.06,‘二次金叉’),COLORRED;

  A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

  底背离:=REF(CLOSE,A1+1)》CLOSE AND DIFF》REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

  DRAWTEXT(底背离,-0.2-MACD,‘底背离’),COLORWHITE;

  A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

  顶背离:=REF(CLOSE,A2+1)《CLOSE AND REF(DIFF,A2+1)》DIFF AND CROSS(DEA,DIFF);

  DRAWTEXT(顶背离,0.2+MACD,‘顶背离’),COLORWHITE;

?


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top