最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 同花顺公式 > 今日同花顺股票公式:同花顺 MACD底背离、金叉、二次金叉精美组

今日同花顺股票公式:同花顺 MACD底背离、金叉、二次金叉精美组

来源:网络 点击: 时间:2019-02-10

www.igojr.com带来今日同花顺股票公式:同花顺 MACD底背离、金叉、二次金叉精美组合及二次金叉选股公式(源码)。

  (二)同花顺 MACD底背离、金叉、二次金叉精美组合及二次金叉选股公式(源码)

  DIFF: EMA(CLOSE,8) - EMA(CLOSE,13),colorwhite;

  DEA: EMA(DIFF,9),coloryellow;

  MACD: 2*(DIFF-DEA), COLORSTICK;

  STICKLINE(MACD《REF(MACD,1)AND MACD》0,0,MACD,0,0),coloryellow;

  STICKLINE(MACD》REF(MACD,1)AND MACD《0,0,MACD,0,0),colorgreen;

  低位金叉:=CROSS(DIFF,DEA) AND DIFF《-0.1;

  STICKLINE(低位金叉,0,0.08,6,0),coloryellow;

  DRAWTEXT(低位金叉,0.16,‘ 低金叉’),colorwhite;

  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA》=0));

  二次金叉:=CROSS(DIFF,DEA) AND DEA《0 AND COUNT(JCCOUNT=2,21)=1;

  STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;

  DRAWICON(二次金叉,DEA*0.9,1) ;

  DRAWTEXT(二次金叉,0.2,‘ 二次金叉’),coloryellow;

  A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

  底背离:=REF(CLOSE,A1+1)》CLOSE AND DIFF》REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

  STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

  底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,LINETHICK4;

  DRAWTEXT(底背离,0.12,‘ 底背离’),COLORFF00FF;

  A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

  顶背离:=REF(CLOSE,A2+1)《CLOSE AND REF(DIFF,A2+1)》DIFF AND CROSS(DEA,DIFF);

  顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,LINETHICK4;

  DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,‘三全项’),COLOR0000FF,LINETHICK2;

  IF(DIFF《0,DIFF,0),colorred,LINETHICK1;

  IF(DIFF《0,0,DIFF),colorred,LINETHICK1;

  IF(DIFF《DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;

  IF(DIFF》DEA,DEA,DEA),colorwhite,LINETHICK1;

  金叉:=CROSS(DIFF,DEA) AND DIFF《0.3;

  DIFF:=EMA(CLOSE,8) - EMA(CLOSE,13);

  DEA:=EMA(DIFF,9);

  MACD:=2*(DIFF-DEA);

  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA》=0));

  二次金叉:CROSS(DIFF,DEA) AND DEA《0 AND COUNT(JCCOUNT=2,21)=1;

  更多同花顺股票公式,请关注www.igojr.com。


标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top