最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 指标知识 > 青龙白虎指标的使用方法及源码分享

青龙白虎指标的使用方法及源码分享

来源:网络 点击: 时间:2019-02-28
青龙白虎其实是天体星象的名称,在风水上它是用来进行定位的,而有投资者根据就以此为名称设立了一个指标,所以这也是青龙白虎指标的产生。那究竟青龙白虎指标的使用方法是怎么样的?今天赢家学院的主编老师就为大家进行简单的介绍。

  一、认识

  青龙白虎指标是什么?它指标可以给投资者看到抄底的时机以及卖出的时机。在每一次时机出现的时候,就会有相关的提示出现。所以在使用上是非常简单的。

  二、使用方法

  当股价开始迎来大底的时候,不回西安蓝色长柱并有青龙出海的字样,在呢就意味着股票在近期不就就会开始进行大举的反攻,要注意的是小心庄家多数会再次挖坑后才反弹,要与黄色向上的箭头配合使用,蓝柱后一般等到向上的黄箭头出现并有“买点”字样的时候,既是安全的抄底点位,如下图所示。

青龙白虎指标.jpg

  当黄色向上箭头买点出现的前后,一般有红色或紫色箭头出现,或淡红色短柱出现,表示在此处根据情况可以多次加仓。

  零轴下绿色网格表示庄家的建仓区,股友不要轻易碰触这个区域,庄建仓后会有紫色小箭头出现,表示建仓完毕。当股票被套初期见到绿色网格,必是割肉走人!

  零轴上红色网格表示庄的拉升区,股友可以随庄的趋势吃肉喝汤,拉升结束时会出现向下的橙黄色箭头,此时是股票的阶段顶部,需要轻仓或空仓。

  在股票的一波拉升后会有回调,若此阶段出现多个白色长柱,我给它起名叫“白虎出山”,一定要紧盯庄的举动,此后不久庄家极有可能会是一波更猛烈的拉升过程,但是股友要谨慎:白色长柱风险巨大,也许是庄家大量出货的阶段,利益与风险并存,白虎出山能得到巨大利益,但也会伤人。股友能否赚的个满钵,看这次的把握。

  当黄色买点出现后不久,若出现紫色向上的大箭头,表明有大机构参与,股友可放心一搏。当出现密集的白色短柱时,表示有大量的散户跟风,或者是敢死队的游资在参与,股价会一路上扬。

  当有白色的网格出现时,既是到了阶段顶部,可能有回调需要。

  指标里不时会出现金手指,大黑马,主力,做底,蓝色小箭头,绿色小箭头,红色小柱,蓝色小柱等指示。

  三、公式源码

  N1:=14;{N1: 5, 250, 14}

  VAR4C:=MA(CLOSE,5);

  VAR5C:=MA(CLOSE,10);

  VAR6C:=MA(CLOSE,30);

  VAREC:=(SUM(((CLOSE * VOL) * 100),28) / SUM((VOL * 100),28));

  VARFC:=(INTPART((VAREC * 100)) / 100);

  短线趋势:=(EMA(CLOSE,5) - EMA(CLOSE,10));

  中线趋势:=EMA(短线趋势,9);

  VAR14C:=REF(中线趋势,1);

  VAR15C:=中线趋势;

  VAR16C:=(VAR15C - VAR14C);

  VAR17C:=REF(短线趋势,1);

  VAR18C:=短线趋势;

  VAR19C:=(VAR18C - VAR17C);

  发现机构:IF((((((((OPEN <= VAR4C) AND (OPEN <= VAR5C)) AND (OPEN <= VAR6C)) AND

  (CLOSE >= VAR4C)) AND (CLOSE >= VARFC)) AND (VAR16C > 0)) AND (VAR19C > 0)),95,0),

  LINETHICK3,COLORFF00FF;

  -15;

  VAR91:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;

  VAR92:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;

  VAR93:=SMA(VAR92,2,1);

  天C:=100+(-ABS(VAR91));

  下:=SMA(VAR93,2,1);

  无:=ABS(VAR91);

  买:STICKLINE(CROSS(下,无),15,30,2,0),COLORLIRED,LINETHICK1;

  卖:STICKLINE(CROSS(下,天C),80,99,2,0),COLORFF9900,LINETHICK1;

  DRAWICON((CROSS(下,20) ),-10,11);

  FG:=MA(C,60);

  HI:=100*(C-REF(C,60))/REF(C,60);

  HJ:=100*(INDEXC-REF(INDEXC,60))/REF(INDEXC,60);

  HK:=SMA(HI-HJ,2,1);

  HM:=V>REF(V,1)*3;

  HO:=HM AND (C

  DRAWICON(HO,HK+40,5),COLORWHITE;

  A11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-

  2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

  黑马线:=EMA(A11,5);

  A41:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

  趋势线:=(MA(3*SMA(A41,6,1)-2*SMA(SMA(A41,5,1),5,1),2));

  DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,-10,'↖大黑马 '),COLORFFFF00;

  VAR1F:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);

  VAR20:=REVERSE(VAR1F);

  VAR21:=SMA(VAR1F,3,1);

  趋势:=SMA(VAR21,3,1);

  人气:=SMA(趋势,3,1);

  AA:=LLV(LOW,36);

  BB:=HHV(HIGH,30);

  DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);

  出击:=IF(CROSS(趋势,人气) AND (趋势<30),30,0),COLOR0000FF,LINETHICK2;

  必卖:IF(CROSS(人气,趋势) AND (人气>68),85,100),COLORBLUE,LINETHICK2;

  短卖:IF(CROSS(趋势,DD) AND (DD>73),75,100),COLOR008000,LINETHICK1;

  顶:=85;

  VAR5W:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

  CCS:=SMA(VAR5W,13,1);

  CC1S:=SMA(CCS,5,1);

  出击O:IF((CROSS(CCS,CC1S) AND (CC1S < 顶) ),40,0),COLORRED;

  VAR81:=100 - (3)*(SMA(((CLOSE - LLV(LOW,75))/(HHV(HIGH,75) - LLV(LOW,75)))*(100),20,1))

  + (2)*(SMA(SMA(((CLOSE - LLV(LOW,75))/(HHV(HIGH,75) - LLV(LOW,75)))*(100),20,1),15,1));

  VAR82:=100 - (3)*(SMA(((OPEN - LLV(LOW,75))/(HHV(HIGH,75) - LLV(LOW,75)))*(100),20,1))

  + (2)*(SMA(SMA(((OPEN - LLV(LOW,75))/(HHV(HIGH,75) - LLV(LOW,75)))*(100),20,1),15,1));

  VAR83:=(VAR81 < REF(VAR82,1)) AND (VOL > REF(VOL,1)) AND (CLOSE > REF(CLOSE,1));

  有主力:IF(VAR83 AND (COUNT(VAR83,24) = 1),60,0),LINETHICK1,COLORFF00FF;

  DRAWTEXT((有主力 =60),55,'主力'),COLORFF00FF;

  短趋势:=((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-

  2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50);

  VAR2:=(2*CLOSE+HIGH+LOW+OPEN)/5;

  VAR3:=LLV(LOW,34);

  VAR4:=HHV(HIGH,34);

  长趋势:=EMA((VAR2-VAR3)/(VAR4-VAR3)*100,13);

  VAR7:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;

  附属:=SMA(VAR7,5,1);

  白金:=SMA(附属,10,1);

  庄加仓后有买点:IF(CROSS(附属,白金) AND 附属<40,85,0),COLORYELLOW,LINETHICK2;

  DRAWTEXT(CROSS(附属,白金) AND 附属<40,50,'↑买点'),COLORYELLOW,LINETHICK1;

  QW1:=(HIGH+LOW+CLOSE*2)/4;

  QW3:=EMA(QW1,10);

  QW4:=STD(QW1,10);

  QW5:=(QW1-QW3)*100/QW4;

  QW6:=EMA(QW5,5);

  RK7:=EMA(QW6,10);

  涨:=EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;

  跌:=EMA(涨,4),LINETHICK1,COLORFFFF34;

  做多:=IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK3,COLORFF00FF;

  做空:IF(CROSS(跌,80),70,100),COLOR0099FF,LINETHICK3;

  DRAWICON(做多,30,1),COLORFF00FF;

  DRAWICON(CROSS(跌,80),70,2),COLORGREEN;

  VAR18T:=HHV(HIGH,30);

  VAR19T:=LLV(LOW,30);

  NL:=EMA((CLOSE-VAR19T)/(VAR18T-VAR19T)*100,5)/8*10,COLORYELLOW,LINETHICK2;

  DRAWTEXT(CROSS(5,NL),30,'★做底'),COLORWHITE;

  VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);

  神奇线:= MA((CLOSE-VAR2Q)/VAR2Q,2);

  买12:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012 AND ((C-REF(C,2))/C)>0.06,60,0),COLORWHITE,LINETHICK2;

  YY:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);

  YT:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);

  ST:=IF(CROSS(YT,YY),30,0);

  VAR5PT:=(HIGH+LOW+CLOSE)/3;

  VAR6PT:=(VAR5PT-MA(VAR5PT,14))/(0.015*AVEDEV(VAR5PT,14));

  VAR7PT:=(VAR5PT-MA(VAR5PT,85))/(0.015*AVEDEV(VAR5PT,85));

  SA:=IF(VAR7PT>=200 AND VAR6PT>=150,10,0);

  VAR3QQ:=REF(CLOSE,1);

  VAR4QQ:=SMA(MAX(CLOSE-VAR3QQ,0),6,1)/SMA(ABS(CLOSE-VAR3QQ),6,1)*100;

  SM:=IF(CROSS(80,VAR4QQ),100,0);

  卖11:IF((SM AND (SA OR ST)),70,100),COLORCCCC33,LINETHICK2;

  HII:=100*(C-REF(C,60))/REF(C,60);

  丰盛:IF(((COUNT(C>O,10)>=8) OR (COUNT(C>O,15)>=12)) AND HII<100,20,0),COLORFF00FF,LINETHICK1;

  FC:=MA(C,3);FD:=MA(C,10);

  FE:=MA(C,20);FF:=MA(C,30);FG1:=MA(C,60);

  FH:=ABS(FC-FD)/MIN(FC,FD);FI:=ABS(FC-FE)/MIN(FC,FE);

  FJ:=ABS(FC-FF)/MIN(FC,FF);

  FK:=ABS(FE-FD)/MIN(FE,FD);FL:=ABS(FF-FD)/MIN(FF,FD);

  FM:=ABS(FE-FF)/MIN(FE,FF);

  FN:=MAX(MAX(MAX(FH,FI),MAX(FJ,FK)),MAX(FL,FM))*100,LINETHICK2;

  FO:=EMA(FN,3),COLORBLUE;

  FS:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

  FT:=(SMA(FS,3,1)-18)*1.55;

  FV:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;

  FW:=SMA(FV,10,1);

  GJ:=(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5))*(-1)+0.9;

  GK:=(HHV(H,10)-C)/(HHV(H,10)-LLV(L,10))*(-1)+0.92;

  GL:=(HHV(H,15)-C)/(HHV(H,15)-LLV(L,15))*(-1)+0.93;

  GM:=(HHV(H,55)-C)/(HHV(H,55)-LLV(L,55))*(-1)+0.94;

  GN:=(HHV(H,89)-C)/(HHV(H,89)-LLV(L,89))*(-1)+0.95;

  GO:=(HHV(H,120)-C)/(HHV(H,120)-LLV(L,120))*(-1)+0.91;

  SP:=(HHV(H,180)-C)/(HHV(H,180)-LLV(L,180))*(-1)+0.96;

  SQ:=(((GJ+GK+GL)*8+GM+GN+SP+GO)/28-0.1)*185;

  GR:=SMA(SQ,3,1);

  GS:=(FT+FW+GR*2)/4,COLOR00FFFF ;

  白虎出山:IF(FO<8 AND GS>95,GS,0),STICK,LINETHICK3,COLORFFFFFF;

  {N1:5,250,14;}

  K1:=N1/2;

  DTPL:=MA(C,N1)>MA(C,N1*1.5) AND MA(C,N1*1.5)>MA(C,N1*3) AND MA(C,3)>MA(C,N1*6);

  连续走强:=COUNT(C>MA(C,N1),K1)=K1;

  ZQSJ:=BARSLAST(连续走强);

  STICKLINE(连续走强 ,0 ,K1*0.8 ,5 ,1 ),COLORRED;

  下穿:=CROSS(MA(C,N1),C);

  GLL:=MA(C,N1/2)/MA(C,N1*2)>=1.05;

  买跌:(下穿 AND ZQSJ<=3 AND DTPL AND GLL)*N1,COLOR00FF00,LINETHICK2;

  连续走弱:=COUNT(C

  ZRSJ:=BARSLAST(连续走弱);

  STICKLINE(连续走弱 ,0 ,K1*-0.8 ,5 ,1 ),COLOR00FF00;

  上穿:=CROSS(C,MA(C,N1));

  买涨:(上穿 AND ZRSJ<=3)*K1,COLORFF00FF,LINETHICK2;

  强:连续走强*K1*0.3,COLORRED;

  弱:连续走弱*K1*-0.3,COLOR00FF00;

  AAW1:=(EMA(CLOSE,12)-EMA(CLOSE,26))*(100)+50;

  AAW2:=EMA(AAW1,9);

  AAW3:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;

  AAW4:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);

  AAW5:=SMA(AAW4,13,8);

  走势1:=CEILING(SMA(AAW5,13,8)),COLOR00FF00;

  AAW6:=SMA(AAW3,21,8);

  卖观注:STICKLINE(走势1-AAW6>85,100,95,6,1),COLORFFFF00;

  卖出1:STICKLINE((LONGCROSS(AAW2,(AAW1)*(0.94999998),7) AND (AAW1>0)),100,80,1,0),COLOR0000FF;

  NN:=34;

  MM:=3;

  大盘生命指数:= EMA(100*(CLOSE-LLV(LOW,NN))/(HHV(HIGH,NN)-LLV(LOW,NN)),MM)/4;

  大盘生命量能:=IF(大盘生命指数>23.16,大盘生命指数,0);

  STICKLINE(大盘生命量能,100,70,1,1),COLORWHITE;

  VARFN:=LOW*0.9;

  VAR11N:=EMA(VARFN,30);

  VAR12N:=CLOSE-REF(CLOSE,1);

  VAR13N:=MAX(VAR12N,0);

  VAR14N:=ABS(VAR12N);

  VAR15N:=SMA(VAR13N,7,1)/SMA(VAR14N,7,1)*100;

  VAR16N:=SMA(VAR13N,13,1)/SMA(VAR14N,13,1)*100;

  VAR17N:=BARSCOUNT(CLOSE);

  VAR18N:=SMA(MAX(VAR12N,0),6,1)/SMA(ABS(VAR12N),6,1)*100;

  VAR19N:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;

  VAR1AN:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

  VAR1BN:=SMA((SMA(VAR1AN,4,1)-50)*2,3,1);

  VAR1CN:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

  VAR1DN:=SMA(VAR1CN,4,1);

  VAR1EN:=SMA(VAR1DN,3,1);

  VAR1FN:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

  VAR20N:=VAR18N<=25 AND VAR19N<-95 AND VAR1FN>20 AND VAR1BN<-30 AND VAR1EN<30

  AND VAR11N-CLOSE>=-0.25 AND VAR15N<22 AND VAR16N<28 AND VAR17N>50;

  STICKLINE(VAR20N,0,70,1,0),COLORBLUE,LINETHICK3 ;

  DRAWTEXT(VAR20N,80,'★青龙出海!'),COLORBLUE;

  青龙白虎指标的使用方法及源码分享就到这里,相信大家对此已经掌握了,如若您想要学习蜡烛图精解的知识点可点击进入,最后预祝大家投资愉快。

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top