最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 指标知识 > “一阳十线”指标的使用方法及源码讲解

“一阳十线”指标的使用方法及源码讲解

来源:网络 点击: 时间:2018-08-20
股票技术指标有很多,在赢家学院的很多栏目都有关于指标的学习,当然不同的软件有不同的指标公式,今天小编为大家带来的是“一阳十线”指标的使用方法及源码分享,希望能够对大家有所帮助。

  一、使用方法

  “一阳十线”指标如何使用?该指标的使用方法为:一阳穿十线(3日、5日、8日、10日、12日、35日、40日、45日、50日、60日大指数平滑移动平均线),显然它不是简单的移动平均线,而是EXPMEMA。该指标一共有两个指标提示,一是共振信号提示,二是买字信号提示,共振信号即一日同时上穿上述10条均线。

  买字信号则是一阳上穿3日、5日、8日、10日、12日这五条均线,当然这是一种短线操作的买点信号。那大家编写了选股指标,分别有三个,一个是“买”点信号提示选股、“共振”信号选股、“买”字信号和“共振”信号同时出现选股。如下图所示。

一阳穿十线.jpg

  二、指标源码

  “一阳十线”指标源码是怎么样的?相应的源码具体如下:

  1、“一阳十线”指标源码(主图):

  MA1:EXPMEMA(CLOSE,3);

  MA2:EXPMEMA(CLOSE,5);

  MA3:EXPMEMA(CLOSE,8);

  MA4:EXPMEMA(CLOSE,10);

  MA5:EXPMEMA(CLOSE,12);

  MA6:EXPMEMA(CLOSE,35);

  MA7:EXPMEMA(CLOSE,40);

  MA8:EXPMEMA(CLOSE,45);

  MA9:EXPMEMA(CLOSE,50);

  MA10:EXPMEMA(CLOSE,60);

  效果:=O<=MIN(MA1,MIN(MA2,MIN(MA3,MIN(MA4,MA5))))AND

  C>=MAX(MA1,MAX(MA2,MAX(MA3,MAX(MA4,MA5))));

  A01:=MIN(O,C);

  B01:=ABS(O-C);

  A02:=MAX(O,C);

  {公众号:股票量化研究所}

  DRAWTEXT(效果,L*0.99,'★买'),COLORYELLOW;

  STICKLINE(效果,A01,A01+B01/4,2.5,0),COLORMAGENTA;

  共振:=O<=MIN(MA1,MIN(MA2,MIN(MA3,MIN(MA4,MIN(MA5,MIN(MA6,MIN(MA7,MIN(MA8,

  MIN(MA9,MA10)))))))))AND C>=MAX(MA1,MAX(MA2,MAX(MA3,MAX(MA4,MAX(MA5,

  MAX(MA6,MAX(MA7,MAX(MA8,MAX(MA9,MA10)))))))));

  STICKLINE(共振,OPEN,CLOSE,2,0),COLORRED;

  DRAWTEXT(FILTER(共振=1,2),LOW-0.01,'↖共振'),COLORRED;

  2、“一阳十线”共振信号源码(选股):

  MA1:=EXPMEMA(CLOSE,3);

  MA2:=EXPMEMA(CLOSE,5);

  MA3:=EXPMEMA(CLOSE,8);

  MA4:=EXPMEMA(CLOSE,10);

  MA5:=EXPMEMA(CLOSE,12);

  MA6:=EXPMEMA(CLOSE,35);

  MA7:=EXPMEMA(CLOSE,40);

  MA8:=EXPMEMA(CLOSE,45);

  MA9:=EXPMEMA(CLOSE,50);

  MA10:=EXPMEMA(CLOSE,60);

  共振:O<=MIN(MA1,MIN(MA2,MIN(MA3,MIN(MA4,MIN(MA5,MIN(MA6,MIN(MA7,MIN(MA8,

  MIN(MA9,MA10)))))))))AND C>=MAX(MA1,MAX(MA2,MAX(MA3,MAX(MA4,MAX(MA5,

  MAX(MA6,MAX(MA7,MAX(MA8,MAX(MA9,MA10)))))))));

  3、“一阳十线”买字指标源码(选股):

  MA1:=EXPMEMA(CLOSE,3);

  MA2:=EXPMEMA(CLOSE,5);

  MA3:=EXPMEMA(CLOSE,8);

  MA4:=EXPMEMA(CLOSE,10);

  MA5:=EXPMEMA(CLOSE,12);

  MA6:=EXPMEMA(CLOSE,35);

  MA7:=EXPMEMA(CLOSE,40);

  MA8:=EXPMEMA(CLOSE,45);

  MA9:=EXPMEMA(CLOSE,50);

  MA10:=EXPMEMA(CLOSE,60);

  效果:O<=MIN(MA1,MIN(MA2,MIN(MA3,MIN(MA4,MA5))))AND

  C>=MAX(MA1,MAX(MA2,MAX(MA3,MAX(MA4,MA5))));

  4、“一阳十线”买字与共振信号同时出现指标源码(选股):

  MA1:=EXPMEMA(CLOSE,3);

  MA2:=EXPMEMA(CLOSE,5);

  MA3:=EXPMEMA(CLOSE,8);

  MA4:=EXPMEMA(CLOSE,10);

  MA5:=EXPMEMA(CLOSE,12);

  MA6:=EXPMEMA(CLOSE,35);

  MA7:=EXPMEMA(CLOSE,40);

  MA8:=EXPMEMA(CLOSE,45);

  MA9:=EXPMEMA(CLOSE,50);

  MA10:=EXPMEMA(CLOSE,60);

  效果:=O<=MIN(MA1,MIN(MA2,MIN(MA3,MIN(MA4,MA5))))AND

  C>=MAX(MA1,MAX(MA2,MAX(MA3,MAX(MA4,MA5))));

  共振:=O<=MIN(MA1,MIN(MA2,MIN(MA3,MIN(MA4,MIN(MA5,MIN(MA6,MIN(MA7,MIN(MA8,

  MIN(MA9,MA10)))))))))AND C>=MAX(MA1,MAX(MA2,MAX(MA3,MAX(MA4,MAX(MA5,

  MAX(MA6,MAX(MA7,MAX(MA8,MAX(MA9,MA10)))))))));

  XG:效果 AND 共振;

  “一阳十线”指标的使用方法及源码就到这里,相信带对此已经掌握了,如若您想要学习企业市场分析的知识点可点击进入,最后预祝大家投资愉快。

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top