最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 指标知识 > 八字操盘买卖主图指标公式解析(附源码)

八字操盘买卖主图指标公式解析(附源码)

来源:网络 点击: 时间:2019-05-21
股市投资的一举一动都会牵涉到资金的安全问题,同时也关系到盈利的多少,因此八字操盘是很多投资者信奉的准则,然而在实战中,八字操盘买卖怎样应用的,可以通过其买卖主图指标股票公式进行研究分析,下面我们通过早知道、八字主图、买卖主图公式进行研究分析。

  1、八字早知道指标公式

  我们知道在股市中,消息的重要性,而八字早知道指标就是从基本的消息与技术K线走势相结合进行研究的指标,其公式源码如下:

  R:=(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*-100;

  八字早知道:SMA(R,3,1),COLORRED;

  见红股票好:SMA(八字早知道,21,1);

  白色上升起:MA(八字早知道,10),COLORWHITE;

  绿色准备跑:MA(见红股票好,34),COLORLIGREEN;

  STICKLINE(白色上升起>绿色准备跑,白色上升起,绿色准备跑,3,0),COLORWHITE;

  STICKLINE(白色上升起<绿色准备跑,白色上升起,绿色准备跑,3,0),COLORYELLOW;

  STICKLINE(八字早知道<白色上升起,八字早知道,白色上升起,1,0),COLORGREEN;

  STICKLINE(八字早知道>白色上升起,八字早知道,白色上升起,1.5,0),COLORRED;

八字早知道指标

  从源码中的分析图可以看出,指标线的走势随着股价的走势进行变化,给出最低点的买入信号或者是最高点的卖出信号。

  2、八字主图指标公式

  A1:=(LOW+HIGH+CLOSE+OPEN)/4;

  A2:=EMA((EMA(A1,14.4)-EMA(A1,36)),6);

  A3:=((EMA(A1,14.4)-EMA(A1,36))-A2)*6;

  A4:=IF(A3>=1000 ,1000 ,IF(A3<=A1,A1,A3));

  八字主图:LLV((MA(A1,6)),36),COLORYELLOW,LINETHICK2;

  乾坤:EXPMEMA(OPEN,3),COLORGREEN;

  线起:IF(乾坤>REF(MA(乾坤,3),16),乾坤,DRAWNULL),COLORRED;

  A5:=COSTEX((FORCAST(FORCAST(A4,36),14.4)),REF(OPEN,1));

  成本:MA(A5,24),COLORLIBLUE;

  赢利:MA((COSTEX(OPEN,REF(OPEN,1))),16),COLORMAGENTA;

  STICKLINE(成本<赢利,成本,赢利,2,1),COLORWHITE;

  A6:=MA((COST(50)),14.4);

  STICKLINE((COST(50))>A6,(COST(50)),A6,0.2,0),COLORMAGENTA;

  八字:MA(乾坤,72),COLORWHITE,POINTDOT;

  财运好:MA((MA(乾坤,34)),144),COLORYELLOW,POINTDOT;

八字主图指标公式

  八字主图主要讲解的是成本与盈利的关系,帮助投资者从中了解基本的买卖点位置,并计算好操作盈利的位置。

  3、买卖主图指标公式

  EMA13:=EMA(C,13),COLORWHITE;

  EMA21:=EMA(C,21),COLORYELLOW;

  EMA34:=EMA(C,34),COLORFF00FF;

  A7:=(2*C+H+L)/4;

  八字买卖提示2:MA(A7,5),COLORWHITE;

  变色K线:MA(C,60),COLORYELLOW;

  X1:=(C+L+H)/3;

  X2:=EMA(X1,6);

  X3:=EMA(X2,5);

  STICKLINE(X2>X3 AND C>EMA13,LOW,HIGH,0.1,1),COLORWHITE;

  STICKLINE(X2>X3 AND C>EMA13,CLOSE,OPEN,3,1),COLORWHITE;

  STICKLINE(X2

  STICKLINE(X2

  GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5));

  GR2:=EMA13>EMA21 AND EMA21>EMA34 AND EMA13>REF(EMA13,1);

  GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);

  GR4:=H=HHV(H,GR1);

  GR5:="MACD.MACD"(9,17,8)

  GR6:=GR2 AND GR3 AND GR4;

  GR7:=GR2 AND GR3 AND GR4 AND GR5;

  GR8:=GR6 AND GR7;

  LC := REF(CLOSE,1);

  RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

  BIAS5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

  换手:=100*V/CAPITAL;

  BB13:=ATAN(EMA13-REF(EMA13,1))*3.1416*10;

  EMA8:=EMA(C,8);

  AA1:=AMOUNT/VOL;

  BB1:=L

  CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

  DD1:=L

  EE1:=VOL

  FF1:=BB1 AND CC1 AND DD1 AND EE1;

  DRAWTEXT(FF1,L*0.99,'买点'),COLORLIBLUE;

  STICKLINE(FF1,H,L,0.3,0),COLORLIBLUE;

  STICKLINE(FF1,O,C,3,1),LINETHICK2,COLORLIBLUE;

  A2:=(C-REF(C,1))/REF(C,1)*100<1.02;

  A3:=H>MA(C,5)*1.12;

  AA:= A2 AND A3;

  DRAWTEXT(AA,H*1.05,'卖点'),COLORMAGENTA;

  STICKLINE(AA,H,L,3,0),COLORMAGENTA;

八字买卖主图指标

  源码的介绍中,在图形指标线走势中,提示的买点和卖点的位置,帮助投资者从中了解基本的操作技巧。

  以上就是本文讲解的关于股市中八字操盘买卖指标的公式源码解析,如果您还想要了解更加专业的技术分析或者是指标走势,请点击boll指标详解,为您讲解通道型指标的应用技巧分析。

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top