最新更新 - 网站地图 - 手机版
您的当前位置:爱购股票学习网 > 股票公式 > 指标知识 > 能量CR组合+黄金CR股票技术指标公式解析

能量CR组合+黄金CR股票技术指标公式解析

来源:网络 点击: 时间:2019-05-24
在股市中研究的是K线的形态与股价的量能变化,而其量能是可以运用能量指标进行分析的,比如是能量CR指标的组合形态与黄金走势的股票技术指标公式,都是需要进行研究的分析的操作对象,下面就基本的指标源码公式进行分析。

  【能量CR指标】

  CR指标本身就是能量指标的代表,表现的是量能的走势变化,其指标的形态是又两根指标线组成的,但是其参数是可以进行调整的,而其基本的公式代码如下:

  N:=26;

  M1:=5;

  M2:=20;

  M3:=40;

  M4:=62;

  MID:=REF(HIGH+LOW,1)/2;

  CRR:=SUM(MAX(0,HIGH-MID),N)/SUM(MAX(0,MID-LOW),N)*100;

  RCC:=SUM(MIN(0,L-MID),N)/SUM(MIN(0,MID-H),N)*100;

  CR:if(CRR>200,200,CRR),COLORWHITE;

  RC:if(RCC>200,200,RCC),COLORCYAN;

  STICKLINE(CR<50 AND CR>20,40,50,8,0),COLORMAGENTA;

  STICKLINE(CR<40 AND CR>20,40,30,8,0),COLORYELLOW;

  STICKLINE(CR<30 AND CR>20,20,30,8,0),COLORRED;

  STICKLINE(RC<50 AND RC>20,180,170,8,0),COLORCYAN;

  STICKLINE(RC<40 AND RC>20,190,180,8,0),COLORBLUE;

  STICKLINE(RC<30 AND RC>20,200,190,8,0),COLORGREEN;

能量CR指标

  从指标的走势形态中,可以看出量能的指标走势是依据K线的走势进行变化的,其中在出现金叉形态的时候,是一个买入的操作信号,在出现死叉形态的时候是一个卖出的信号,对应的就是图中的买卖点位置。

  【黄金CR指标】

  黄金CR指标说的是能量指标CR在走势变化的形态中,具有不同的指标形态走势,因为其参数是可以进行修改的,比如是CR指标与均线的走势变化形态,具有不同的操作技巧,其基本的源码如下:

  MID:=REF(H+C,1)/2;

  CR:SUM(MAX(0,HIGH-MID),13)/SUM(MAX(0,MID-L),13)*233,COLORFFFFFF;

  MA1:REF(MA(CR,8),3),COLOR00FFFF;

  MA2:REF(MA(CR,13),5),COLORFF00FF;

  MA3:REF(MA(CR,21),8),COLOR00FF00;

  MA4:REF(MA(CR,34),13),COLOR0066CC;

CR指标

  从中可以看出在形态的走势变化中,能够发现其上涨的变化趋势是和股价的走势相似的,投资者可以依据在形态中的走势进行操作策略的变化。

  【CR组合指标】

  在组合的指标形态中,投资者可以看出在股市的走势变化中,CR指标可以发现攻击的操作形态和出击的操作形态,而且在形态的走势变化中,其基本的指标源码如下:

  N:=26;

  VAR1:=EMA(HHV(HIGH,500),21);

  VAR2:=EMA(HHV(HIGH,250),21);

  VAR3:=EMA(HHV(HIGH,90),21);

  VAR4:=EMA(LLV(LOW,500),21);

  VAR5:=EMA(LLV(LOW,250),21);

  VAR6:=EMA(LLV(LOW,90),21);

  VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);

  VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);

  VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);

  VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);

  VARB:=REF(LOW,1);

  VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;

  VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);

  VARE:=LLV(LOW,30);

  VARF:=HHV(VARD,30);

  VAR10:=IF(MA(CLOSE,58),1,0);

  MID:=REF(HIGH+LOW,1)/2;

  CR:SUM(MAX(0,HIGH-MID),N)/SUM(MAX(0,MID-LOW),N)*100,COLORWHITE;

  VAR12:=SUM(MAX(0,HIGH-MID),N)/SUM(MAX(0,MID-LOW),N)*100;

  VAR11:=EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;

  出击:IF(VAR12<60 AND VAR11>10,6000/VAR12,0),COLORRED;

  攻击:IF (VAR11>20,VAR11*3,0),COLORYELLOW;

CR组合

  以上就是本文讲解的关于CR指标的源码公式介绍,如果您还想要了解更多的股市指标公式请点击emv指标怎么用,帮助您相关的指标应用技巧。

标签:

    Copyright 2018- www.igojr.com 爱购股票学习网 版权所有 邮箱:terrylm@qq.com

    免责声名:本站所发表的内容仅用于学术交流和学习,内容所带来的一切后果均与本站无关。若您发现本站存在您非授权的原创作品,请第一时间联系本站删除!

    Top